• Wifi not working on some network


    @joekamprad
    Here the info requested:

    As I wrote above , I had similar problem with another Intel PC on Ubuntu ( it was a 2’ generation I5 I’m not sure about the wifi card in use there).
    This happened more than 1 year ago (and it is still happening on both the old pc and the new one) so I am not so confident in new kernel fixing this unless we create some proper bug report …

  • I suspect that wouldn’t be the issue for me since my wifi has never worked with that router, but might be the issue for the OP.

  • @postadelmaga

    Direct firmware load for iwlwifi-8000C-23.ucode failed with error -2
    

    Network controller: Intel Corporation Wireless 8260 (rev 3a)
    There is a firmware-BUG

  • This solution worked for me:

    http://r3dux.org/2017/01/how-to-fix-intel-8260-rev-3a-slow-rubbish-wireless-issues-in-linux/

    What I did:

    cd /lib/firmware
    sudo mv iwlwifi-8000C-22.ucode iwlwifi-8000C-22-ucode.renamed
    

    and rebooted. Firmware 21 is then used. It seems that firmware 22 is buggy. See https://bugzilla.kernel.org/show_bug.cgi?id=190831

  • @cribari, @joekamprad

    Although I have the same wifi card ( intel 8260 (rev 3a), I am not sure if those bugs are related because those bugs points to a recent problem with kernel 4.8 and 8260 card while my problem is related to 2 different wifi cart and it is not a recent problem … at the moment I can only make the above hypothesis since I cannot test the solution on the router with the issue.
    @matt
    Did you have chance to try the above solution ( rename firmware 22) ?
    http://r3dux.org/2017/01/how-to-fix-intel-8260-rev-3a-slow-rubbish-wireless-issues-in-linux/
    This link also state to disable Wifi n

  • @postadelmaga from your logs:
    [ 2.275101] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-8000C-24.ucode failed with error -2
    [ 2.275117] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-8000C-23.ucode failed with error -2

    1. Firmware load failure warnings are normal. The system tries to load the newest firmware first.
    2. Yes, I renamed firmware version 22 (as suggested in the link I provided) and the problem went away. Anyway, the most recent firmware update (version 20170217.12987ca-1) solved the problem for me. Firmware 22 now works as expected, at least for me.
    3. I did not disable wifi N. This is what I have in /etc/modprobe.d/iwlwifi.conf:
    options iwlwifi bt_coex_active=0 11n_disable=8
    
  • I have the same problem. Only for certain hotel wifis. connecting to my phone or home wifi is always fine. Also fine with some hotel wifis, but sometimes it just hangs and doesn’t connect.

wifi152 Posts 29Views 7370
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.