• A Small Number Of Niggling Issues


    I installed Antergos about a week ago and do like it very much so far. Nevertheless, I have had a small number of niggling issues which have prevented me from feeling in control of my operating system. The reason I am here is because I was not lucky enough to find solutions elsewhere. Please take a look and see if you can help. I have marked the items that don’t work or need attention with arrows.

    The item indicated below does not work whatsoever. My desktop just loads but doesn’t lock like it should.

    [img:hhvkvkux]http://i.imgur.com/1oPeQCJ.png[/img:hhvkvkux]

    Who/What are these other users? They have been there since installation.

    [img:hhvkvkux]http://i.imgur.com/VhIuQ0e.png[/img:hhvkvkux]

    The first marked item sounds worrisome. The second is because I uninstalled hspell as I really don’t need a Hebrew dictionary for spell checking. Why it is a dependency is beyond my comprehension. Is it possible to make this reminder go away?

    [img:hhvkvkux]http://i.imgur.com/5sBQsR1.png?1[/img:hhvkvkux]

    This has also been there since installation and neither the Antergos wiki nor the Arch wiki have an entry for Repacman. There’s obviously something wrong, but I don’t know what.

    [img:hhvkvkux]http://i.imgur.com/Y3Y1ZNQ.png[/img:hhvkvkux]

    [img:hhvkvkux]http://i.imgur.com/UYpMDCd.png[/img:hhvkvkux]

    I also have an issue with Grub. It takes longer to load than anything else. Why should Grub take 15 seconds to load when Antergos itself only takes 5 seconds on my SSD? It just says “Grub loading …” for what feels like ages, then boom, everything seems to fall into place.

    I thank you all in advance for any solutions you may provide.

  • I installed Antergos about a week ago and do like it very much so far. Nevertheless, I have had a small number of niggling issues which have prevented me from feeling in control of my operating system. The reason I am here is because I was not lucky enough to find solutions elsewhere. Please take a look and see if you can help. I have marked the items that don’t work or need attention with arrows.

    The item indicated below does not work whatsoever. My desktop just loads but doesn’t lock like it should.

    [img:hhvkvkux]http://i.imgur.com/1oPeQCJ.png[/img:hhvkvkux]

    Who/What are these other users? They have been there since installation.

    [img:hhvkvkux]http://i.imgur.com/VhIuQ0e.png[/img:hhvkvkux]

    The first marked item sounds worrisome. The second is because I uninstalled hspell as I really don’t need a Hebrew dictionary for spell checking. Why it is a dependency is beyond my comprehension. Is it possible to make this reminder go away?

    [img:hhvkvkux]http://i.imgur.com/5sBQsR1.png?1[/img:hhvkvkux]

    This has also been there since installation and neither the Antergos wiki nor the Arch wiki have an entry for Repacman. There’s obviously something wrong, but I don’t know what.

    [img:hhvkvkux]http://i.imgur.com/Y3Y1ZNQ.png[/img:hhvkvkux]

    [img:hhvkvkux]http://i.imgur.com/UYpMDCd.png[/img:hhvkvkux]

    I also have an issue with Grub. It takes longer to load than anything else. Why should Grub take 15 seconds to load when Antergos itself only takes 5 seconds on my SSD? It just says “Grub loading …” for what feels like ages, then boom, everything seems to fall into place.

    I thank you all in advance for any solutions you may provide.

  • @“FutureSuture”:2e5139sk said:

    The item indicated below does not work whatsoever. My desktop just loads but doesn’t lock like it should.[/quote:2e5139sk]KDM is not the default display manager for Antergos which is why those settings have no affect. Have you enabled KDM manually? If you are using the default (LightDM) I do not think it has a feature to lock the screen after autologin? I’m not 100% sure though.

    @“FutureSuture”:2e5139sk said:

    Who/What are these other users? They have been there since installation.[/quote:2e5139sk]I believe my answer to your first question has answered at least half of this one

    @“FutureSuture”:2e5139sk said:

    The first marked item sounds worrisome. The second is because I uninstalled hspell as I really don’t need a Hebrew dictionary for spell checking. Why it is a dependency is beyond my comprehension. Is it possible to make this reminder go away?
    [/quote:2e5139sk]This is nothing to worry about. Merely a side affect of the way PacmanXG pipes the output of pacman into it’s window.

    @“FutureSuture”:2e5139sk said:

    This has also been there since installation and neither the Antergos wiki nor the Arch wiki have an entry for Repacman. There’s obviously something wrong, but I don’t know what.[/quote:2e5139sk]I have requested the developer remove that warning because it gives a false impression of something being wrong. There is nothing wrong. Repacman is an unnecessary program that can be used to recreate a pacman package from an already installed application’s files.

    @“FutureSuture”:2e5139sk said:

    I also have an issue with Grub. It takes longer to load than anything else. Why should Grub take 15 seconds to load when Antergos itself only takes 5 seconds on my SSD? It just says “Grub loading …” for what feels like ages, then boom, everything seems to fall into place.[/quote:2e5139sk]Please post the contents of /boot/grub/grub.cfg here so we can check for any issues.

    Cheers!!

  • @“lots.0.logs”:214ysuxq said:

    @“FutureSuture”:214ysuxq said:

    The item indicated below does not work whatsoever. My desktop just loads but doesn’t lock like it should.[/quote:214ysuxq]KDM is not the default display manager for Antergos which is why those settings have no affect. Have you enabled KDM manually? If you are using the default (LightDM) I do not think it has a feature to lock the screen after autologin? I’m not 100% sure though.[/quote:214ysuxq]I have not done anything to enable KDM, I just assumed it would be the default display manager. I have found [this Arch wiki entry on display managers[/url:214ysuxq] and found 3 installed packages related to LightDM but am not sure what I am meant to do to fully switch to KDM, get rid of LightDM, and not break anything in the process.

    @“lots.0.logs”:214ysuxq said:

    @“FutureSuture”:214ysuxq said:

    Who/What are these other users? They have been there since installation.[/quote:214ysuxq]I believe my answer to your first question has answered at least half of this one

    @“lots.0.logs”:214ysuxq said:

    @“FutureSuture”:214ysuxq said:

    The first marked item sounds worrisome. The second is because I uninstalled hspell as I really don’t need a Hebrew dictionary for spell checking. Why it is a dependency is beyond my comprehension. Is it possible to make this reminder go away?
    [/quote:214ysuxq]This is nothing to worry about. Merely a side affect of the way PacmanXG pipes the output of pacman into it’s window.[/quote:214ysuxq]Hmmm, I did select Konsole as my default terminal. Is there any way through which I can get rid of the hspell reminder?

    @“lots.0.logs”:214ysuxq said:

    @“FutureSuture”:214ysuxq said:

    This has also been there since installation and neither the Antergos wiki nor the Arch wiki have an entry for Repacman. There’s obviously something wrong, but I don’t know what.[/quote:214ysuxq]I have requested the developer remove that warning because it gives a false impression of something being wrong. There is nothing wrong. Repacman is an unnecessary program that can be used to recreate a pacman package from an already installed application’s files.[/quote:214ysuxq]I see, again, thank you very much for the information. It doesn’t seem to be a package as I cannot rid myself of it.

    @“lots.0.logs”:214ysuxq said:

    @“FutureSuture”:214ysuxq said:

    I also have an issue with Grub. It takes longer to load than anything else. Why should Grub take 15 seconds to load when Antergos itself only takes 5 seconds on my SSD? It just says “Grub loading …” for what feels like ages, then boom, everything seems to fall into place.[/quote:214ysuxq]Please post the contents of /boot/grub/grub.cfg here so we can check for any issues.[/quote:214ysuxq]Here you go:

    \#  
    > > > > > > > > > > \# DO NOT EDIT THIS FILE  
    > > > > > > > > > > \#  
    > > > > > > > > > > \# It is automatically generated by grub-mkconfig using templates  
    > > > > > > > > > > \# from /etc/grub.d and settings from /etc/default/grub  
    > > > > > > > > > > \#  
    > > > > > > > > > >   
    > > > > > > > > > > \#\#\# BEGIN /etc/grub.d/00\_header \#\#\#  
    > > > > > > > > > > insmod part\_gpt  
    > > > > > > > > > > insmod part\_msdos  
    > > > > > > > > > > if [ -s $prefix/grubenv ]; then  
    > > > > > > > > > > load\_env  
    > > > > > > > > > > fi  
    > > > > > > > > > > if [ "${next\_entry}" ] ; then  
    > > > > > > > > > > set default="${next\_entry}"  
    > > > > > > > > > > set next\_entry=  
    > > > > > > > > > > save\_env next\_entry  
    > > > > > > > > > > set boot\_once=true  
    > > > > > > > > > > else  
    > > > > > > > > > > set default="${saved\_entry}"  
    > > > > > > > > > > fi  
    > > > > > > > > > >   
    > > > > > > > > > > if [ x"${feature\_menuentry\_id}" = xy ]; then  
    > > > > > > > > > > menuentry\_id\_option="--id"  
    > > > > > > > > > > else  
    > > > > > > > > > > menuentry\_id\_option=""  
    > > > > > > > > > > fi  
    > > > > > > > > > >   
    > > > > > > > > > > export menuentry\_id\_option  
    > > > > > > > > > >   
    > > > > > > > > > > if [ "${prev\_saved\_entry}" ]; then  
    > > > > > > > > > > set saved\_entry="${prev\_saved\_entry}"  
    > > > > > > > > > > save\_env saved\_entry  
    > > > > > > > > > > set prev\_saved\_entry=  
    > > > > > > > > > > save\_env prev\_saved\_entry  
    > > > > > > > > > > set boot\_once=true  
    > > > > > > > > > > fi  
    > > > > > > > > > >   
    > > > > > > > > > > function savedefault {  
    > > > > > > > > > > if [ -z "${boot\_once}" ]; then  
    > > > > > > > > > > saved\_entry="${chosen}"  
    > > > > > > > > > > save\_env saved\_entry  
    > > > > > > > > > > fi  
    > > > > > > > > > > }  
    > > > > > > > > > >   
    > > > > > > > > > > function load\_video {  
    > > > > > > > > > > if [ x$feature\_all\_video\_module = xy ]; then  
    > > > > > > > > > > insmod all\_video  
    > > > > > > > > > > else  
    > > > > > > > > > > insmod efi\_gop  
    > > > > > > > > > > insmod efi\_uga  
    > > > > > > > > > > insmod ieee1275\_fb  
    > > > > > > > > > > insmod vbe  
    > > > > > > > > > > insmod vga  
    > > > > > > > > > > insmod video\_bochs  
    > > > > > > > > > > insmod video\_cirrus  
    > > > > > > > > > > fi  
    > > > > > > > > > > }  
    > > > > > > > > > >   
    > > > > > > > > > > if [ x$feature\_default\_font\_path = xy ] ; then  
    > > > > > > > > > > font=unicode  
    > > > > > > > > > > else  
    > > > > > > > > > > insmod part\_gpt   
    > > > > > > > > > > insmod btrfs  
    > > > > > > > > > > set root='hd0,gpt2'  
    > > > > > > > > > > if [ x$feature\_platform\_search\_hint = xy ]; then  
    > > > > > > > > > > search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2 5483d9e6-7ff7-48ab-b78a-cc349c9abec0  
    > > > > > > > > > > else  
    > > > > > > > > > > search --no-floppy --fs-uuid --set=root 5483d9e6-7ff7-48ab-b78a-cc349c9abec0  
    > > > > > > > > > > fi  
    > > > > > > > > > > font="/usr/share/grub/unicode.pf2"  
    > > > > > > > > > > fi  
    > > > > > > > > > >   
    > > > > > > > > > > if loadfont $font ; then  
    > > > > > > > > > > set gfxmode=auto  
    > > > > > > > > > > load\_video  
    > > > > > > > > > > insmod gfxterm  
    > > > > > > > > > > fi  
    > > > > > > > > > > terminal\_input console  
    > > > > > > > > > > terminal\_output gfxterm  
    > > > > > > > > > > if [ x$feature\_timeout\_style = xy ] ; then  
    > > > > > > > > > > set timeout\_style=menu  
    > > > > > > > > > > set timeout=0  
    > > > > > > > > > > \# Fallback normal timeout code in case the timeout\_style feature is  
    > > > > > > > > > > \# unavailable.  
    > > > > > > > > > > else  
    > > > > > > > > > > set timeout=0  
    > > > > > > > > > > fi  
    > > > > > > > > > > \#\#\# END /etc/grub.d/00\_header \#\#\#  
    > > > > > > > > > >   
    > > > > > > > > > > \#\#\# BEGIN /etc/grub.d/10\_antergos \#\#\#  
    > > > > > > > > > > menuentry 'Antergos Linux' --class antergos --class gnu-linux --class gnu --class os $menuentry\_id\_option 'gnulinux-simple-5483d9e6-7ff7-48ab-b78a-cc349c9abec0' {  
    > > > > > > > > > > load\_video  
    > > > > > > > > > > set gfxpayload=keep  
    > > > > > > > > > > insmod gzio  
    > > > > > > > > > > insmod part\_gpt   
    > > > > > > > > > > insmod btrfs  
    > > > > > > > > > > set root='hd0,gpt2'  
    > > > > > > > > > > if [ x$feature\_platform\_search\_hint = xy ]; then  
    > > > > > > > > > > search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2 5483d9e6-7ff7-48ab-b78a-cc349c9abec0  
    > > > > > > > > > > else  
    > > > > > > > > > > search --no-floppy --fs-uuid --set=root 5483d9e6-7ff7-48ab-b78a-cc349c9abec0  
    > > > > > > > > > > fi  
    > > > > > > > > > > echo 'Loading linux kernel ...'  
    > > > > > > > > > > linux /boot/vmlinuz-linux root=UUID=5483d9e6-7ff7-48ab-b78a-cc349c9abec0 rw   
    > > > > > > > > > > echo 'Loading initial ramdisk ...'  
    > > > > > > > > > > initrd /boot/initramfs-linux.img  
    > > > > > > > > > > }  
    > > > > > > > > > >   
    > > > > > > > > > > \#\#\# END /etc/grub.d/10\_antergos \#\#\#  
    > > > > > > > > > >   
    > > > > > > > > > > \#\#\# BEGIN /etc/grub.d/20\_linux\_xen \#\#\#  
    > > > > > > > > > > \#\#\# END /etc/grub.d/20\_linux\_xen \#\#\#  
    > > > > > > > > > >   
    > > > > > > > > > > \#\#\# BEGIN /etc/grub.d/30\_os-prober \#\#\#  
    > > > > > > > > > > \#\#\# END /etc/grub.d/30\_os-prober \#\#\#  
    > > > > > > > > > >   
    > > > > > > > > > > \#\#\# BEGIN /etc/grub.d/40\_custom \#\#\#  
    > > > > > > > > > > \# This file provides an easy way to add custom menu entries. Simply type the  
    > > > > > > > > > > \# menu entries you want to add after this comment. Be careful not to change  
    > > > > > > > > > > \# the 'exec tail' line above.  
    > > > > > > > > > > \#\#\# END /etc/grub.d/40\_custom \#\#\#  
    > > > > > > > > > >   
    > > > > > > > > > > \#\#\# BEGIN /etc/grub.d/41\_custom \#\#\#  
    > > > > > > > > > > if [ -f ${config\_directory}/custom.cfg ]; then  
    > > > > > > > > > > source ${config\_directory}/custom.cfg  
    > > > > > > > > > > elif [ -z "${config\_directory}" -a -f $prefix/custom.cfg ]; then  
    > > > > > > > > > > source $prefix/custom.cfg;  
    > > > > > > > > > > fi  
    > > > > > > > > > > \#\#\# END /etc/grub.d/41\_custom \#\#\#  
    > > > > > > > > > >   
    > > > > > > > > > > \#\#\# BEGIN /etc/grub.d/60\_memtest86+ \#\#\#  
    > > > > > > > > > > \#\#\# END /etc/grub.d/60\_memtest86+ \#\#\#
    

    Thank you again for your response. I really do appreciate it. I can’t wait to get all this fixed! Linux makes makes me feel a special kind of helpless!

    ]0

  • @“FutureSuture”:29x7rczz said:

    I have not done anything to enable KDM, I just assumed it would be the default display manager. [/quote:29x7rczz]Nope. We chose LightDM because of it’s minimal footprint and it’s compatibility with all desktops. It creates a consistent user experience regardless of which desktop you choose to install. If you want to switch you can do this:

    sudo systemctl disable lightdm && sudo systemctl enable kdm
    

    Then restart your system.

    @“FutureSuture”:29x7rczz said:

    Strange that they are available as options for logging in since they aren’t user accounts[/quote:29x7rczz]If you remove them, there respective application will not function. For aesthetic purposes you can hide them by editing /etc/lightdm/users.conf and changing “[UserAccounts]” into “[UserList]”. (If you are going to uninstall lightdm anyway then no need to worry about this.

    @“FutureSuture”:29x7rczz said:

    Is there any way through which I can get rid of the hspell reminder?
    [/quote:29x7rczz]No, not unless you install it. For whatever reason the package maintainer lists it as a dependency. If you don’t believe it should be you can contact the maintainer

    Everything looks normal in your grub config. Is it possible your UEFI firmware is causing the delay? I don’t know where that might be logged b/c I don’t have a UEFI system.

    Cheers!

  • @“lots.0.logs”:3jk15arv said:

    @“FutureSuture”:3jk15arv said:

    I have not done anything to enable KDM, I just assumed it would be the default display manager. [/quote:3jk15arv]Nope. We chose LightDM because of it’s minimal footprint and it’s compatibility with all desktops. It creates a consistent user experience regardless of which desktop you choose to install. If you want to switch you can do this:

    sudo systemctl disable lightdm && sudo systemctl enable kdm
    

    Then restart your system.[/quote:3jk15arv]Thank you very much! KDM works!

    @“lots.0.logs”:3jk15arv said:

    @“FutureSuture”:3jk15arv said:

    Strange that they are available as options for logging in since they aren’t user accounts[/quote:3jk15arv]If you remove them, there respective application will not function. For aesthetic purposes you can hide them by editing /etc/lightdm/users.conf and changing “[UserAccounts]” into “[UserList]”. (If you are going to uninstall lightdm anyway then no need to worry about this.[/quote:3jk15arv]And so I did. Thanks again.

    @“lots.0.logs”:3jk15arv said:

    @“FutureSuture”:3jk15arv said:

    Is there any way through which I can get rid of the hspell reminder?
    [/quote:3jk15arv]No, not unless you install it. For whatever reason the package maintainer lists it as a dependency. If you don’t believe it should be you can contact the maintainer

    @“lots.0.logs”:3jk15arv said:

    Everything looks normal in your grub config. Is it possible your UEFI firmware is causing the delay? I don’t know where that might be logged b/c I don’t have a UEFI system.[/quote:3jk15arv]That is possible, but I wouldn’t have a clue as to where to start looking.

    Nevertheless, a new problem has popped up: PacmanXG doesn’t show up any longer when attempting to run as root, only when running as the current user. Seems like it’s linked to LightDM in some manner as that is all I changed.

  • @“FutureSuture”:2nnljm71 said:

    Nevertheless, a new problem has popped up: PacmanXG doesn’t show up any longer when attempting to run as root, only when running as the current user. Seems like it’s linked to LightDM in some manner as that is all I changed.
    [/quote:2nnljm71]I would have to say it’s a coincidence b/c LightDM has nothing to do with pacmanXG. Try this:

    sudo pacman -Syyu
    

    If that doesn’t help then do this:

    sudo pacman -Rc pacmanxg4 ssx --nosave  
    > sudo pacman -S pacmanxg4
    

    Cheers!

  • @“lots.0.logs”:3rvmm3yc said:

    @“FutureSuture”:3rvmm3yc said:

    Nevertheless, a new problem has popped up: PacmanXG doesn’t show up any longer when attempting to run as root, only when running as the current user. Seems like it’s linked to LightDM in some manner as that is all I changed.
    [/quote:3rvmm3yc]I would have to say it’s a coincidence b/c LightDM has nothing to do with pacmanXG. Try this:

    sudo pacman -Syyu
    

    If that doesn’t help then do this:

    sudo pacman -Rc pacmanxg4 ssx --nosave  
    > > sudo pacman -S pacmanxg4
    

    Cheers![/quote:3rvmm3yc]I assumed that PacmanXG was set to just display in LightDM but I am no developer. Popped those commands into Konsole but the problem remains.

  • How are you launching pacmanXG?

  • @“lots.0.logs”:uhwaljsc said:

    How are you launching pacmanXG?[/quote:uhwaljsc]Through the graphical user interface. Just tried through the terminal and got this:

    No protocol specified   
    > An unhandled exception occurred at $000000000057853A :   
    > egui : Can not connect to display tinternalapplication .   
    > $000000000057853A   
    > $0000000000578690   
    > $00000000004B4171   
    > $0000000000567404   
    > $0000000000565D84   
    > $00000000004B405C   
    > $00000000004AED58   
    > $000000000048CCE6   
    > $00000000006100EC   
    > $0000000000724FDC   
    > $000000000047B5D6   
    >   
    > An unhandled exception occurred at $0000000000476597 :   
    > An unhandled exception occurred at $00007FB46813ACCD :
    
  • Try starting it from the Terminal with

    sudo -i pacmanxg4  
    
    

    If this doesn’t work, check if you have a .Xauthority file in /root with

    ls -la /root  
    
    

    If there is such file run this command with your user-terminal (not root-terminal)

    sudo xauth -f /root/.Xauthority merge /home/$USER/.Xauthority  
    
    

    If there is not such file, find a way to generate it. I don’t know how to do it, but the command up there will pretty much fix your issue.

    Please give a feedback after you get help so the thread can be set to solved.

Posts 11Views 1138
Log in to reply