• Applications can't use location in GNOME

    So i’ve installed Antergos GNOME but I can’t use location provided by GNOME. I’ve enabled it in settings but still Redshift can’t use the location.

    Any tips in fixing this?

  • The post is too generic. It precludes a good answer.

    Few suggestions.

    1. Check your current timezone setting

      timedatectl status
    2. If Time Zone: field doesn’t coincide with your current time zone, then display the list of available time zones

      timedatectl list-timezones
    3. Find one that corresponds to your geographical time zone and set it. For Helsinki, Finland

      timedatectl set-timezone Europe/Helsinki
  • I can’t get Redshift to work with geoclue2 for location. On Ubuntu GNOME it worked out of the box. Basically GNOME doesn’t use location services. There should be a icon in taskbar when location is used but there is no icon there, so as it seems location services don’t work.

  • @matjaz132 said in Applications can't use location in GNOME:

    …Basically GNOME doesn’t use location services…

    It does:


    Make also sure that the hardware clock is set to use UTC time, not a local time.

  • I’m not having problems with timezones, the problem I’m having are about geolocation services under privacy settings.

    For example as I said, Redshift application which uses geoclue2 to get the coordinates of my position, cannot get them because GNOME as it seems doesn’t “allow” to use geolocation, even if it’s enabled in privacy settings.

  • After cleaning some unwanted package the problem resolved by it self. It might have been a problem with LighDM which I switched with GDM.

    Thank you!

  • It would be nice if you mark the topic as Solved then. Use the bottom right Topic Tools button to do it.

wireless38 gnome310 location5 redshift3 Posts 7Views 1517
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.