• Installation's problem.


    I am trying to install Antergos for a first time but at the end of cnchi’s installer a popup window tell me: cannot create download package list (metalinks). Please reference the following number when reporting this error: 431482.
    Can someone help me?
    Thanks.

    PD: I send you a picture. I am using a wired internet conection.

    0_1485115218324_Captura de pantalla de 2017-01-22 20-21-39.png

  • Hi @Ogenki,

    I’ve seen the same error (although different error code) for the past few hours and seems still present now.

    Looking in the /tmp/cnchi.log file:

    [ERROR] metalink.py(124) create(): Can't find these packages: cdrkit
    

    The next line shows our failure and fails the installation with error.

    I did try to see if, on the live usb/cd distro, using the following would make any difference:

    pacman -S cdrtools
    

    The only difference it shows what there’s a conflict in packages to resolve.

    looking for conflicting packages...
    :: cdrtools and cdrkit are in conflict. Remove cdrkit? [y/N]
    

    Answering yes, doesn’t make a difference during install…And this may be unrelated but it’s the first thing I looked to try.

    I haven’t got workaround to share for it currently, just thought I’d speak up that I’m seeing it too.

    jdmac

  • I can also report the same problem. Tried installing without additional packages still no such luck. Interestingly if I visit the /api/hook?cnchi=xxx&install_id=xxx&result=False page I see on the terminal when the install fails I get an error:

    "{\"msg": \"wrong event type\"}"
    

    Not sure it is related.

  • @chris - Is that on antergos build site?
    I noticed similar entries to that on my logs but it appears frequently without error so I led myself to believe it was callbacks to report installation statistics.

    By similar I mean API calls, but I don’t see “wrong event type” specifically.

  • Unfortunately akismet spam protection is stopping me posting links:

    /api/hook?cnchi=2580656b5c7be34e4144a3129a95e421&install_id=432268&result=False

  • I am seeing the same issue also. Unable to find package cdrkit is the reason for the failure in the log.

  • Hi,

    There has been a package rename in Arch repositories. cdrkit now it’s called cdrtools. We’ve fixed it. Give a few hours before retrying again, though.

    Thanks!

  • Thanks to everyone. I am very surprised for the interest and help in this community. I am an unexperienced Linux user and most of your comments are very complicated to understand for my but I supose that the problem has been fixed and I will try to reinstall Antergos in a few hours.

    PD: Sorry for my bad english…

  • I can confirm it is working now.

  • no not yet i try again and that error shows
    metalink download package

    Asus n552wv-A 4K Antergos + Cinnamon + Dark Arc Theme

    Macbook Pro 2016 + macOS Sierra + Virtual : Arch + Antergos + Mint + Windows 10.

  • @karasu said in Installation's problem.:

    Give a few hours before retrying again, though.

    This probably means it takes a while to propagate the changes across the many mirrors that Antergos uses. Alternatively this could be caused by some sort of aggressive cacheing between you and the Antergos server.

    Based on your geographical location / ISP @JARVIS you might be getting served old files by a different mirror server.

    You have two options:

    1. Wait it out, changes will most likely have propagated within the next day or so.

    2. Try and change mirrors to a server with the newest files on.

    @bcameron any idea which mirror you used?

  • (sorry bad eng-not native language)

    @chris first thanks , I don’t think so about my ISP because last 2 day I was installed antergos on some one pc but now i cant.

    And how can I change my mirror server to gets new files, I test it (change mirror in this forum) by pacman in terminal and didn’t work.

    I think I must wait.

    Asus n552wv-A 4K Antergos + Cinnamon + Dark Arc Theme

    Macbook Pro 2016 + macOS Sierra + Virtual : Arch + Antergos + Mint + Windows 10.

  • @chris thanks , tested not working.

    Asus n552wv-A 4K Antergos + Cinnamon + Dark Arc Theme

    Macbook Pro 2016 + macOS Sierra + Virtual : Arch + Antergos + Mint + Windows 10.

  • I had to try in two times but I can confirm it works now.
    Thanks a lot to all.

    PD: I am writting from Spain with my new “Antergos”!

  • Guys what is this saying ?

    link text

    Asus n552wv-A 4K Antergos + Cinnamon + Dark Arc Theme

    Macbook Pro 2016 + macOS Sierra + Virtual : Arch + Antergos + Mint + Windows 10.

  • @JARVIS did you have a network connection on? You must be connected to the Internet to be able to install Antergos.

  • @JARVIS said in Installation's problem.:

    Guys what is this saying ?

    It says that installer looks for gstreamer0.10-plugins package, cannot find and download it, so the installation will stop:

    2017-01-23 23:16:56 [ERROR] download.py(145) create_metalinks_list(): Error creating metalink for package gstreamer0.10-plugins. Installation will stop
    

    gstreamer0.10-plugins doesn’t exist in the repos. No surprise that it can’t be found.

    It seems that developers have removed the package on Github from the list of packages to download 3 hours ago.

    Re-try the installation. Cnchi should nont look anymore for gstreamer0.10-plugins.

  • @just that’s true, but that’s because he has no connection, so the packages.xml file is not being retrieved online and Cnchi is using the one in the cd/usb instead, that’s why it does not work.
    ;)

  • @karasu said in Installation's problem.:

    @just that’s true, but that’s because he has no connection, so the packages.xml file is not being retrieved online and Cnchi is using the one in the cd/usb instead, that’s why it does not work.
    ;)

    Ooh, I wasn’t aware of it. I’ll take it into account in the future. Cnchi is even smarter than it seems initially.

installations3 problem7 Posts 22Views 1788
Log in to reply