• Dual boot Win10 & Antergos on 2 SSD's

    i want to make a dualboot setup with Win10 on one SSD and Antergos on a second SSD.
    Win 10 is allready installed and the second ssd can fully be used for antergos.
    I dont want to mess things up with the windows SSD so please say me if i understood all steps it needs for the installation.

    Some stats of my System:
    -16gb ram
    -SSD1 Windows 10 /EFI/GPT
    -SSD2 clear
    So i have to:

    1. Turn of secure boot
    2. start install Antergos from live usb stick
    3. Make /,/home,/swap partitions on SSD2
    4. (Here it gets a bit tricky) must I set the /boot/efi to the /efi of my win10 on SSD1 ?
      I dont realy got if i need to set it or not. (Please help me with this)
    5. Install grub to SSD1
    6. run update-grub ?

    Pls tell me if the steps are right.
    Greetings & Thanks so far.

  • @chill3er

    I won’t be responsible for any damages (data loss) but this is what I did / would do:

    As always: Make a backup! Things can break and sometimes they do. Sometimes it’s just bad luck.

    I have a dual boot of Win 8.1 and 3 drives (Win SSD, SSD for linux and a huge HDD).
    Disable Secure Boot and disable fast startup (or you probably won’t get into the boot menu).

    Do you have a Win CD? I once broke my bootloader and I couldn’t start anything, however the Windows CD could fix my Windows bootloader and I could at least boot windows again.

    As the installer wanted, I took about 30GB of my SSD (look for the right) for root (/) and the rest for “/home”. I didn’t need to set any boot partition except the bootlader (on the very bottom of the installer inside the partiton manager).
    Important is that you install the bootlader (very bottom of installer) at the drive where your Windows is.

    I also looked a bit to this guide which helped me a bit, however I wasn’t doing exact all the steps:

    It’s also important to know what GPU you have. A new one can need a little workaround. I e.g. (no idea why) hadn’t the possibility to set “Install nvidia drivers during installation” inside cnchi (maybe this feature has been removed, idk). Therefore after booting I had a blackscreen. I managed this with booting into the text mode.

    I did this this way:
    Wait for Grub --> Select Antergos and press “E” and add to the line where it says “… quiet” the number “3” (of course with space between).
    Then press “STRG+X” and it should boot into text mode.

    The next thing I needed was installing the nvidia drivers.
    I did this following this guide: http://unix.stackexchange.com/questions/207895/how-do-i-install-antergos-with-a-gtx-970
    Which basically means:

    pacman -Syy nvidia nvidia-utils nvidia-libgl
    pacman -Rccn xf86-video-nouveau

    And boom I sucessfully installed Antergos as a dual boot.

  • i also have a gtx970, I think i will give it a try after some backups.
    Thanks for your help.
    You didnt created any swap partition?

  • @chill3er
    Good idea ;)

    Nope I didn’t.
    There are many discussions on the web if a swap is really needed at a desktop machine.
    I always installed one but I did not noticed that it was used or gave me any advantages.
    But of course you can ;)

  • @got-it-man

    Hey, I tried your method but you can’t do that if your system is UEFI. During the installation you have to point your /boot/efi partition or you can’t continue the installation because it tells you that EFI/boot part is required, the arrow is in the right corner is greyed out.

    My problem is have been trying to install Antergos for 2 days now, i’ve 2 SSDs one with windows 10(sda) and one is empty(sdb), I did it like that during the install:

    • disabled fast-boot on windows

    • set secure boot to Other OS in my bios (otherwise i can’t even boot on the liveusb)

    • ‘/’ is 40gb ext4

    • /home is 70gb ext4

    • swap is 8gb

    • created a /boot/efi on sdb with 1gb fat32
      EDIT: Windows 10 didn’t make any EFI partition like i saw on a few guides, theres just my C: drive and thats all…

    installed grub2 on sda (at the bottom of the window it ask you)

    But i just can’t get it to work, when i install and then reboot it shows grub with antergos but no windows entry, and when i try to boot on antergos once it tells me theres no such device, and last time it just gived me a black screen with ‘_’ character blinking… I’ve no idea how to install Antergos i guess we need an expert lol.

  • Have you tryed “sudo update-grub” to find windows?
    I have read that it can happen that grub doesnt find windows, but you can update it somehow.

  • Hey,

    got some news… So i’ve seen that every guides contains a EFI partition on their antergos install screenshot, so i managed to make one. Basically on windows i shrinked my Windows part, made a new one of 200mb FAT32, copied windows bootfile on it with bcdboot cmd, then i cleaned sdb with the clean cmd on diskpart.

    After, i rebooted on antergos liveusb launched the install, so i did it this way:

    • sdb:

    • ‘/’ ext4 40gb

    • /home ext4 71gb

    • swap 8gb

    • sda (windows) :

    • /boot/efi with no format (fat32) on the efi part i created above.

    • grub2 on sda (windows)

    after installation i rebooted, got the grub2 bootloader with antergos logo etc, then it booted on antargos but it just gave me a black screen with a blinking cursor, so i rebooted and checked the grub command line for antergos, removed the quiet command booted and apparently it stops doing anything after it says : [OK] Started hostname service

    so when it gave me the blinking cursor again, i did ctrl+alt+f2, so i logged in to my antergos account as root, went to /var/log and apparently Xorg made error logs so i guess my problem is coming from my graphic adapter ? I own a 1060 GTX 6gb. I managed to copy the log on my ftp heres the link: http://henrygolant.altervista.org/log.log

    I also tried to put nomodeset in grub but it didnt do anything. Is anyone able to help me out ? I can make a new thread if its needed.

  • so you set the /boot/efi to the /efi partition of windows? right?

  • @chill3er
    yep thats what i did, but do not format it during antergos installation do not check format for that part otherwise it will screw up your boot files for windows.

    edit: also i think grub-update won’t work with antergos because its based on arch linux the right cmd is : grub-mkconfig

  • @got-it-man

    Awesome news ! Got it working i completly forgot got-it-man had this issue with his graphic card, so I did exactly the suggestion from his post, and i’m actually writing this from Antergos ! @chill3er if you still have the same issues i’ll try to help you, i’m complete noob with linux but yet i managed to finally install antergos lol

  • Nice…i can try it later this week, but i will let you know if I will get it to work ;)

  • @exoje said in Dual boot Win10 & Antergos on 2 SSD's:


    Awesome news ! Got it working i completly forgot got-it-man had this issue with his graphic card, so I did exactly the suggestion from his post, and i’m actually writing this from Antergos ! @chill3er if you still have the same issues i’ll try to help you, i’m complete noob with linux but yet i managed to finally install antergos lol

    Great to hear ;)
    Yeah I think there’s a mistake inside the installer. Looks like newer GPUs don’t get recongnized and therefore you can’t click “Install Nvidia drivers” during installation.
    I opened an issue at the Github page of cnchi.
    –> https://github.com/Antergos/Cnchi/issues/694

  • To link the /boot/efi right…you chose the efi partition of windows
    and set mount point of the windows partition to /boot/efi …or do you create a new partition?
    Or what is the way to link the /efi partition to /boot/efi?

  • @chill3er

    During antergos installation, you need to select your EFI part then click edit and select /boot/efi and leave the format checkbox unchecked, thats all for /boot/efi , then just do the usual root,home,swap ! Also install the grub2 bootloader on your windows disk (bottom of the window). I’m still trying to figure out how to add windows entry to grub’s menu but i guess thats another problem, i can still boot on windows if i pick my ssd (sda) in the boot menu.

  • Ok, i think than i understood it right, thanks mate.
    Please tell us if you got a solution fpr your problem ;)

  • @chill3er Hey ! Another day and another answer to my question hehe

    So, first of all in my case i didn’t know but my windows drive (sda) was MBR and not GPT (which is weird cause my mobo is UEFI) so thats why i didn’t have any EFI partition made by windows and thats also why i couldn’t manage to add windows to grub’s menu (i think so).

    I completly uninstalled Antergos, cleaned my SSD with diskpart on windows, then i downloaded a software called AOMEI Partition Assistant to convert my MBR disk to GPT without losing any data. (theres also a free tool called gptgen, but i didn’t want to mess up with it). Basically it rebooted my PC converted the disk then created the EFI partition.

    After then, i reinstalled Antergos, pointed /boot/efi on the correct fat32 EFI partition made by windows, did the usual home,swap,root and installed grub2 on windows disk. Rebooted after installation, i had the usual bug with my nvidia card so i followed the instructions from got-it-man’s post above, rebooted again and I was on Antergos’s desktop !

    Now the next step was to add Windows 10 to grub’s bootloader. I ran a shell, used:

    sudo os-prober

    which gave me :

    /dev/[email protected]/EFI/Microsoft/Boot/bootmgfw.efi:Windows Boot Manager:Windows:efi

    then I did:

    sudo grub-mkconfig -o /boot/grub/grub.cfg

    It found the windows bootmanager and added it to the grub menu 👏

    Now i’ve got a working dual boot with windows 10 & Antergos ! Hope this helps someone else !

  • I also got it to work. Now having win 10 and antergos in dualboot.
    Antergos installed flawlessly and even the nvidia driver did.
    I also needed to add windows to grub, but your commands workt perfectly.
    Thanks mate ;)

  • @chill3er

    good to hear that mate 🤘 enjoy !

uefi43 antergos22 dualboot14 win105 Posts 18Views 4017
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.