• Blackscreen after Installation - Mouse in corner, Lightdm


    Hi,

    I did a installation of Antergos. At the installation from the live cd I (again) had the problem that my cursor was stucked in the upper left corner. As I have had this bug earlier, but I remembered the solution. At the startup of the live cd I changed the Kernel Mode to “No ACPI”.
    Therefore I would install Antergos and use the mouse at the installation.

    After the installation and everything worked (I have done this today for 4 times…) I wanted to start Antergos, however my mouse cursor is stucked in the upper left corner and then I get a full blackscreen (no TTY).

    However with “quiet 3” inside Grub I managed to get TTY-access and I could startx and lightdm in test/debug mode, but my mouse cursor is still stucked. I tried the famous invisible mouse cursor uxa fix of the antergos wiki, but after creating the conf-file and rebooting I can’t start lightdm anymore and startx gives me an X11 error “(EE) no screens found (EE)” (which I will upload in a minute).

    I also found out that chinchi isn’t installing/ offering to install Nvidia-drivers. At one of my many installation tried I found out that the nvidia drivers weren’t installed, but installing them didn’t really use anything.

    XORG:
    X1
    https://imgur.com/ynHTyVm
    X2
    https://imgur.com/pfbfYyz

    Lightdm:
    lightdm
    https://imgur.com/Rnuotfo

    I onced tried installing and enabling GDM but it didn’t worked either. But maybe I installed in wrong. (Installing through pacman, enabling and rebooting).
    Hope you guys can help.

  • @got-it-man I fixed it following this guide: http://unix.stackexchange.com/questions/207895/how-do-i-install-antergos-with-a-gtx-970
    Which basically means:

    pacman -Syy nvidia nvidia-utils nvidia-libgl
    pacman -Rccn xf86-video-nouveau
    nvidia-xconfig
    

    To get into the text mode I edited inside the Grub the Antergos Parameteres.
    I just added a “3” after quiet.
    Looks like to Cnchi installer doesn’t bring the nvidia driver anymore which makes booting from a new GPU like Nvidia GTX 1080 impossible. Lightdm looks like to be fixed.

  • Thanks for sharing, @got-it-man 👍

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 18.04 64bit Gnome
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch No problem 😉 Glad if I can help 🙂

lightdm125 blackscreen4 mouse uxa1 x11 no screens1 Posts 4Views 1331
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.