• Like 0

    Black screen instead of login screen


    Hello, I just installed Antergos on a external hard drive.
    But when I boot it, instead of a login screen there is just a black screen with visible mouse pointer.

    I’m using Openbox and tried MATE too, same problem.

    My specs:

    CPU
    Intel Core i7 2670QM @ 2.20GHz
    Sandy Bridge 32nm Technology
    RAM
    8,00GB Dual-Channel DDR3 @ 665MHz (9-9-9-24)
    Motherboard
    MEDION X682X (SOCKET 0)
    Graphics
    Intel HD Graphics 3000 (MSI)
    1535MB NVIDIA GeForce GTX 670M (MSI)

    Thank you.

  • Like 0

    @Spewks when u’re installing, are u checking nvidia and amd drivers?

  • Like 0

    @johnmcmuffin I tried it checked and unchecked, its the same result.

  • Like 0

    Try to boot with one additional parameter:

    modprobe.blacklist=nouveau
    
  • Like 0

    @just Nope that didn’t work.
    In case I did it wrong because I’m new: http://i.imgur.com/ziJ2kWq.jpg

  • Like 0

    @Spewks said

    when I boot it, instead of a login screen there is just a black screen with visible mouse pointer.

    Sorry if I sound silly (I m no expert with NVIDIAs) but when was the installation done?
    Could the issue with the broken LIGHTDM be the culprit here, so entering a TTY screen and getting the latest updates worth a try??

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.04 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Like 0

    @Spewks said in Black screen instead of login screen:


    In case I did it wrong…

    You did it in a wrong way. The parameter must be added to the kernel’s boot line, not as a command in the grub shell (on the photo).

    To add a parameter to kernel’s boot lines, press e to start editing them. There are two lines. The first one starts with “kernel …”. You must edit this one.

    Ar the bottom of the screen Grub 2 lists all keys you can use to move around.

    At the end of the first line add ** modprobe.blacklist=nouveau **. Separate it with one or more spaces from preceeding parameters. Place one or more spaces after added parameter.

    Press F10, or another key suggested by Grub 2 at the bottom, to boot with the modified “kernel …” boot line.

    I do not use Grub 2 boot loader and don’t remember all its editing keys, so I may be wrong with the keys. Search somewhere how to edit the boot line(s) in Grub 2.

  • Like 0

    @anarch This is my second install and I didn’t check the nvidia drivers this time (I thought that was causing the problems but no)
    I updated my system but the problem was still there.
    I reinstalled lightdm-webkit2-greeter and lightdm, now the login screen appears but when I login I get a grey screen… :|

  • Like 0

    @Spewks If is MATE DE there is a bug with it that display a grey screen…

    Antergos (default OS) - WIN10 (abandoned)
    MATE desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB

  • Like 0

    @fernandomaroto Nope its openbox

  • Like 0

    @just This is the only line with kernel I see:

    echo ‘loading linux kernel…’

  • Like 0

    When you see Grub 2 menu on the screen, press the e key. It will place you in the edit mode for currently selected menu option. You’ll be able to modify the boot parameters, adding the new one.

    Edit

    Probably, in Grub 2 the kernel loading line starts not with “kernel …” but with “linux …”.

    It may look like

    linux /boot/vmlinuz-linux root=UUID=aaaa-bbbb-cccc-ddd-eee quiet splash
    

    Add the new parameter at the end:

    linux /boot/vmlinuz-linux root=UUID=aaaa-bbbb-cccc-ddd-eee quiet splash modprobe.blacklist=nouveau
    

    Press Ctrl+x to boot with it.

  • Like 0

    @just It indeed starts with linux, now I get it.
    I did how you told me, but it still doesn’t work.

    I don’t think its a problem with nvidia

    After reinstalling lightdm-webkit2-greeter the login screen appears but when I login I get a grey screen.

  • Like 0

    @Spewks said in Black screen instead of login screen:


    After reinstalling lightdm-webkit2-greeter the login screen appears but when I login I get a grey screen.

    Can’t help with lightdm-webkit2-greeter, because I substitute it with lightdm-gtk-greeter, and then skip it entirely with autologin.

  • Like 0

    @Spewks said

    don’t think its a problem with nvidia
    After reinstalling lightdm-webkit2-greeter the login screen appears but when I login I get a grey screen.

    Did you run the live media(Try Antergos) before installing it? Were there any issues there?

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.04 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Like 0

    @anarch Yes, and I didn’t had any problems.

  • Like 0

    The only idea I can come up with is trying another DM. There were a number of reports where some systems did not like lightdm at all and refused to work with it…

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.04 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Like 0

    @Spewks said in Black screen instead of login screen:

    @fernandomaroto Nope its openbox

    i don’t use openbox, but look this link… [https://forum.antergos.com/topic/5869/openbox/4]([link url]

    It seems openbox is broken (MATE as well)

    PS: so i guessing is not a Login manager problem, but a DE problem

    Antergos (default OS) - WIN10 (abandoned)
    MATE desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB

  • Like 0

    @fernandomaroto So I picked a broken DE twice…

    Tomorrow I’ll try to reinstall it with a different DE and see what that gives.

    Thanks for the help everyone

  • Like 0

    @just Have also tried this one. After booting I only get a blackscreen with a blinking underline character. Never had so many problems with Antergos… An older version in December run flawlessly…

    @Spewks Yeah please keep us up to date if changing fixes the problem.

  • Like 0

    @Spewks You don’t need to install all the system again, just another DE, if this is really the problem.

    Antergos (default OS) - WIN10 (abandoned)
    MATE desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB

login53 black27 Posts 28Views 1332
Log in to reply