• Updated Antergos: Black Screen with Mouse Pointer


    I recently updated my antergos installation, and where the lightdm used to be… is a black screen with the mouse pointer. I read some of the other forums regarding this issue and fixed it by replacing lightdm with gdm.

    Everything seems to be in working order, but is there anything in the future I should be concerned about regarding libraries, dependencies, broken packages? Thanks for your help! I’m not new to Linux, but the more I learn the more I realize how little I know!

  • @johndoe86x

    Pleased to see you go it fixed.

    For now, do not update to webkitgtk 2.4.11- 4 as it is not fixed yet, and it will still give the same problem and break GDM.

    Also, do not downgrade to any other version of webkitgtk either as again it will break GDM.

    Refer to Antergos > Announcements and it’s titled;
    Package Advisory: webkit2gtk-2.14.3-1 for any service updates.

    I’ve been using Linux for close on 12 years and I’m still learning, and if you have any more problems please don’t hesitate to post.

    Good luck & all the best - Steve

  • @Cenobite
    Thank you for your response! What would be the best way to ignore the webkitgtk in the meantime? Would it be editing the pacman.conf file with:

    IgnorePkg   = webkitgtk
    

    Or is there a bit more to it than that?

  • @johndoe86x I just use preferences in the pamac GUI.

    Add and Remove > Look for the last icon after repo’s > preferences > general
    the use + to select ignore updates.

    I have just re-installed Antergos Gnome, using the latest iso
    and the lightdm works. I have tested it with all the Login, Restarts, Logouts and Power Off selections. You might get a ‘false’ error on boot but ignore it, it still cycles and you then get the lightdm.

pointer3 updated5 black45 mouse44 Posts 4Views 668
Log in to reply