• [Solved] Optimus Issues preventing first boot - Thinkpad P50

    Edit: The problem was lightdm, not related to GPU driver issues at all.

    Hope someone can help. This is the first optimus install I’ve done, and the first UEFI install I’ve done. (My current other laptop is 2nd gen Sandybridge w/nvidia gtx460m, but optimus is HW disabled on the motherboard, so I"ve never had to worry about it before.)

    Long story short - I booted the liveusb with bios set to “legacy boot” and “hybrid graphics”. I actually don’t care at all about the switchable graphics. I’ll get it working if I can, but I’m very happy to use nvidia only.

    However, counterintuitively, if I choose “discrete only” in the bios, I can’t boot to the live environment no matter what I’ve tried. (And I did spend quite awhile trying.)

    With the settings as noted above, I was able to boot to the live environment and install Antergos, only with adding “modprobe.blacklist=nouveau” to the kernel line.

    On first boot after install, lightdm failed to load.

    Well, I haven’t documented what I did very well, but suffice to say that I have combed google, the Antergos wiki, and the arch wiki to try and understand how to get this thing to boot. The problem appears to be lightdm failing every single time.

    I have undone all the xorg conf and etc that I did along the way, however I did pacman -S nvidia - and that is still installed.

    Confounding me further - I tried booting into the live environment again while typing this, and now that’s not working either.

    I don’t seem to be finding a lot of reports of problems installing linux with this laptop, but perhaps my google skills are just super weak?

    While I’m not actually a noob, I AM entirely one with regard to having to worry about these hybrid graphics issues - so if someone could give me a little handholding, I’d certainly appreciate it.

    I’d like to try and fix the current install if possible, but if I can get the live environment to boot again, I’m happy to start fresh.


  • @noobforever Hi! Well i’m not sure if:

    1. you managed to install everything fine and this bug happened to you [https://forum.antergos.com/topic/5910/package-advisory-webkit2gtk-2-14-3-1](link url) (this case it’s easy to fix)
    2. you installed proprietary drivers and that crashed you system :( (i don’t know how to fix if it’s the case)
    3. if you just messed the BIOS config (since you can’t boot live USB anymore)
    4. All :(

    I’d say to check in that order…

  • Thanks! I hope it’s not option 4. :-D

    I’ve only changed those two bios settings you mentioned, so I feel like I should be pretty safe there as well.

    However, I’ll def check out the lightdm problem. I’d prefer using sddm anyhow with Plasma, so I’ll just swap one for the other when I get to it later, and hopefully kill two birds with one stone.

    The install did appear to proceed with no problem, so I’m cautiously optimistic.

    I’m honestly surprised that I’m having this kind of trouble - it’s been so long since I tried installing Linux on a piece of hardware that wanted to fight me about it that I nearly can’t remember the last time it happened. 5 or 6 years at least. 😠

  • Hi,

    Just today we (Antergos) have released a script that maybe helps you.

    It’s called nvidia-installer and you can install it with:
    sudo pacman -S nvidia-installer

    Then, you can:

    1. Install nouveau drivers with:
      sudo nvidia-installer -n
    2. Install nvidia drivers with:
      sudo nvidia-installer
    3. Install bumblebee (for Optimus cards):
      sudo nvidia-installer -b

    If you add -t to any of this options you will be able to see what the script will try to do (it’s a test mode). Your system won’t be modified with this option.

    Hope this helps.


  • Hey apologies for letting this sit so long - in case anyone else finds this issue, I was too quick to blame anything related to my nvidia GPU.

    It was indeed the lightdm issue - as soon as I replaced with sddm, problem solved.

    As I will never ever do any gaming with this laptop (it’s strictly for work) I don’t think I’m going to bother with optirun/bumblebee/proprietary driver at all.

    I know this is an old thread, just wanted to leave this post for closure. Thanks for the help!

lightdm137 optimus26 solved19 Posts 5Views 1216
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.