• GDM - Not Prompting For Password After Standby


    Hey Guys,

    As the subject states, I switched to GDM after the last update broke some things to lightDM. For security, when I put my computer to standby, and wake it up, I like to be prompted for my password to enter back into the system. This worked fine with LightDM, but GDM just takes me straight to my desktop…how do I enable authentication after resuming from standby?

    Thanks!

  • Anyone know the answer to this please?

  • It should be in System Settings, look for Privacy or Lock…

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • my system it was working, some updates about gdm freeze my my login screen, anyway I reinstall the system and everything it is working now, any I am will make attention when updates come here on my laptop.

  • @ricardodomingos97 said

    I have the same situation here, last updates are making the Antergos a terrible distro

    Such comments don t give enough info so that the community can help. When you say “same situation here” you mean you switched to gdm, too? If so, have you looked into your system settings, as I have already said, before?
    So, please, help to make Antergos a better distro…:+1:
    Cheers

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @a4orce84

    As Anarch stated, the requirement for password to access your system after standby is in ‘Settings’. Click on ‘Privacy’, then click on ‘Screen lock’, turn on ‘Automatic screen lock’ to enable it, specify the time and if you want to view notifications.

  • Switching to GDM (from LightDM) and it appears my gnome desktop environment is slightly different. I am missing the pop-out menu on the left-hand side:

    alt text

    It also appears there are some other minor differences with my gnome environment. Are there other changes behind the scenes that happen when you go from LightDM to GDM?

    Thanks,
    Asif

  • Anyone that knows the answer? TIA.

  • To give a bit more information, I am using xscreensaver as my manager to control screensaver settings. I checked the box for logging in after a few minutes, but when I move my mouse, I am NOT greeted with any credentials / log-in information.

    Do I need to do some extra work with xscreensaver and GDM ?

    Thanks,
    Asif

  • @a4orce84 said in GDM - Not Prompting For Password After Standby:

    Switching to GDM (from LightDM) and it appears my gnome desktop environment is slightly different. I am missing the pop-out menu on the left-hand side:

    alt text

    It also appears there are some other minor differences with my gnome environment. Are there other changes behind the scenes that happen when you go from LightDM to GDM?

    Thanks,
    Asif

    Did you install the Top Icons Plus extension by any chance?

  • I did NOT. Thanks.

  • @a4orce84 said in GDM - Not Prompting For Password After Standby:

    I did NOT. Thanks.

    OK, no problem. I also did the same thing as you - uninstalled LightDM and installed GDM, and I am ALSO using XScreensaver as my screensaver application. While I was able to get the screensaver going, my gnome also stopped asking for a password after resuming from a screen blackout/suspend.

    To get the computer to start asking for a password again, I did what has been shared above already - Settings > Privacy > Screen Lock - On.

    0_1499369048401_Privacy-Settings.png

    To get XScreensaver and Power to play nicely together, I used the following settings…

    0_1499369468492_xscreensaver-demo.png

    0_1499369492198_xscreensaver-advanced-preferences.png

    0_1499369517870_Power-Settings-with-Automatic-Suspend-Delay.png

    Notice how I’ve timed the system suspend setting to kick in after xscreensaver suspends the monitor. This whole arrangement allows my computer to display a screensaver for 15 minutes, after which the monitor is suspended (in which time if I have walked away for a short while, I can walk back to my computer and resume work again). When xscreensaver has suspended my monitor and the system is truly idle, the Power settings kick in, blacking out the monitor after a further gap of 15 mins, and another wait for 30 mins before the computer is fully suspended. This is for when I leave my seat at night, and leave the computer to be suspended till the next morning.

    Hope this helps you.

standby3 password20 gdm33 prompting1 Posts 12Views 843
Log in to reply