• Package Advisory: webkit2gtk-2.14.3-1


    Updating to the latest version of the webkit2gtk package breaks the login screen (for users of lightdm-webkit2-greeter). We are currently investigating the issue.

    Click here to see the full blog post

  • @lots.0.logs thank you very much, i turned on my pc > updated > opened antergos forum > read your post > downgraded the package :)
    👍

    PS: If someone already installed and restarted your pc can downgrade the package:
    Enter terminal mode with Ctrl+Alt+F2
    login
    wget http://ala.seblu.net/packages/w/webkit2gtk/webkit2gtk-2.14.2-2-x86_64.pkg.tar.xz
    sudo pacman -U webkit2gtk-2.14.2-2-x86_64.pkg.tar.xz
    reboot
    Cheers!

  • Wow! @fernandomaroto

    Very thanks for this tip, you’re the man 💪

    Im waiting while for the fix. So keep calm and bless linux. 🐧

  • indeed a great tip, just annoying that pamac keep pushing for the update

  • @darknet you can ignore it in pacman.conf but they’ll have it fixed before you know it

  • Thank you for the info, just downgraded the package. I hope I encounter tomorrow no problems after switch on the pc.
    This is the second time that the login screen is broken by an update within the last 2-3 months. I think it might be an idea to switch to another login screen. Xubuntu has a very nice, simplified and fast login screen, they use lightdm-gtk-greeter.

  • @darknet said

    just annoying that pamac keep pushing for the update

    You can tell Pamac to ignore it. There s a setting for this in its preferencies…

  • Thanks a lot Fernando, just applied your suggestion regarding the downgrade, and everything is fine. I will be checking to see if a solution has been issued, and yes I might try a different login screen.

  • @fernandomaroto Hello, I just entered this into my tty but after entering the first line i get an error saying:
    Resolving ala.seblu.net (ala.seblu.net)… 62.210.204.83, 2001:bc8:3173💯:1
    Connecting to ala.seblu.net (ala.seblu.net) |62.210.2014.83|:80… connected.
    2017-01-19 044:37:49 ERROR 404: Not Found.

    i have just installed antergos today and having issues with the lightdm failing.
    Any help would be appriciated

  • @menesdal There’s a new lightdm-greeter package which fixes the issue with the latest webkit2gtk package so if you run pacman -Syu you should pick it up

  • i can confirm this, after the update all works fine over here

  • it’s very strange, my Lightdm still not working. Just black screen and mouse arrow. What can be problem?

  • @Kozeb You probably need to access a mirror that has the latest packages. Sounds like yours hasn’t updated yet.

  • @Swipe Yes, I think you right. If I downgrade version, it’s working normaly.
    Ooo, just now come new update with lightdm-webkit2-greeter! What do you think should i updeate it ;)? And update webkit2gtk?

  • The latest update 2.14.3-1 fixed this issue for me. I was able to return to lightdm with no issues.

  • @Swipe so after i launch antergos and it goes to tty lightdm should fail, then i hit alt + f2 and just enter pacman -Syu ? I am very new to this just trying to get it installed sorry if im asking basic questions

  • I updated and confirmed everything works again with LightDM. Only thing is it appears to be a bit laggy, when entering my password for example, but it works!

  • I am now putting in pacman -Syu but keep getting
    error: failed retrieving file ,multilib.db
    A lot of times. idk what is wrong

  • @menesdal , I don t know what you did but the correct steps are:

    • Reach that black screen
    • Hit CTRL+ALT+F2 (try another F key if F2 fails)
    • Type your user name when prompted
    • Type your password
    • Run sudo pacman -Syu or sudo pacman -Syyu to also refresh data basis
  • I just updated and the bug is fixed. I noticed some kind of “fading efect” on screen after login as @a4orce84 said.

    Cheers!

advisory2 Posts 24Views 5860
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.