• How to add NAS to Plex

    Hey guys, I am struggling with how to add my synology NAS to plex. There doesn’t seem to be any straight forward guide anywhere. After reading a lot of posts I think the best way is to use NFS and have my shares automount. I am not sure how to do this. I am not new to Linux, however I just switched from debian based systems to Antergos and so far it is great. I would really appreciate some help?

  • https://wiki.archlinux.org/index.php/NFS#Client

    Try manual mounting first, to check that it is working.

    Will be the synology always on? Then you can add your nfs folders to automount in /etc/fstab
    More info: https://wiki.archlinux.org/index.php/NFS#Mount_using_.2Fetc.2Ffstab

    If not, you should use autofs:

    (it’s what I use, and works fairly well).

  • Thanks so much for the info, I will work on this and get back to you. As far as my NAS goes, it is always on except for when it reboots after an upgrade.

  • Well I didnt get very far, I am stuck on step 1 which is to manually mount my NAS.
    After I enter “sudo mount -t nfs -o vers=4 JStation:/volume1/Movies /mnt/NAS”
    I get this error - “mount.nfs: Failed to resolve server JStation: Name or service not known”

    Any ideas?

  • I tried the same line using instead the IP of my NAS and it seemed to have worked
    sudo mount -t nfs -o vers=4 /mnt/NAS

    I went to check in nautilus to see the contents of my /mnt/NAS folder and it tells me I don’t have the permissions to see the content?

  • It’s better to use the hostname and not the IP. To be able to do that you can add this to your /etc/hosts file:      JStation

    And I think you don’t need to add vers=4 when mounting as I think is the default

    I’m sure you have a UID/GID problem. In a terminal, what does sudo ls -l /mnt/NAS return? (after having mounted it, of course).

  • [email protected] etc]$ sudo ls -l /mnt/NAS
    [sudo] password for jamie: 
    total 17554980
    drwxrwxrwx  2 nobody users       4096 Sep 25 17:21 '1962 Kid Galahad DVD'
    drwxrwxrwx  4 nobody users       4096 Mar 31  2014 '47 Ronin 2013 BRRip 720p x264 AAC - KiNGDOM'
    drwxrwxrwx  4 nobody users       4096 Sep  3 20:10 '[ALETORRENTY.PL]Heavy Metal 2000(2000)-alE13'
    -rw-rw-rw-  1 nobody users 1803005287 Aug 28  2015 'Aloha (2015) 720p BRRiP DD5.1 x264 NLSuBS.mkv'
    drwxrwxrwx  3 nobody users       4096 Jan 15  2014 'American Reunion Unrated BRRIP'
    drwxrwxrwx  4 nobody users       4096 Sep  3 20:10 'Ant-Man 2015 1080p WEB-DL x264 AC3-JYK'
    drwxrwxrwx  5 nobody users       4096 Sep  2  2014 'Avatar Extended Collectors Edition (2009)'
    -rw-rw-rw-  1 nobody users 2070721687 Jun 16  2015 'Avengers Age of Ultron - (2015) - (720p) - [HDTS] - Makintos13.mkv'
    drwxrwxrwx  3 nobody users       4096 Jun 16  2015 'Avengers Age of Ultron 2015 NEW SOURCE 720p HDTS XVID MP3 TiTAN'
    drwxrwxrwx  6 nobody users       4096 Mar 30  2016 'Back to the Future Trilogy 720p'
    drwxrwxrwx  4 nobody users       4096 Sep  2  2014 'Batman Begins 2005 BRRip 1080p'
    drwxrwxrwx  4 nobody users       4096 Sep  3 20:10 'Batman The Killing Joke 2016 1080p BluRay x264 DTS-JYK'
  • Ok, so I changed the squash setting in my NFS privileges and now I can access the mounted folder. I also added this line to my fstab; JStation:/volume1/Movies /mnt/NAS nfs rsize=8192,wsize=8192,timeo=14,_netdev 0 0

    I also edited my hosts file like you mentioned above.

  • This post is deleted!
  • This post is deleted!
  • @jamie.junod
    The only way I have ever been able to mount my Synology DS215 at boot and that was by adding it to fstab using this line. But you must also create a folder in your home directory for the NAS to mount.
    //NAS_IP/NASFOLDERNAME /home/YOURUSERNAME/NAMEOFFOLDERSAVEDINHOME cifs username=nasusername,password=naspassword,uid=1000,nounix,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
    Its all one line, but the post is limiting. There is a space between ‘cifs’ and ‘user name’ and ‘/nasfoldername’ and ‘/home’ but as mentioned it is all one line. I could send you a screenshot of how it looks if you want.

    Since using this line in fstab I have stopped using gvfs and gigolo and the speed
    and search has improved.

  • Thanks for all the help, I have it working now.

  • @jamie.junod Good to see you got it working.

    Just out of curiousity Jamie, how did you do it in the end?

nas9 plex5 Posts 13Views 2499
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.