• Middle click Emulation (paste and open new tabs) disabled!


    Hi, today i just noticed that mouse middle click to paste and open new tabs is not working, I MEAN USING TWO BUTTONS TO EMULATE). Did anyone noticed it too? I didn’t mess the system, so i guess was some update…

    PS: yesterday there was an update in xorg
    Should i fix with this? [https://bbs.archlinux.org/viewtopic.php?pid=847309#p847309](link url)
    Cheers!

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • Someone please help! i use the left+right click to emulate middle click a lot and need to fix it…

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • Seems to be working fine on Cinnamon here.

  • Hi all! i really didn’t discover what/how the config stopped working, but just fixed following the instructions beneath from the link [http://unix.stackexchange.com/questions/9973/configuring-mouse-for-rightleft-button-simulating-middle-click-for-copy-paste#9992](link url)

    The third mouse button can be enabled system wide by adding a file /etc/X11/xorg.conf.d/20-3rdbutton.conf with the following content:

    Section "InputClass"
    Identifier "middle button"
    MatchIsPointer "on"
    MatchDriver "libinput"
    Option “MiddleEmulation” "on"
    EndSection

    It seems that the problem only happened to me, that’s weird that even downgrading ALL the packages to a day before the issue didn’t solved the problem,…

    But now everything is fine, and if someone else have the problem can fix following the instructions on the link.

    Cheers!

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • I reopened the post, since i reinstalled my system the middle click emulation is gone again, and the previous solution no longer work…

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • Ok, the same solution worked; My observation is that if you create the file and reboot the system won’t be able to boot, then after creating the file you need to close session>relogin> only then reboot.

    Marking as solved again!

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

middle1 paste1 click8 tabs1 Posts 6Views 369
Log in to reply