• Blender graphical glitches


    This is how it looks: https://youtu.be/zQNqeKYhAMY

    Using Antergos Linux 64-bit with GNOME Version 3.22.2 on:
    Intel Core i5 2500K
    AMD Radeon HD 7970 (which is showing in the details as: Gallium 0.4 on AMD TAHITI (DRM 2.46.0 / 4.8.13-1-ARCH, LLVM 3.9.1))
    8 GB of RAM

    I installed Blender through AUR. Graphical problems. Reinstalled it. Same. Tried downloading from https://www.blender.org/ and running it as is. Same thing.

    Thought that maybe I needed to install AMD drivers for my 7970 but I don’t know how to do it properly. I tried the method explained in this video https://youtu.be/0P-mG8s8Deg but the first command:

    sudo pacman-key -r 653C3094
    

    returns:

    gpg: keyserver receive failed: Network is unreachable
    ==> ERROR: Remote key not fetched correctly from keyserver.
    

    I have to mention that when I first installed Antergos I installed it with Chromium and Flash Player. Chromium was having some weird visual glitches as well so I installed Chrome and uninstalled Chromium. Chrome was also having the same problems so I thought about uninstalling Flash Player and it worked for some reason.

    What is the source of the problem here? How do I solve it? I’m new to Linux. I installed Ubuntu before Antergos but it was a horrible user experience in my opinion. Antergos with GNOME is really up my alley and I would like to use it for web development and 3D modelling, but I have to get this deal breaking issue fixed first.

  • The only thing I can think of is to try the new amdgpu drivers.

    https://wiki.archlinux.org/index.php/AMDGPU

    It’s not an easy task, as if I’m not mistaken, you’ll have to recompile your kernel. Check the section “Enable amdgpu for Sea Islands or Southern Islands cards”.

    The other driver you can try is the catalyst one:
    https://wiki.archlinux.org/index.php/AMD_Catalyst
    The problem with this one is that it does not support xorg-server 1.18 (and current version is 1.19!). So you’ll have to downgrade to xorg-server 1.17 (which imho, is a pita).

    Sorry that I do not have better news. To be honest, I think you’ll have better success with a non-rolling and older distro. You could try Gnome Ubuntu (and better if is not the latest release, but one from 2015 or so).

    Cheers!

  • @karasu Yeah, I’ve been trying every method out there since yesterday. I was able to get it sort of working (without the graphical glitches) but I couldn’t make Blender use the GPU to render. I tried Fedora with Gnome but I also had trouble installing AMD drivers. I’m using Ubuntu GNOME right now but that’s a whole can of worms in it’s own right. Antergos was the distro I had least troubles with, apart from the glitches in Blender.

    There’s also a weird thing that happened to me. After reinstalling Antergos and searching for AMD drivers in AUR, I found the Catalyst drivers (official drivers, apparently). There were multiple entries so I tried installing the main one. After installation I read the details and it said I had to install the other components for it to work, so I searched for Catalyst again but now it only had one entry for the driver I just installed. I tried uninstalling that and searching again but it returned nothing. I couldn’t find it even after reinstalling Antergos. So there’s a ghost story for you.

    I’ll probably just have to stick with Windows 10 since there I can at least work without much problem. Such a shame. I really liked Antergos with GNOME. The only problem is with the drivers, and from what I’ve read it seems like it’s only getting worse.

  • Same on me… I’m using open-source drivers… Try to start in terminal and look what’s wrong? 0_1484717242928_blender crushes termmessage.png

  • Hi,

    jack is an audio server. You really don’t need it to work with Blender, so I think that this error has no relation with any graphical glitches you may have.

  • @karasu yes i know…but that’s the terminal message.

  • @omerdemirbag which graphics card do you have?

  • @karasu ati mobility radeon hd5xxx

  • @FelliVox user preferences > system > window draw method… holy crap!
    @karasu

  • @omerdemirbag So that solves the glitches? I reinstalled many times, many different distros, so I don’t have the same installation to try now. But I still couldn’t get the drivers working so I could use my GPU to render. I got Blender working fine without glitches in several installations, but couldn’t get it to use OpenCL to be able to render with the GPU. So it’s still a deal breaker.

  • @FelliVox it solves, yes…

    Blender’s gonna experience a poor period, but imo coders will support gpu rendering with opencl on some day ;)

  • @omerdemirbag Then I guess the main issue is solved. I’ll just have to stick with Windows if I want to actually render anything in less than 3x the time it takes the CPU to do it. I’ll keep trying to get it working on Linux, I guess. Maybe someday…

blender6 graphical4 graphics issues2 graphics driver5 Posts 12Views 547
Log in to reply