• Inconsistent Mouse Live USB


    Hello all,

    I have Antergos running on my Lenovo laptop just fine, no real issues at all so far and absolutely love it. However I’m running into a very frustrating issue with my main PC. The issue is strange, let me detail it as best as I can.

    Issue:
    When I boot the live USB, Antergos boots up, and Cnchi pops up ready to go but I have a key problem, I am unable to click the buttons of any box that pops up on top of the Cnchi window. Partitioning options for example. The buttons seem to register the clicks, in a sense - that is you can see them being clicked, but no action is taken and the options of the box can’t be changed via the mouse or the box closed. (You can obviously get around this by using the keyboard).

    I wondered whether this was just an issue with Cnchi or something, but when some of my bios settings are changed to be different from the settings below, such as fast boot disabled, the mouse seems even worse, and I can’t even change the wallpaper, for example. It doesn’t allow me to click a wallpaper or scroll, but the mouse still moves and can exit the wallpaper window. However, if the settings on the bios are exactly as below, the wallpaper problem is no longer an issue but the Cnchi problems are. (Just to clarify, it’s not just wallpaper, sometimes I can’t click or register that my mouse is hovered over the icon bar, or even click the buttons on the top bar.

    Bios Settings:

    Fast Boot - Enabled
    Secure Boot - Other OS
    No to booting USB with UEFI
    Legacy USB Support - Enabled
    XHCI Handoff - Enabled
    

    It’s very strange, and I’m relatively new to Linux (fed up with Windows 10). I have had this exact issue however with Ubuntu, when i tried that on the same computer, (and this was after I had installed it) - it was just consistently failing to register mouse clicks, or do anything about them, but for a few seconds it would work every now and again. So it must be an issue with something both distros are using, and it’s compatibility with my hardware.

    I’ve tried a different mouse, I’ve tried the mouse in USB 3.0 and 2.0 ports, still with no improvement. I’ve searched everywhere for help, and absolutely nothing has worked. (Although I’ve not come across any exact issue like this one).

    So I am now thoroughly stumped, and would love to hear any suggestions.
    Is it worth completing the installation to see if it’s an issue when I’m running on my SSD?

    Thanks in advance for any help.

    Specs Below:

    CPU - Intel Core i7 6700K @ 4.00GHz
    RAM - 24 GB Corsair Vengeance
    Motherboard - ASUS Maximus VIII Hero (LGA 1151)
    Storage - 2 x 480 GB Sandisk Ultra II, 1 TB Toshiba, 2 TB Western Digital
    Network - TP Link Archer, Ethernet (This is how I'm connecting)
    Mouse - Roccat Kone XTD (tried a bog standard advent mouse)
    Keyboard - Advent (Wireless)
    GPU - EVGA GTX 1080 (Currently removed as can't move mouse at all with it in)
    
  • Hi all,

    After 4 weeks of trying to get this to work, I have found that it’s all down to a USB receiver for a pair of Corsair Void Wireless headphones. Couldn’t believe it, when I removed it, the mouse started working perfectly!

    Feel free to close this topic down.

  • This post is deleted!
clicks2 mouse41 mouse crash4 cnchi104 Posts 3Views 330
Log in to reply