• No Czech (extended) characters input in wine

    I’m unable to enter any UTF-8 Czech characters like ěščřžýáíéúů in any Wine application. When I open a document containing any of these characters, they display just fine. Also, if I copy these from a Linux native app, I’m able to paste them to Wine and they display correctly. But there is no way to enter them with the keyboard. When for example the “č” key is pressed, just nothing happens. Just like I haven’t pressed any key at all. where the shoe pinches

    This issue has never occurred on LinuxMint I used before. It is persistent on any Arch based system I’ve tried (Manjaro, Netrunner). The DE doesn’t matter. Also, the Wine app doesn’t matter - from explorer.exe through notepad.exe to MS Office 2007 or 2010.

    My system locale is:

    [[email protected] ~]$ locale
    [[email protected] ~]$ locale -a
    [[email protected] ~]$ 

    I’ve tried to change the locale for Wine, which surprisingly brings a minor change. When I run

    LC_ALL=C wine notepad.exe

    I can type some of Czech chatacters, specifically “ýáíéú”.

    It may be of interest, that in a console (TTY 2 to 6) the environment is in English, although locale and locale -a give the same output as in DE.

    Does anybody have a clue, where the shoe pinches?

    Thanks for any advice.

  • After some more digging I learned, the the cause could be the libx11-6 library. I’ve found a Debian user with same issue. He managed to solve it by downgrading from 1.6.4-2 to 1.6.2-3. My version is 1.6.4-1. How potentially dangerous could it be to downgrade it?

  • It is usually safe enough to downgrade a package, and use the lower version for some time. The time may vary from some days to some months. Everything depends on a package’s characteristics and every particular system configuration.

    For example, I have two downgraded packages. One is in-line for two, another - for three months. It helps the systems to work flawlessly. The downside is that I don’t know when it will be safe to use the recent packages versions again.

    In your case, you may downgrade to immediately preceding libx11-1.6.3-1-x86_64.pkg.tar.xz version, not to 1.6.2-3 as in Debian.

    In any case, downgrading is not a good practice. We’re doing it at our own risk.

  • SOLVED! Downgraded libx11 to version 1.6.2-2, diacritics now types and shows just fine. Where and how can I report this issue in Antergos or Arch to get the latest version fixed?

  • @vlad.kuzba The package is not maintained by Antergos devs. So there’s no sense to report it to Antergos.

    You may use Arch bugtracker to report the issue.

input15 characters7 extended4 czech2 Posts 5Views 990
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.