• Problem with upgrading: local is newer than antergos


    I am getting the warnings below when I upgrade the packages in my system:

    warning: lightdm-webkit2-greeter: local (2.2.1-1) is newer than antergos (2.1.6-1)
    warning: numix-icon-theme: local (1:0.r1890.2-1) is newer than antergos (1:0.r1890-1)
    warning: numix-icon-theme-square: local (1:0.r83_8-1) is newer than antergos (1:0.r83_7-1)
    warning: pamac: local (4.1.7-1) is newer than antergos (4.1.6-2)
    warning: pepper-flash: local (1:24.0.0.186-1) is newer than antergos (1:23.0.0.207-5)
    warning: qt5-styleplugins: local (5.0.0.1r32-1) is newer than antergos (5.0.0.1r29-1)
    warning: terminix: local (1.4.2-1) is newer than antergos (1.3.5-1)
    warning: vivaldi: local (1.6.689.34-2) is newer than antergos (1.5.658.44-1)
    
    

    The versions of the packages in the antergos repositories do not correspond, I believe, to those listed above. For instance, the version of the vivaldi browser in the antergos repository is 1.6.689.34-2, and not 1.5.658.44-1.

    I found an old topic in this forum that suggests waiting. I am, however, a bit confused with the packages version numbers, as explained above.

  • Sounds like the update server you are connecting to is outdated. You can check which servers you are using by editing the /etc/pacman.d/antergos-mirrorlist file.

  • This is what I have in /etc/pacman.d/antergos-mirrorlist:

    http://pastebin.com/g4PQWeWM

    BTW, I am having this problem in three different notebooks that run Antergos. In one of them, I installed Antergos from scratch yesterday.

  • The only solution that worked for me:

    sudo rankmirrors -n 0 /etc/pacman.d/antergos-mirrorlist > /tmp/antergos-mirrorlist && sudo cp /tmp/antergos-mirrorlist /etc/pacman.d
    
    sudo pacman -Syyu
    
upgrading4 newer1 Posts 4Views 786
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.