• Issues with USB Headset


    Hi, so I’ll preface this with the fact that I am new to using linux as a desktop environment and also new to Arch in general, I’ve primarily used Debian.

    I’m having issues with getting my USB headset to be recognized. From what I’ve gathered so far it’s related to PulseAudio but I don’t know enough about it in order to debug it and researching it has proven fruitless.

    Basically, my headset (HyperX Cloud 2) shows up under alsamixer, but not under the sound panel under settings. I managed to somehow get it to display after unplugging it and plugging it back in but even then it would not function. It does work, if I unplug the headset from it’s USB soundcard it came with and use the 3.5mm jack on my front panel.

    The interesting thing is, as I was distro hopping to find one I really like, I had this exact same issue on Fedora 25, but not on Debian 8, Elementary, or CentOS. So I’m assuming that it’s related to a version of something that’s installed or the lack of something being installed.

    I appreciate any assistance and apologize if I’m being an idiot (very new to linux desktops).

    Thanks ahead of time.

  • @MattTreck What do you see if you use pavucontrol? (install it with sudo pacman -S pavucontrol)

  • @karasu said in Issues with USB Headset:

    @MattTreck What do you see if you use pavucontrol? (install it with sudo pacman -S pavucontrol)

    The same thing as the sound app. Which is only my DisplayPort cable running to my monitor.

    If I unplug the headset and plug it back in it shows up there also. But as with the other app, selecting it does nothing. And if I select the DP connection it disappears until I unplug it again.

    Thanks!

  • selecting it does nothing

    That’s odd. If it shows up it’s that it is detecting it.

    In pavucontrol, check the last tab Configuration. I have a bluetooth headset and I had to choose the correct Profile the first time (it works with A2DP sink for me).

    Oh, and in Output Devices tab , check that it appears correctly and it’s not muted.

    Also, you can try to add this to your /etc/pulse/default.conf so it changes automatically to your headset when detects it (but I don’t think it will solve your problem).

    # switch the output sound to the newly connected device
    load-module module-switch-on-connect
    

    Hopefully somebody with an USB headset shows up and helps…

  • @karasu said in Issues with USB Headset:

    selecting it does nothing

    That’s odd. If it shows up it’s that it is detecting it.

    In pavucontrol, check the last tab Configuration. I have a bluetooth headset and I had to choose the correct Profile the first time (it works with A2DP sink for me).

    Oh, and in Output Devices tab , check that it appears correctly and it’s not muted.

    Also, you can try to add this to your /etc/pulse/default.conf so it changes automatically to your headset when detects it (but I don’t think it will solve your problem).

    # switch the output sound to the newly connected device
    load-module module-switch-on-connect
    

    Hopefully somebody with an USB headset shows up and helps…

    So I think that your previous recommendation actually worked, but I was having another issue unrelated to the OS that I’ve now fixed.

    When I select the headset in the OS’s Sound App I’m noticing that it’s not switching the profile at the bottom nor giving me the option to. However if I select it in the pavucontrol app it does in fact switch it

    It looks like we’ve got it working now, thanks a ton! Loving the OS.

  • Glad it worked!

    Cheers!

usb54 headset2 issues40 Posts 6Views 424
Log in to reply