• Antergos Macbook runs very hot


    I really, really love Antergos, but I’ve noticed that it runs very hot. At idle, it sits around 50c, but even if I am simply watching a youtube video, it climbs to 70-80C. I have read various topics here and on other resources documenting a similar issue, but none of their solutions have solved my probem. I have done a number of things to try to alleviate this problem, but to no avail.

    I have installed mbpfan, which helps to set a min/max fan RPM.
    Thermald, using default configuration
    CPUPower, set to PowerSave
    My graphics card driver is installed as well.

    I have a late '14 Macbook Air, and I am running Gnome.
    I am unsure of what to try next. Any help would be greatly appreciated.

  • @tree_fingers Have you tried tlp? (it’s more to control your battery, but maybe helps).
    https://wiki.archlinux.org/index.php/TLP

    Which graphics card do you have? Also, which wireless chip?

  • Hi there, thanks for your help.
    I have just installed TLP. I will let you know if it helps. I have a broadcom BCM4360 WIFI chip. My graphics card is: Intel Corporation Haswell-ULT Integrated Graphics Controller, and the driver I am using is xf86-video-intel.

    Thanks again for your help!

  • So, after some experimenting, I think the problem has something to do with my wifi driver. I have been connected to the internet via a usb dongle today, and my temperatures have been MUCH lower. WIthout the wifi dongle, my computer would sit at like 75-80c watching video, using the wifi dongle it sits at around 60C. I would prefer not to permanently have a wifi usb dongle attached to my computer. Does anyone have any suggestions as to why using the broadcom chip would result in such high temperatures?

    Thanks!

  • Which driver are you using? wl? b43?

  • I’m using broadcom-wl. I installed through yaourt.

  • What’s the output of lspci -nn -d 14e4: ?

    Then you can check if b43 supports it:
    https://wireless.wiki.kernel.org/en/users/Drivers/b43

    Also, you can try enabling power management with sudo iwconfig wlan0 power on

  • Thanks for the tip. B43 doesn’t support it, I think WL is my only option. I have adjusted the range at which the fans turn on, and I think I will just have to deal with the higher temps. It doesn’t normally get too much hotter 80C. It’s a small annoyance, but I’m not sure that there is anything else I can do. I really appreciate all of your support, though. I did try enabling power management. Perhaps this will make it a little better.

macbook22 runs1 hot1 Posts 8Views 1136
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.