• Nvidia and mesa Causing Lagging Desktop


    I’m installing Antergos on a Dell Inspirion laptop with a GTX 960M graphics card.

    When installing, I selected “install nonfree nvidia drivers” on the installation menu. But, when I first started the laptop up, I couldn’t get to the lightdm login screen (my screen was just black, with a movable cursor).

    Installing mesa-libgl over nvidia-libgl seemed to fix the problem, and i could get into the Cinnamon desktop. But now the problem is the whole desktop is very laggy, and extremely choppy.

    I’d like to be using the nvidia proprietary drivers, but installing nvidia-libgl is out of the question, as I can’t even get it to the login screen. And using mesa causes the desktop to be slow and choppy.

    So how do I fix this?

    EDIT: I’ve tried installing intel-ucode (https://wiki.archlinux.org/index.php/Microcode) , and updating grub, but nothing. I still get a black screen with nvidia-libgl installed instead of mesa-libgl

  • @anarchist said in Nvidia and mesa Causing Lagging Desktop:


    So how do I fix this?

    By reinstalling, thoroughly following the Bumblebee for NVIDIA Optimus article in Antergos WIki.

  • @just

    Thanks for the reply.

    Actually, installing bumblebee w/ optimus didn’t fix the desktop lagging. Strangely, I switched from Cinnamon to Budgie DE and that fixed the lagging. I guess it wasn’t the drivers or hardware, but the desktop environment.

  • @anarchist For nothing.

    Antergos Cinnamon has a few problems and doesn’t work well enough right now. There’re many posts in the forum reporting various Cinnamon problems in recent hours.

    For already existing Cinnamon installations Antergos devs suggest to delay Cinnamon upgrades for a few hours, here and here.

    For me, it looks unusual that you successfully run Cinnamon without big problems, excluding lagging, in such a situation.

  • Interesting.

    I just thought it strange because both XFCE and Cinnamon had the same lagging issues, which is why I thought the drivers were the problem. But, for the most part, Cinnamon ran fine excluding the lagging (python 3.6 did cause issues, such as not being able to open some cinnamon settings apps.)

  • @anarchist said in Nvidia and mesa Causing Lagging Desktop:

    …which is why I thought the drivers were the problem…

    My first answer was for the correct way of proprietary Nvidia driver installation, not the lagging problem.

    As I never experienced such a problem, I have no solution for it.

    For sure, the lagging doesn’t depend on Nvidia driver. On Optimus computers the whole system runs by default on Intel GPU 99,9% of time. Including all DE components. In other words, it runs using xf86-video-intel driver, not Nvidia. It is the default Bumblebee behaviour.

    Most people believe that with Bumblebee it’s impossible to run on Nvidia by default. It is not true. It is possible.

    But. Very advanced tweaks are needed to make the system run on Nvidiaby default. I never published them, nowhere, and will never do that.

    Briefly. With Bumblebee installed, the system always runs by default on Intel GPU (using xf86-video-intel), and never on Nvidia GPU. The lagging problem lies somewhere else. I have no solution for it.

  • @anarchist You could try to do the following test.

    Reinstall XFCE or Cinnamon, where the lagging happens. Remember to not enable Nvidia driver installation. Do not install Bumblebee.

    After a clean installation, there should be two video drivers installed:

    • xf86-video-intel
    • xf86-video-nouveau

    Uninstall nouveau; I do that always, in all distros, in all DEs, immediately after a fresh installation:

    sudo pacman -Rc xf86-video-nouveau
    

    After that, only Intel driver will remain - xf86-video-intel. This is an ideal starting point for all Optimus computers.

    Reboot.

    If the lagging is still present, at least you’ll be sure that it doesn’t depend neither on nouveau nor on nvidia video drivers.

causing1 nvidia99 mesa8 lagging1 Posts 7Views 521
Log in to reply