• My system time is off and I can't fix it!


    I have a fully updated Antergos system with Gnome 3 installed. For some reason, I can’t get my time correct. I have Gnome set to automatically get the date, time and time zone. It puts in me in New York which is fine since I need Eastern time. However, my clock is currently 73 minutes behind. I copied my timedatectl status below:

    [[email protected] ~]$ timedatectl status  
    Local time: Wed 2014-03-26 18:09:41 EDT  
    Universal time: Wed 2014-03-26 22:09:41 UTC  
    RTC time: Wed 2014-03-26 22:20:26  
    Timezone: America/New\_York (EDT, -0400)  
    NTP enabled: yes  
    NTP synchronized: no  
    RTC in local TZ: no  
    DST active: yes  
    Last DST change: DST began at  
    Sun 2014-03-09 01:59:59 EST  
    Sun 2014-03-09 03:00:00 EDT  
    Next DST change: DST ends (the clock jumps one hour backwards) at  
    Sun 2014-11-02 01:59:59 EDT  
    Sun 2014-11-02 01:00:00 EST
    

    Any help would be appreciated. I was almost late for work!

    PS, loving Antergos and AUR so far!

  • I have a fully updated Antergos system with Gnome 3 installed. For some reason, I can’t get my time correct. I have Gnome set to automatically get the date, time and time zone. It puts in me in New York which is fine since I need Eastern time. However, my clock is currently 73 minutes behind. I copied my timedatectl status below:

    [[email protected] ~]$ timedatectl status  
    Local time: Wed 2014-03-26 18:09:41 EDT  
    Universal time: Wed 2014-03-26 22:09:41 UTC  
    RTC time: Wed 2014-03-26 22:20:26  
    Timezone: America/New\_York (EDT, -0400)  
    NTP enabled: yes  
    NTP synchronized: no  
    RTC in local TZ: no  
    DST active: yes  
    Last DST change: DST began at  
    Sun 2014-03-09 01:59:59 EST  
    Sun 2014-03-09 03:00:00 EDT  
    Next DST change: DST ends (the clock jumps one hour backwards) at  
    Sun 2014-11-02 01:59:59 EDT  
    Sun 2014-11-02 01:00:00 EST
    

    Any help would be appreciated. I was almost late for work!

    PS, loving Antergos and AUR so far!

  • Hi,

    Did you install ntp? I’ve found that it’s the safest approach (as long as you have an Internet connection, of course).

    More info: [url:snvsmau2]https://wiki.archlinux.org/index.php/Network_Time_Protocol_daemon[/url:snvsmau2]

    Cheers!

  • Thanks for responding. After lots of searching, I finally found my answer which was changing the clocksource to hpet. This may have to do with Linux and my ASUS M5A99FX PRO R2.0 motherboard.

    NOTE: Your hardware has to actually support hpet. To find out what your system supports, use the command

    cat /sys/devices/system/clocksource/clocksource0/available\_clocksource
    

    If you see hpet and have a clock issue, you can follow these steps to switch:

    1. Edit /etc/deafult/grub[/color:1r01l6wo] with your favorite editor
    2. Find [color]GRUB_CMDLINE_LINUX_DEFAULT=""[/color:1r01l6wo] (you may already have options in the quotes)
    3. Add “[color]clocksource=hpet[/color:1r01l6wo]” inside the quotes and save.
    4. Lastly, run “[color]sudo grub-mkconfig -o /boot/grub/grub.cfg[/color:1r01l6wo]” to update grub and reboot[/color][/color][/color]
  • Nice finding!

    If you have the time, you could post this in our wiki: wiki.antergos.com

    Cheers!

  • I agree. This is a good find. And I would also encourage you to post the tut in the wiki.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • I had issues trying to register so I sent an email using the Info -> Contact section and am waiting on a response. Once I get registered, I’ll post the info. This will be my first wiki post of any sort.

    I would like to pass the credit the site/forum post I found the info on but I can’t find it anymore oddly enough even though I tried searching “hpet” in my history. I remember it was a bit dated because it said to use clock=hpet instead of clocksource=hpet. I only found that clock= was deprecated by looking at dmesg which said to change to clocksource. Also, I’m guessing the need to change was caused by Linux not working properly in the other clocksource mode with my particular board/chipset.

  • Had same issue and I wanted to investigate a bit further. I found the following article from the Arch site which provided a solution for me that works and it is simple: https://wiki.archlinux.org/index.php/Systemd-timesyncd

    Basically the only command I needed to run was: timedatectl set-ntp true

  • That looks like a MUCH more elegant solution. I’ll have to try this on my PC this week. I remember at the start looking for NTP issues. I never imagined I’d end up using a kernel parameter.

    This doesn’t appear to be a common issue as far as I can tell and my laptop never had it. Are you using AMD hardware by chance bmeister?

  • I am indeed using AMD hardware.

Posts 12Views 2582
Log in to reply