• Mouse stuck in upper left corner


    I’m having the same issue with a comparable system but these tips haven’t resolved my issue. I’m refusing to remove the graphics card as for now, this has to be solvable! Common :)

    Strange thing is that the mouse works fine, graphics work fine (although slow) but the cursor icon is stuck in the upper left corner. Right clicking on he background I can see the mouse just moves fine just the cursor icon is stuck… rather frustrating. Anybody any ideas? Other then removing the nvidia card? :D

  • Hi!
    Is it possible that changing from libinput to evdev driver (or vice-versa) may solve the issue? (i don’t know since i’m newbie, but it’s worth to try it)

  • @got-it-man Yea that is strange. Removiing the card for installation wasnt ideal but it worked out in the end.

    Now im having a problem getting it scaled right on my 4K monitor. Everything is so tiny! Its either too big after i bump the HDPI setting to 2 in gnome or when tweaking it with xrandr through the terminal, some things look good while others dont. System wide scaling is one thing Windows 10 does really well with out of the box.

  • I got the mouse working for install using no acpi and no kms (press f3 and f4 when selecting boot option on live USB). Installed and the issue came back. Installed the nvidia drivers and now it’s working fine.

    It’s very slow at the moment but will figure it out, part of the fun of Linux on a new build right :)

  • @tjerk.plantenberg Don’t know why you guys don’t read the other posts, I’ve already suggested the solution with “No ACPI” :D
    Anway great to hear, that you could solve the problem ;)

    @got-it-man said in Mouse stuck in upper left corner:

    @gilad215 @joekamprad If it’s your first start and you trying to install Antergos then just press F4 after you selected the drive with the installation files at the boot menu.
    There should be 3 options: start from harddrive, start antergos-live and non-graphical boot
    At the bottom there’s language (F2), videomode (F3) and Kernel (F4).
    Just press now F4 and select inside the menu “No ACPI”, press Enter and start the Antergos-Live-System. Now you can install Antergos without having an invisible mouse.

  • @got-it-man Sorry, I fixed it thanks to your post so you deserve all the credit ❗ 👊

  • @tjerk.plantenberg No problem :P I know there are often many posts which don’t really help, but sometimes they help xD :D
    Anyway welcome to Antergos! The (probably) best Linux Distro out there :P

  • I installed Antergos onto my USB with GPT partition scheme for UEFI in rufus. When I boot from the USB UEFI I get to choose Antergos, Antergos (NVIDIA Fallback), Antergos (Non-Graphical Fallback) I choose Antergos. Then it loads into the os and intallation but the mouse cursor is stuck in the top left corner. When I press e it comes up with a line, I add noacpi and press ctrl-x but nothing happens, then I press enter and it’s the same problem. Please help me!

    Specs are:
    I5 6600k
    MSI GTX 1070
    MSI Z170 Gaming Pro Carbon

  • https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1646574

    GTX 1070 is same as inside the bug from ubuntu,
    so my opinion is to put: nouveau.modeset=0 to kernel parameters on boot

    if this does not work try: nouveau.blacklist=1

  • How do I set that and where do I set it?

  • @adamrydberg9 Bild Text
    simply choose language choose "Start Antergos Live and click to the "Boot Options lines end to write your parameter inside

  • I dont have that menu, mine looks like something else, is that uefi mode or legacy on the pic? Shall I install the iso as gpt or mbr?

  • @adamrydberg9 onto my USB with GPT partition scheme for UEFI in rufus… so do you have grub there? The best way is to put the image to usb stick as it is with dd

  • may you can choose the entry you want to start and press “e” give you a edit menue for the entry where you can add a kernel parameter

  • It does but I’m not sure how to apply the code

  • i never was able to use kinda uefi systems… can you pos a screenshot/picture ?

  • Should I install it as mbr instead? And I will hav the menu u showed me?

  • rufus has also a “dd” modus

  • I have the same issue with UEFI and a GTX1080.

    None of the proposed solutions have helped.

    Can I do something to help, I really want this to work.

mouse67 stuck45 left6 upper3 Posts 48Views 12583
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.