• Mouse stuck in upper left corner


    Mouse icon stuck in upper left corner but I can move around my mouse though it is “invisible”

  • Have the same issue, Tried to install my own system as thought I would give antergos a try.
    Already switched my daughters from Mageia as hers has an AMD 290x. (Mageia built mesa13 with llvm 3.8 :confused: )

    My system specs

    4790k
    GTX 1080 fe
    16gb ram
    ssds

    Have tried both 2016.11.20 iso and 17.1 iso. Both have the same problem

    Would be nice to know the OP’s specs/info :smirk:

  • @pete910 said in Mouse stuck in upper left corner:

    Have the same issue, Tried to install my own system as thought I would give antergos a try.
    Already switched my daughters from Mageia as hers has an AMD 290x. (Mageia built mesa13 with llvm 3.8 :confused: )

    My system specs

    4790k
    GTX 1080 fe
    16gb ram
    ssds

    Have tried both 2016.11.20 iso and 17.1 iso. Both have the same problem

    Would be nice to know the OP’s specs/info :smirk:

    GTX MSI 1070
    6700k
    16gb ram

  • @stellaris said in Mouse stuck in upper left corner:

    @pete910 said in Mouse stuck in upper left corner:

    Have the same issue, Tried to install my own system as thought I would give antergos a try.
    Already switched my daughters from Mageia as hers has an AMD 290x. (Mageia built mesa13 with llvm 3.8 :confused: )

    My system specs

    4790k
    GTX 1080 fe
    16gb ram
    ssds

    Have tried both 2016.11.20 iso and 17.1 iso. Both have the same problem

    Would be nice to know the OP’s specs/info :smirk:

    GTX MSI 1070
    6700k
    16gb ram

    Have a feeling it’s yet another NV driver thing on the 10xx series going on you have a 1070.

    Apart from my daughters, tested on my sons, he has a 390. Again no issues, worked out of the box.

  • For users with modern 10xx Nvidia Optimus cards.

    Try to exclude the malefic nouveau driver from being used. And to run on pure Intel.

    To blacklist nouveau, add to to boot line:

    modprobe.blacklist=nouveau
    

    This will disable xf86-video-nouveau, and the system will run on xf86-video-intel only. Remember, the trick works for Optimus cards only.

  • @just said in Mouse stuck in upper left corner:

    Optimus cards

    Not using a mobile chip, nouveau want loaded when I looked. I will try/check again though to be sure

    Thanks for the suggestion

  • @pete910 said in Mouse stuck in upper left corner:

    @just said in Mouse stuck in upper left corner:

    Optimus cards

    Not using a mobile chip, nouveau want loaded when I looked. I will try/check again though to be sure

    Thanks for the suggestion

    Just an update, Tried again last night to see if it was Nouveau.
    It is a Nouveau issue. Blacklisting just gives you the cli as no prop driver from what I can see

  • @pete910 Having the same issue since years :P Try to change the Kernel Mode to “No ACPI” at the startup.

  • @got-it-man said in Mouse stuck in upper left corner:

    No ACPI

    Damn, never though of that trick.

    Cheers, I will give that a go next time.

  • Update, The No ACPI trick fixed it for me.

  • I’m having this same issue with my GTX 1070. I’m not very savy on Linux as I’m just getting started, but can follow instructions and navigate the terminal well enough. Could any of you possibly explain in a little more detail how to add “modprobe.blacklist=nouveauabove” or changing the kernel mode to “No ACPI” if that doesn’t work for a novice?

    Thanks

  • for the noacpi option you can install grub-customizer but be carefull to check first save options, then install to mbr and check if you are booting from /dev/sda may you do not do and have to change it…
    Bild Text
    Here you can see kernel parameters section there you simple add noacpi after quiet.
    then save (left Top button) and File > Safe to MBR > Pop up give you standard locaten on Disk 1 (/dev/sda) you may change if not booting from Disk 1 !! > O.K. wait till finish PopUp appears

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • Facing the same issue aswell, can anyone explain how do i add the noacpi command from the grub itself? im using windows right now trying to flash the iso to the usb, maybe i can edit the grub from windows? thanks

  • @gilad215 you can add while booting, then it is not permanent but you can login to Antergos.
    Press “e” when grub menue appears, go to line where you find “quiet” after this put “noacpi” that it looks like this:
    Bild Text
    then press [Strg + X] or F10 to boot, to make this permanent use grub-customizer as above discribed.

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @gilad215 @joekamprad If it’s your first start and you trying to install Antergos then just press F4 after you selected the drive with the installation files at the boot menu.
    There should be 3 options: start from harddrive, start antergos-live and non-graphical boot
    At the bottom there’s language (F2), videomode (F3) and Kernel (F4).
    Just press now F4 and select inside the menu “No ACPI”, press Enter and start the Antergos-Live-System. Now you can install Antergos without having an invisible mouse.

  • @joekamprad thanks, it worked.
    now facing a different problem, it seems after i install nvidia drivers, my machine still uses the nouveau driver even though the nvidia drivers suppose to blacklist it…any help?

  • @gilad215 Maybe this can help out:

    pacman -Syy nvidia nvidia-utils nvidia-libgl
    pacman -Rccn xf86-video-nouveau
    nvidia-xconfig
    
  • If you want keep nouveau driver installed, but using the nvidia driver:

    you need to modifi /etc/mkinitcpio.conf change the line

    MODULES="nouveau"
    

    to this

    MODULES=""
    

    then:

    sudo mkinitcpio -p linux
    

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • Success! Finally got it running with the GTX 1070 card in. Thank you @joekamprad and @got-it-man for taking the time to help me.

    Even after inserting the noacpi text into the grub console as suggested, I still was unable to run the installer using the NVIDIA card with a functioning mouse. I had to remove the graphics card and run the installer using the onboard graphics. Once finished i went ahead and installed the grub-customizer anyways as well as efibootmgr that was needed for my system. Made the no acpi change, and then installed the NVIDIA drivers using just the first line “pacman -Syy nvidia nvidia-utils nvidia-libgl” mentioned above.

    Thanks again

  • @mantatux Welcome on board ;)
    Interesting, I have a GTX 1080 and I could just install Antergos flawlessly after I changed the kernel mode at the startup.
    After the installation I had a black screen (driver problem), but I could fix this using the three lines I posted before ;)

mouse44 left4 upper3 stuck28 Posts 48Views 6390
Log in to reply