• Problem with update (jasper & lib-curl)


    Today’s detected updates failed. See screenshot for details. Antergos with Gnome.
    0_1483464155812_Screenshot from 2017-01-03 12-18-41.png

  • I have a similar problem with an attempted update today. I am using Plasma 5 KDE desktop.
    Unsure of how to proceed.
    0_1483469270574_Screenshot_20170103_124436.png

  • yaourt -Syu --aur
    

    in a terminal will give you more options

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • OK, I issued “yaourt -Syu --aur” in a terminal and I’ve attached a screenshot of the results.
    0_1483470378487_Screenshot_20170103_130350.png

    So, I’m still to new to Arch to go from here. I checked the Arch website for any post concerning this issue and found nothing.

  • @Orlet

    try these commands:
    sudo pacman -S gnupg
    sudo pacman-key --populate archlinux
    sudo pacman-key --refresh-keys
    sudo pacman -Syyu

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • @Skiman I have the same issue. Got this message when using command line:

    error: libwmf: signature from “Levente Polyak (anthraxx) [email protected]” is unknown trust
    :: File /var/cache/pacman/pkg/libwmf-0.2.8.4-14-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).

  • @fernandomaroto That fixed my problem. Should have read your post before whining :)

  • @fernandomaroto
    First, a big thanks for posting your response with those commands. That fixed the problem.
    Can you tell me exactly what information in the terminal screenshot let you know that I needed to update keys? I ask because, while I’m grateful for help from a wonderful Antergos community, I also want to learn Arch based Linux.
    I came from Ubuntu( used it for 5 years), was reasonable good at knowing how to manage my own OS. However, the commands you suggested—I never came across or used in Ubuntu. I’m asking so I can learn as much about Arch as I can, manage problems myself, and offer help to others in the future.

  • @Orlet i also learned that today. I tried to update a notebook but i got the same errors; for some reason my Desktop PC didn’t show the same errors. I tried then to clean the pacman cache (sometime conflicting version’s packages can be installed that way), but didn’t work. Than i googled and found a site about errors with pgp signatures, where these commands were suggested.
    The error is here File /var/cache/pacman/pkg/libwmf-0.2.8.4-14-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).

    These commands should be enough to fix the problem (but i posted to you the same way i used)
    sudo pacman-key --refresh-keys
    sudo pacman -Syyu

    I’m also learning… We learn and spread the knowledge :p

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • Had the same issue this morning and came straight to the forum to check if there was already an answer. Wasn’t disappointed once more! Thank you @fernandomaroto , those two commands did the trick.

jasper2 lib-curl1 Posts 10Views 1575
Log in to reply