• \[SOLVED\] Nouveau x86 won't work fine with X


    Well I have a big fight with Arch + NVIDIA + Flash Player,

    Hardware:
    01:00.0 VGA compatible controller: NVIDIA Corporation G98 [GeForce 9300 GE] (rev a1)

    Monitors:
    Dell P2011H 1600x900
    Dell P2011H 1600x900

    3.9.3-1-ARCH

    First of all, I try this with a clean installation of arch, and I won’t get it flash/flex works on a webpage.

    I try with nouveau and Nvidia drivers, dowloaded from nvidia, etc.

    But when I try with an installation with Antergos, Flash/Flex works,

    My problem now is that I have two monitors and it detects with xrandar;

      
    Screen 0: minimum 320 x 200, current 1600 x 900, maximum 8192 x 8192  
      
    DVI-I-1 connected primary 1600x900+0+0 (normal left inverted right x axis y axis) 443mm x 249mm  
    1600x900 60.0\*+  
    1280x1024 75.0 60.0   
    1152x864 75.0   
    1024x768 75.1 60.0   
    800x600 75.0 60.3   
    640x480 75.0 60.0   
    720x400 70.1   
      
    DVI-I-2 connected 1600x900+0+0 (normal left inverted right x axis y axis) 443mm x 249mm  
    1600x900 60.0\*+  
    1280x1024 75.0 60.0   
    1152x864 75.0   
    1024x768 75.1 60.0   
    800x600 75.0 60.3   
    640x480 75.0 60.0   
    720x400 70.1   
      
    
    

    My right monitor goes to “Power Safe Mode” and displays this message “[b:2mc2ivqh]There is no signal coming from your computer[/b:2mc2ivqh]”

    I ran a command to configure X

    sudo X -congifure
    

    And I try test my new configuration won’t work, I get a black screen.

    X -config /root/xorg.conf.new
    

    So, I apply some fixes, like make manually run commands:

      
    randr --output DVI-I-1 --mode 1600x900 --pos 0x0 --rotate normal --output DVI-I-2 --mode 1600x900 --pos 1600x0 --rotate normal  
    
    

    or my own configuration files as described on arch wiki and still can not get it to work [url:2mc2ivqh]https://wiki.archlinux.org/index.php/Nouveau#Dual_Head[/url:2mc2ivqh]

      
    $ ls /etc/X11/  
    xinit xorg.conf xorg.conf.d  
      
    $ ls /etc/X11/xorg.conf.d/  
    10-evdev.conf 10-quirks.conf 20-nouveau.conf 50-synaptics.conf  
    
    

    This is the xorg.conf what I copied from /root/xorg.conf.new

      
    Section "ServerLayout"  
    Identifier "X.org Configured"  
    Screen 0 "Screen0" 0 0  
    InputDevice "Mouse0" "CorePointer"  
    InputDevice "Keyboard0" "CoreKeyboard"  
    EndSection  
      
    Section "Files"  
    ModulePath "/usr/lib/xorg/modules"  
    FontPath "/usr/share/fonts/misc/"  
    FontPath "/usr/share/fonts/TTF/"  
    FontPath "/usr/share/fonts/OTF/"  
    FontPath "/usr/share/fonts/Type1/"  
    FontPath "/usr/share/fonts/100dpi/"  
    FontPath "/usr/share/fonts/75dpi/"  
    EndSection  
      
    Section "Module"  
    Load "glx"  
    EndSection  
      
    Section "InputDevice"  
    Identifier "Keyboard0"  
    Driver "kbd"  
    EndSection  
      
    Section "InputDevice"  
    Identifier "Mouse0"  
    Driver "mouse"  
    Option "Protocol" "auto"  
    Option "Device" "/dev/input/mice"  
    Option "ZAxisMapping" "4 5 6 7"  
    EndSection  
      
    Section "Monitor"  
    Identifier "Monitor0"  
    VendorName "Dell"  
    ModelName "Monitor Model"  
    EndSection  
      
    Section "Device"  
    \#\#\# Available Driver options are:-  
    \#\#\# Values: <i\>: integer, <f\>: float, <bool\>: "True"/"False",  
    \#\#\# <string\>: "String", <freq\>: "<f\> Hz/kHz/MHz",  
    \#\#\# <percent\>: "<f\>%"  
    \#\#\# [arg]: arg optional  
    \#Option "SWcursor" \# [<bool\>]  
    \#Option "HWcursor" \# [<bool\>]  
    \#Option "NoAccel" \# [<bool\>]  
    \#Option "ShadowFB" \# [<bool\>]  
    \#Option "VideoKey" \# <i\>  
    \#Option "WrappedFB" \# [<bool\>]  
    \#Option "GLXVBlank" \# [<bool\>]  
    \#Option "ZaphodHeads" \# <str\>  
    \#Option "PageFlip" \# [<bool\>]  
    \#Option "SwapLimit" \# <i\>  
    \#Option "AsyncUTSDFS" \# [<bool\>]  
    Identifier "Card0"  
    Driver "nouveau"  
    BusID "PCI:1:0:0"  
    EndSection  
      
    Section "Screen"  
    Identifier "Screen0"  
    Device "Card0"  
    Monitor "Monitor0"  
    SubSection "Display"  
    Viewport 0 0  
    Depth 1  
    EndSubSection  
    SubSection "Display"  
    Viewport 0 0  
    Depth 4  
    EndSubSection  
    SubSection "Display"  
    Viewport 0 0  
    Depth 8  
    EndSubSection  
    SubSection "Display"  
    Viewport 0 0  
    Depth 15  
    EndSubSection  
    SubSection "Display"  
    Viewport 0 0  
    Depth 16  
    EndSubSection  
    SubSection "Display"  
    Viewport 0 0  
    Depth 24  
    EndSubSection  
    EndSection  
      
      
    
    

    20-nouveau.conf

      
    \# the right one  
    Section "Monitor"  
    Identifier "left"  
    Option "PreferredMode" "1600x900\_60.00"  
    EndSection  
      
    \# the left one  
    Section "Monitor"  
    Identifier "right"  
    Option "PreferredMode" "1600x900\_60.00"  
    Option "RightOf" "left"  
    EndSection  
      
    Section "Device"  
    Identifier "nvidia card"  
    Driver "nouveau"  
    Option "Monitor-DVI-I-1" "left"  
    Option "Monitor-DVI-I-2" "right"  
    EndSection  
      
    Section "Screen"  
    Identifier "screen1"  
    Monitor "left"  
    DefaultDepth 24  
    SubSection "Display"  
    Depth 24  
    Virtual 2560 2048  
    EndSubSection  
    Device "nvidia card"  
    EndSection  
      
    Section "ServerLayout"  
    Identifier "layout1"  
    Screen "screen1"  
    EndSection  
    
    
  • Well I have a big fight with Arch + NVIDIA + Flash Player,

    Hardware:
    01:00.0 VGA compatible controller: NVIDIA Corporation G98 [GeForce 9300 GE] (rev a1)

    Monitors:
    Dell P2011H 1600x900
    Dell P2011H 1600x900

    3.9.3-1-ARCH

    First of all, I try this with a clean installation of arch, and I won’t get it flash/flex works on a webpage.

    I try with nouveau and Nvidia drivers, dowloaded from nvidia, etc.

    But when I try with an installation with Antergos, Flash/Flex works,

    My problem now is that I have two monitors and it detects with xrandar;

      
    Screen 0: minimum 320 x 200, current 1600 x 900, maximum 8192 x 8192  
      
    DVI-I-1 connected primary 1600x900+0+0 (normal left inverted right x axis y axis) 443mm x 249mm  
    1600x900 60.0\*+  
    1280x1024 75.0 60.0   
    1152x864 75.0   
    1024x768 75.1 60.0   
    800x600 75.0 60.3   
    640x480 75.0 60.0   
    720x400 70.1   
      
    DVI-I-2 connected 1600x900+0+0 (normal left inverted right x axis y axis) 443mm x 249mm  
    1600x900 60.0\*+  
    1280x1024 75.0 60.0   
    1152x864 75.0   
    1024x768 75.1 60.0   
    800x600 75.0 60.3   
    640x480 75.0 60.0   
    720x400 70.1   
      
    
    

    My right monitor goes to “Power Safe Mode” and displays this message “[b:2mc2ivqh]There is no signal coming from your computer[/b:2mc2ivqh]”

    I ran a command to configure X

    sudo X -congifure
    

    And I try test my new configuration won’t work, I get a black screen.

    X -config /root/xorg.conf.new
    

    So, I apply some fixes, like make manually run commands:

      
    randr --output DVI-I-1 --mode 1600x900 --pos 0x0 --rotate normal --output DVI-I-2 --mode 1600x900 --pos 1600x0 --rotate normal  
    
    

    or my own configuration files as described on arch wiki and still can not get it to work [url:2mc2ivqh]https://wiki.archlinux.org/index.php/Nouveau#Dual_Head[/url:2mc2ivqh]

      
    $ ls /etc/X11/  
    xinit xorg.conf xorg.conf.d  
      
    $ ls /etc/X11/xorg.conf.d/  
    10-evdev.conf 10-quirks.conf 20-nouveau.conf 50-synaptics.conf  
    
    

    This is the xorg.conf what I copied from /root/xorg.conf.new

      
    Section "ServerLayout"  
    Identifier "X.org Configured"  
    Screen 0 "Screen0" 0 0  
    InputDevice "Mouse0" "CorePointer"  
    InputDevice "Keyboard0" "CoreKeyboard"  
    EndSection  
      
    Section "Files"  
    ModulePath "/usr/lib/xorg/modules"  
    FontPath "/usr/share/fonts/misc/"  
    FontPath "/usr/share/fonts/TTF/"  
    FontPath "/usr/share/fonts/OTF/"  
    FontPath "/usr/share/fonts/Type1/"  
    FontPath "/usr/share/fonts/100dpi/"  
    FontPath "/usr/share/fonts/75dpi/"  
    EndSection  
      
    Section "Module"  
    Load "glx"  
    EndSection  
      
    Section "InputDevice"  
    Identifier "Keyboard0"  
    Driver "kbd"  
    EndSection  
      
    Section "InputDevice"  
    Identifier "Mouse0"  
    Driver "mouse"  
    Option "Protocol" "auto"  
    Option "Device" "/dev/input/mice"  
    Option "ZAxisMapping" "4 5 6 7"  
    EndSection  
      
    Section "Monitor"  
    Identifier "Monitor0"  
    VendorName "Dell"  
    ModelName "Monitor Model"  
    EndSection  
      
    Section "Device"  
    \#\#\# Available Driver options are:-  
    \#\#\# Values: <i\>: integer, <f\>: float, <bool\>: "True"/"False",  
    \#\#\# <string\>: "String", <freq\>: "<f\> Hz/kHz/MHz",  
    \#\#\# <percent\>: "<f\>%"  
    \#\#\# [arg]: arg optional  
    \#Option "SWcursor" \# [<bool\>]  
    \#Option "HWcursor" \# [<bool\>]  
    \#Option "NoAccel" \# [<bool\>]  
    \#Option "ShadowFB" \# [<bool\>]  
    \#Option "VideoKey" \# <i\>  
    \#Option "WrappedFB" \# [<bool\>]  
    \#Option "GLXVBlank" \# [<bool\>]  
    \#Option "ZaphodHeads" \# <str\>  
    \#Option "PageFlip" \# [<bool\>]  
    \#Option "SwapLimit" \# <i\>  
    \#Option "AsyncUTSDFS" \# [<bool\>]  
    Identifier "Card0"  
    Driver "nouveau"  
    BusID "PCI:1:0:0"  
    EndSection  
      
    Section "Screen"  
    Identifier "Screen0"  
    Device "Card0"  
    Monitor "Monitor0"  
    SubSection "Display"  
    Viewport 0 0  
    Depth 1  
    EndSubSection  
    SubSection "Display"  
    Viewport 0 0  
    Depth 4  
    EndSubSection  
    SubSection "Display"  
    Viewport 0 0  
    Depth 8  
    EndSubSection  
    SubSection "Display"  
    Viewport 0 0  
    Depth 15  
    EndSubSection  
    SubSection "Display"  
    Viewport 0 0  
    Depth 16  
    EndSubSection  
    SubSection "Display"  
    Viewport 0 0  
    Depth 24  
    EndSubSection  
    EndSection  
      
      
    
    

    20-nouveau.conf

      
    \# the right one  
    Section "Monitor"  
    Identifier "left"  
    Option "PreferredMode" "1600x900\_60.00"  
    EndSection  
      
    \# the left one  
    Section "Monitor"  
    Identifier "right"  
    Option "PreferredMode" "1600x900\_60.00"  
    Option "RightOf" "left"  
    EndSection  
      
    Section "Device"  
    Identifier "nvidia card"  
    Driver "nouveau"  
    Option "Monitor-DVI-I-1" "left"  
    Option "Monitor-DVI-I-2" "right"  
    EndSection  
      
    Section "Screen"  
    Identifier "screen1"  
    Monitor "left"  
    DefaultDepth 24  
    SubSection "Display"  
    Depth 24  
    Virtual 2560 2048  
    EndSubSection  
    Device "nvidia card"  
    EndSection  
      
    Section "ServerLayout"  
    Identifier "layout1"  
    Screen "screen1"  
    EndSection  
    
    
  • Did you try from gnome-control-center instead?

  • Yeap i did it, and shown the 2 displays but never recieve the signal, by the way, the hardware works fine, I check the cables, and testing in another computer, and I switch the cables and only one monitor works

  • Check this post and tell me if it was helpful, this is a bit out of my knowledge

    [https://bbs.archlinux.org/viewtopic.php?pid=652861][0]">[https://bbs.archlinux.org/viewtopic.php?pid=652861][1]

    [0]: <a href=
    [1]: https://bbs.archlinux.org/viewtopic.php?pid=652861

  • Well I broke my Xorg, jaja I’m resintalling antergos again.

    I notice even with LiveCD my second monitor still in black.

  • Do you have a link to migrate from nouveau to nvidia drivers?

  • Here you have everything you need [https://wiki.archlinux.org/index.php/NVIDIA][0]">[https://wiki.archlinux.org/index.php/NVIDIA][1]

    You will have to remove xf86-video-nouveau, nouveau-dri and libgl before installing nvidia

    If you get that libgl can’t be removed due to unsatisfied dependencies, run “sudo pacman -Rdd libgl”

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/NVIDIA

  • I did that, and antergos crash that’s the reason I reinstalled the system, when I installed clean Archlinux, the problem with Nvidia drivers, is the flash issue.

    But I can do it again

  • Ok! now it’s working! and my flash player too, here is the process

      
    sudo systemctl stop lxdm  
    sudo pacman -R xf86-video-nouveau nouveau-dri  
      
    \# for libgl  
    sudo pacman -Rdd mesa-libgl  
      
    sudo pacman nvidia  
    modprobe -r nouveau  
    modprobe nvidia  
    sudo systemctl restart lxdm  
    
    

    By the way, i don’t need anything else for configuring flash or something,

    Thanks faidoc!

Posts 11Views 3734
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.