• Like 0

    How to install via proxy?


    Hello, guys

    I am trying to install Antergos on a pc which can only access internet through a proxy.So i start live cd, set the http,https network proxy at the top corner(tried export http_proxy/https_proxy as well, same result).

    The default.env+=“http_proxy https_proxy” has also been set in the sudoer and sudo pacman -Syy work well and updated. su then pacman -Syy works well too. However cnchi always tells no internet connection at the step two. tried run cnchi at the terminal and saw these errors come up (cnchi gui still opens tho):

    (cnchi.py:2096): GLib-GIO-CRITICAL **: g_dbus_proxy_new_sync:assertion ‘G_IS_DBUS_CONNECTION (connection)’ failed
    (cnchi.py:2096): GLib-GIO-CRITICAL **: g_dbus_proxy_get_name_owner:assertion ‘G_IS_DBUS_PROXY (proxy)’ failed
    (cnchi.py:2096): Gtk-WARNING **: Failed to get an inhibit protal proxy: The name org.freedesktop.portal.Desktop is not owned

    What might be the reason cnchi can’t use the proxy and how to fix it?

    Thanks

  • Like 0

    Saw this old topic https://forum.antergos.com/topic/229/solved-installation-error/7 and tried to do exactly the same like the last dude in the comments but still got no luck.

  • Like 0

    anyone care to help?

  • Like 0

    hi! I have no knowledge to help you. You’ll need to wait someone more experienced to read your post (it can take a while)

    Don’t feel alone although. :p

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • Like 0

    I have bad news and good news:

    • Installer won’t work behind a proxy. It hasn’t been programmed to do it.

    • IMHO, it wouldn’t be very difficult to make it work behind a proxy, it’s a thing I been wanting to do for a long time, but to be honest, I haven’t got the time to do it. I’ll put this in my big TODO list, and I’ll get back to you when I have something (don’t hold your breath).

    EDIT: Did you try setting the environment vars as suggested in the other thread (close the installer first, set the vars and run the installer from the same terminal, with pkexec cnchi or sudo -E cnchi) ?

    export http_proxy="myproxy:8080"  
    export https_proxy="myproxy:8080"  
    export ftp_proxy="myproxy:8080"  
    export HTTP_PROXY="myproxy:8080"  
    export HTTPS_PROXY="myproxy:8080"
    export FTP_PROXY="myproxy:8080"
    
  • Like 0

    Hi karasu,

    I am used to working with Proxy and setting up the proxy as described works for all usages but not the installer. It seems to check with some simple ping if it is connected to internet. When running cinchi it claims to be offline and does not allow any step forward, even though pacman etc work just fine.

    Maybe just enable some way to overcome this step(kindof “I know better, you are online” button when any proxy settings are found?) because expectation would be the rest would actually work?

    kind regards, martin

cnchi95 proxy2 install68 Posts 6Views 475
Log in to reply