• Antergos Live boot hangs to "Reached target Graphical Interface"


    I have tried to install many different linux distros. Almost all of them (ubuntu, xubuntu, debian) needed nomodeset boot parameter so that installation succeeded. Same thing happened when I booted from Antegros Live usb. Without nomodeset boot hangs to “Reached target Graphical Interface”. With nomodeset I can boot to desktop environment, but resolution of desktop is pretty bad compared to situation when windows 10/7 were installed to this computer. I already updated bios, but I wonder if problem is with graphic drivers. I don’t know which one should I install/uninstall or even if problem is with drivers.

    Command:

    lspci | grep VGA
    

    outputs:

    00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Wrestler [Radeon HD 6320 ]
    01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Seymour [Radeon HD 6400M/7400M Series]
    

    and computer itself is Asus X53BY.

    edit:
    I ended up installing antergos with mate. I don’t have to use nomodeset as boot parameter, but it takes like 20-30 min to boot to login screen and I get message “An error was detected in the current theme that could interfere with the system login process” and options: “Load Default Theme”, “Load Fallback Theme” and “Cancel”. If I choose Load Default Theme, I can login and desktop seems otherwise normal but I can’t set any wallpaper to it. Screen resolution is also good and everything else seems to work properly. I also tried change lightdm to gdm, but then boot process froze even earlier and did not proceed to login screen.

  • @lesngr I installed Antergos through minimal ISO on my AMD A4 APU machine and it went well without any graphics problem. FYI, I’m not using third party ATI drivers.

  • Have you tried out @joekamprad’s ISO for Antergos yet? This one might help. If you are interested, here’s the link.

  • @Keegan
    Why would you think that an iso that comes with the proprietary Nvidia driver would solve problems with AMD gpus?
    J.

  • It’s a very old topic anyway.

  • @Jeannie____ said in Antergos Live boot hangs to "Reached target Graphical Interface":

    Why would you think that an iso that comes with the proprietary Nvidia driver would solve problems with AMD gpus?

    I just heard a lot of discussion about @joekamprad’s ISO eliminating the need for adding nomodeset to the boot up process among other useful things in the thread about it. So I thought it might be at least worth a try. I don’t know if it would work, it was just an idea.If I steered anyone wrong, I do apologize for that.

  • @fernandomaroto said in Antergos Live boot hangs to "Reached target Graphical Interface":

    It’s a very old topic anyway.

    🎯

    I see it now…

    #closing this one.

drivers50 radeon13 ati8 nomodeset2 Posts 8Views 1645
Locked
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.