• OpenVPN 2.4.0 update requires administrative interaction


    The upgrade to OpenVPN 2.4.0 makes changes that are incompatible with previous configurations. Take special care if you depend on VPN connectivity for remote access! Administrative interaction is required:

    • Configuration is expected in sub directories now. Move your files from /etc/openvpn/ to /etc/openvpn/server/ or /etc/openvpn/client/
    • The plugin lookup path changed, remove extra plugins/ from relative paths.
    • The systemd unit [email protected] was replaced with [email protected] and [email protected]. Restart and reenable accordingly.

    This does not affect the functionality of networkmanager, connman or qopenvpn.

  • excuse me, what is the, “The systemd unit [email protected] was replaced with [email protected] and [email protected] Restart and reenable accordingly.” ? How do I do that?

    I try using systemctl but not work.

    #systemctl enable [email protected]
    The unit files have no installation config (WantedBy, RequiredBy, Also, Alias
    settings in the [Install] section, and DefaultInstance for template units).
    This means they are not meant to be enabled using systemctl.
    Possible reasons for having this kind of units are:
    1) A unit may be statically enabled by being symlinked from another unit's
       .wants/ or .requires/ directory.
    2) A unit's purpose may be to act as a helper for some other unit which has
       a requirement dependency on it.
    3) A unit may be started when needed via activation (socket, path, timer,
       D-Bus, udev, scripted systemctl call, ...).
    4) In case of template units, the unit is meant to be enabled with some
       instance name specified.
    
  • To start OpenVPN automatically at system boot, either for a client or for a server, enable [email protected]<configuration>.service on the applicable machine. (Leave .conf out of the <configuration> string.)

    For example, if the client configuration file is /etc/openvpn/client/client.conf, the service name is [email protected]

    sudo systemctl enable [email protected]

    Or, if the server configuration file is /etc/openvpn/server/server.conf, the service name is [email protected]

    sudo systemctl enable [email protected]

    Hope this helps.

    Cheers!

2.4.02 requires5 administrative1 openvpn4 Posts 3Views 810
Log in to reply