• plymouth upgrade error - invalid plymouth-theme-antergos signature


    In Pamac, I see a new version for Plymouth, but the upgrade fails. If I try to upgrade Plymouth in terminal manually, I see the following.:

    $ sudo pacman -S plymouth --force
    
    resolving dependencies...
    looking for conflicting packages...
    warning: dependency cycle detected:
    warning: plymouth-theme-antergos will be installed before its plymouth dependency
    
    Packages (2) plymouth-theme-antergos-1.0-1  plymouth-0.9.2.r2031-1
    
    Total Download Size:   0.19 MiB
    Total Installed Size:  2.04 MiB
    Net Upgrade Size:      0.03 MiB
    
    :: Proceed with installation? [Y/n] 
    :: Retrieving packages...
     plymouth-theme-ante...   191.8 KiB   480K/s 00:00 [######################] 100%
    (2/2) checking keys in keyring                     [######################] 100%
    (2/2) checking package integrity                   [######################] 100%
    error: plymouth-theme-antergos: signature from "Antergos Build Server (Automated Package Build System) <[email protected]>" is invalid
    :: File /var/cache/pacman/pkg/plymouth-theme-antergos-1.0-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] 
    error: failed to commit transaction (invalid or corrupted package)
    Errors occurred, no packages were upgraded.
    

    How to fix this issue?

    +antergos:matrix.org
    riot.im/+antergos:matrix.org

  • This issue has been fixed in the repo. It will take a couple hours to reach all the mirrors though.

upgrade68 pamac62 upgrade failure3 plymouth2 Posts 2Views 659
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.