• Like 0

    How to enable numlock keyboard led in GDM on boot?


    Hello
    This tip is not working
    https://wiki.archlinux.org/index.php/Activating_Numlock_on_Bootup#GDM

    Any solution please?

  • Like 0

    I 'm still searching for a solution to this issue.
    Any tip please?

  • Like 2

    @Strangiato
    Hi!
    You need to type numbers in you password?
    If yes, check in your BIOS if you have an option to enable numlock at boot, something like that.
    If not, you can use the package numlockx i use under my i3-wm here and works. That means after login the program will activate numlock.
    I believe it’s possible to enable the program while booting with systemd, but i’m new to it so i’m can’t be sure.
    There may be others solutions but i havenot enough knowledge to help you further than that.

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • Like 2

    @fernandomaroto i use numlockx also and works great.

  • Like 0

    Thanks guys.
    As I said before, numlockx is not working with GDM.
    Numlock is enabled in my bios setup.
    There is a very old and not fixed bug report about this
    https://bugzilla.gnome.org/show_bug.cgi?id=628954

  • Like 1

    @Strangiato not even running trough terminal?
    i don’t run as numlockx on just numlockx &

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • Like 0

    From terminal it works under x11, but no effect under Wayland.
    Do you use Gnome and GDM?

  • Like 1

    @Strangiato No, i don’t use Gnome nor GDM. I was just trying to help and understand more the problem you are experiencing, but i have no more ideas to help you, sorry.

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • Like 1

    ok, thank you very much for your help. :+1:

  • Like 0

    @Strangiato ok, i just read on a brazilian forum that sometimes the solution you tried from Arch’s wiki work but without turning on the keyboard led…
    And one last thing, the arch’s wiki doens’t said anything about wayland, it seems the only way to make numlockx to work is to force GDM to load under X session like this:
    https://ask.fedoraproject.org/en/answers/70205/revisions/

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • Like 0

    I think GDM runs always under xorg.
    After I run numlockx from a terminal, numlock keyboard led is off and no digit appears on my screen when I press any key from my numpad.

  • Like 0

    @Strangiato ok, then i don’t know heheehe

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • Like 0

    This can be automated by installing the systemd-numlockontty package and enabling the numLockOnTty service.

    yaourt -S systemd-numlockontty
    sudo systemctl enable numLockOnTty

    and tested = does NOT work :(

    But:
    edit /etc/gdm/Init/Default and add:

    which numlockx >/dev/null && numlockx on
    

    right after: PATH="/usr/bin:$PATH"

    Seems to work, NumLock is active but LED not, when i press a number LED is starting;)

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • Like 0

    @joekamprad said in How to enable numlock keyboard led in GDM on boot?:

    But:
    edit /etc/gdm/Init/Default and add:

    which numlockx >/dev/null && numlockx on
    

    right after: PATH="/usr/bin:$PATH"

    Seems to work, NumLock is active but LED not, when i press a number LED is starting;)

    it did not work here.

led1 numlock2 keyboard28 enable4 Posts 14Views 328
Log in to reply