• second installation on other partition: kernel not loaded


    One working Antergos Gnome version that i am happy with.
    On other partition a second Antergos openBox version to test openBox.
    Because Gnome openBox isn’t possible with the latest Gnome and to keep the smooth working Antergos Gnome clean and working.

    In EFI there are two antergos-grub folders installed, so the installation seams ok, but when i boot thru rEFInd in the Antergos openBox then i get this:

    error: no such device: ad4103fa-(and so on) 
    Loading Linux core repo kernel ...
    error: no such partition. 
    Loading initial ramdisk ...
    error: you need to load the kernel first. 
    
    Press any key to continue...
    

    It seams that GRUB doesn’t find the kernel, but all GRUB files are properly installed.
    I have found post like this on the Arch forums and tried to fix but doesn’t find where to start, so i ask it in here.

    Happy Bubbles!

  • @bartatantergos

    As I understand, the first (Gnome) installation is working fine, right? Have you tried to reinstall grub from there?

    Simply boot your Gnome installation and:

    sudo grub-mkconfig -o /boot/grub/grub.cfg
    sudo grub-install /dev/sda
    

    When you run grub-mkconfig, it should find both installations. If not, something is wrong, obviously.

    Tell us if it helped or not.

    Cheers!

  • @bartatantergos

    I didn’t read all the antergos installation script but sometime ago I fixed by mounting boot and root (if its in different partition) then chroot to the root path and generated grub, my mind is not clear but it was something like this:

    sudo mount /dev/sdXY /media/root/
    sudo mount /dev/sdXY /media/root/boot/
    sudo chroot /media/root/
    sudo grub-mkconfig -o /boot/grub/grub.cfg
    exit
    sudo grub-install /dev/sdX
    

    Remember to replace “X” with your drive port and “Y” with your partition number

    I hope this help you,
    Best regards

  • @karasu Yes, also found that on the Arch forum.
    Done, and i get this error after sudo grub-install /dev/sda:

    Installing for x86_64-efi platform.
    grub-install: error: efibootmgr: not found. 
    

    Problem is still there.
    What now?

  • @Edwin-Foss Will this fix the grub without that error?

    @all Could it work with chainloading?
    https://bbs.archlinux.org/viewtopic.php?id=134697

  • @bartatantergos
    About the posted topic https://bbs.archlinux.org/viewtopic.php?id=134697, the answer is no because looks like your system is configured as EFI based boot which you can follow the steps on https://wiki.archlinux.org/index.php/GRUB on UEFI section.

    Well, maybe exiting from chroot was unnecessary, can you try the last command before exit like this?

    sudo mount /dev/sdXY /media/root/
    sudo mount /dev/sdXY /media/root/boot/
    sudo chroot /media/root/
    sudo grub-mkconfig -o /boot/grub/grub.cfg
    sudo grub-install /dev/sdX
    exit
    
  • @Edwin-Foss No, not working, but weird or not, simply changing manually the UUID’s in grub.cfg into the correct once does the trick. That this is ok, i don’t know?

    Wow, openBox is soo fast but also so minimal! ;)

  • @bartatantergos

    :open_mouth: If UUID was the root of problem It’s ok to set on grub.cfg but I don’t know if it’s permanent.
    I recommend check fstab file on /etc in both units because can be something wrong there, also cleaning invalid entries can achieve better boot performance and avoid future grub-mkconfig misconfigurations.

  • @Edwin-Foss Happy New has kept me from the screen. :) Ok, i will try to clean that mess up.

    The weird thing is (again, i have mentioned the hard drive switches a few times on this forum) that grub-mkconfig has auto-magically recreated/installed into a new EFI partition (an EFI partition i have deleted to free space before the installation) on the second hard drive (sdb). So, the (efi-)grub files from the first installation is now on sdb and not anymore on sda like it was after the installation.
    Happy well, the two installations still work.
    Is this not a bug, does you or another dev has Antergos installed on a laptop with two hard drives? For all i have read about Arch and Antergos installer problems, a lot of them seams for me related to a grub not-installed during an installation without error problem.
    (@anarch This i mean in a friendly way to help ;)
    Or maybe only on Mac computers?

    p.s.: Anyway openBox is too minimal for me and i will try to install and test Antergos Xfce.

  • @bartatantergos
    Well, it’s really look like a bug for me too but I still must read the installation script before any conclusion.
    My desktop machine was my test bench, but about six months ago one of my hard drives died and I needed the other one to backup other things, and this year I’m planning to upgrade my machine entirely, at this moment, I don’t have resources to test and debug, but AFAIR I used the commands below to fix my grub after failed to install on a secondary disk during many fresh test installations.

    sudo mount /dev/sdXY /mnt/root/
    sudo mount /dev/sdXY /mnt/root/boot/
    sudo mount --bind /proc /mnt/root/proc
    sudo mount --bind /dev /mnt/root/dev
    sudo mount --bind /sys /mnt/root/sys
    sudo chroot /mnt/root
    sudo grub-install /dev/sdX
    sudo grub-mkconfig -o /boot/grub/grub.cfg
    

    Anyway, there is no difference between supposedly universal connections like SATA mean to be, since that, GRUB doesn’t juggle disks because once generated UUID must be the same until reset partition or give a command to set new one to the disk. It’s very strange disks become inaccessible after grub update.

    For who uses GPT partitions and need to check UUIDs the command below may be helpful

    blkid
    

    For non GPT

    lsblk -f
    

    On another similar situation that I had, I think 3 years old now, my UEFI/BIOS saved data got corrupted and gave me some strange bugs like that, after bios reset and reconfiguration the data still got corrupted, then I flashed with last update and reconfigured and voilá, the problem disappeared. I don’t know why happened but happened :laughing:

    Also my SSD (which died 6 months ago) got an intermittent problem in the first sector became unwritable and unable to install any bootloader giving me similar headache, the funny thing is that SSD lived another year after this happened, I suppose that was because the old hardware architecture and flawed firmware.

  • I solved with that:
    https://www.youtube.com/watch?v=2LgdfoN7b2Q
    Then updated grub

    Antergos KDE + Antergos XFCE + Windows 10
    Motherboard Asus P8H67-M LE - CPU: Intel Core™ i5-2400 CPU @ 3.10GHz - RAM 10 Gb
    Samsung EVO 250 Gb Ssd + WD HDD 2 Tb

  • @fabio Looked to that video and it’s the same way i fix my installations, but that’s not normal. Read the reply above from @Edwin-Foss.

  • @Edwin-Foss Till now my manual fix works on both installations, so i keep it for the moment like that.
    With “cleaning invalid entries” do you mean the fstab check or what exactly?

  • Did you have efibootmgr installed?

  • @bartatantergos said in second installation on other partition: kernel not loaded:

    @Edwin-Foss Till now my manual fix works on both installations, so i keep it for the moment like that.
    With “cleaning invalid entries” do you mean the fstab check or what exactly?

    Sorry my bad english :blush:, I was talking about fstab.

    I did a one line bash command that you can use if you wish

    lsblk -f ; echo ; cat /etc/fstab | egrep -v '^$|#' ; echo ; echo ; echo '-------------------- diff --------------------' ; echo ; diff <(lsblk -o UUID | egrep -v '^$|UUID' | sort) <(cat /etc/fstab | egrep -v '^$|#' | sed 's/^UUID=//; s/\s.*$//' | sort) ; echo '------------------ diff end ------------------' 
    

    this script displays lsblk, fstab and diff between them if there any. In diff block will show only UUIDs that doesn’t match and if all UUIDs displayed in diff is inside fstab file, you can remove them from fstab because disk/partition doesn’t exists or isn’t detectable in sysfs or udev by lsblk.

  • @Edwin-Foss Sorry, for late answere, time was running too fast.
    After your one line bash command the UUID from the Gnome partition isn’t in the – diff – list, so i think that’s ok, but the UUID from the openBox partition is in the – diff – list.

    So there’s a problem with the openBox installation.
    The two are still working.

    What can i do next to get this mess cleaned up? ;)

  • @bartatantergos

    Firstly the diff tool will show results like this:

    -------------------- diff --------------------
    
    2c2
    < xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx
    ---
    > yyyyyyyy-yyyy-yyyy-yyyy-yyyyyyyyyyyy
    ------------------ diff end ------------------
    

    Ignore the first line because it’s just diff tool way to identify line and mark “what happened”, it’s useless when the list was manipulated before (as I used sort, sed and egrep commands to generate a custom list);
    The lines starting with " < " (less than) symbol means that the disk exists physically but is not set in fstab entries, the lines starting with " > " (greater than) symbol find them in fstab and delete the entries because there is no partition/disk with matching uuid.

    And finally, the lines which starts with " < " (less than) symbol you can add to fstab if you wish that partition/disk to be mounted at the boot.

  • @Edwin-Foss Thanks. That way i have found out that:

    Gnome partition fstab: has first the Gnome partition UUID and then the /boot/efi UUID

    openBox partition fstab: has first the Gnome partition UUID then the /boot/efi UUID and then in comment the openBox partition UUID.

    That is wrong but what’s the ideal situation for triple boot MacOs, Antergos Gnome and Antergos openBox?

  • @bartatantergos

    Sorry, I got little confused now, can you post both fstab here (and both lsblk -f if it’s possible)?
    And about the rEFInd, it detects both linux EFIs or only one which starts grub giving you the option which Antergos want to start?

  • I think this is the final solution to restore grub on uefi systems

    I managed to “convert” my system from BIOS mode to UEFI, also I disabled CSM function in BIOS/UEFI (PC only).
    I did the following steps:
    I booted with Antergos Installation media, created/managed needed partitions using gparted as described on the wiki about grub uefi (https://wiki.archlinux.org/index.php/GRUB), also I created “/boot/efi” directory in the target disk before the commands below:

    sudo mount /dev/sdXY /mnt
    sudo mount /dev/sdXY /mnt/boot
    sudo mount /dev/sdXY /mnt/boot/efi
    sudo mount --bind /proc /mnt/proc
    sudo mount --bind /dev /mnt/dev
    sudo mount --bind /sys /mnt/sys
    sudo mount --bind /run /mnt/run
    sudo chroot /mnt
    mount -t efivarfs efivarfs /sys/firmware/efi/efivars
    grub-install /dev/sdX
    grub-mkconfig -o /boot/grub/grub.cfg
    

    p.s. efibootmgr must be installed before run the commands above.
    sudo pacman -S efibootmgr

kernel64 partition16 installation186 second3 Posts 27Views 2123
Log in to reply