• Antergos won't boot after inserting Windows 10 SSD

    I am using Antergos Linux on my Lenovo laptop. Everything was working fine until I put another hard drive in the laptop. The new hard drive has Windows 10 installed so probably that messed up my system.
    First I was getting the following error: PXE-M0F: Exiting PXE ROM. So I read that it was trying to boot from the LAN card. After disabling that option in the BIOS the laptop just keeps restarting without showing anything.
    The boot priority is set right so that is not the problem. I guess the Windows messed up my boot loader but I am not sure. The drive is not broken because I entered with live Antergos CD and managed to access the files.
    Does anyone know what is causing the problem and how to fix it?

  • Did you change the safe boot option? Win10 require it to boot (enable safe boot) but you can disable for testing.

  • I have immediately removed the Windows SSD. The problem is that my HDD with Antergos won’t boot

  • @Tetrix Is not clear to me if you restored the old BIOS config.
    Anyway i’m not experienced enough to help you, let’s wait for someone else.

  • As for me a linux reinstall could solve the problem.
    Windows always cause problems if the linux system was installed first.

  • Boot with Antergos installation media and try this to restore your bootloader (as if you installed Antergos as default partition layout which separates boot from root and home, if not, change your mounting points as your layouts):

    sudo mount /dev/sdXY /media/root/
    sudo mount /dev/sdXY /media/root/boot/
    sudo chroot /media/root/
    sudo grub-mkconfig -o /boot/grub/grub.cfg
    sudo grub-install /dev/sdX

    Remember that “X” is your drive port and “Y” is your partition number

  • My partitions are mounted as follows:

    sda4 5.8G
    sda2 256M
    sda3 925.3G /mnt
    sda1 200M /mnt/boot

    In mnt/boot the structure is like this:


    After that I did sudo chroot /mnt
    Then I did sudo grub-mkconfig -o /boot/EFI/antergos_grub/grub.cfg and got the following warning: ‘Failed to connect lvmetad. Falling back to device scanning.’

  • After doing parted -l I saw that sda1 has name UEFI_SYSTEM with flags boot,esp and sda2 has name ANTERGOS_BOOT so I guess the sda2 is my boot partition. So I tried the same method with sda2 partition mounted like this sudo mount /dev/sda2 /mnt/boot and tried to create the the config file but I got the same warning.
    I tried to edit /etc/lvm/lvm.conf and set use_lvmetad = 0 but that didn’t solve the problem

  • @Tetrix
    I researched about and looks like you need to bind /run mount point to make lvmetad start properly inside chroot, then run grub-mkconfig as described here https://www.pckr.co.uk/arch-grub-mkconfig-lvmetad-failures-inside-chroot-install/

  • I already tried those steps and didn’t help. Now what I did was I inserted the SSD with Windows 10, shrinked it and allocated a little bit of space so I can install another Linux. I installed it alongside Windows and it recreated the GRUB. So now I am able to access my Antergos and Windows. It’s a bad fix but I needed the laptop working asap :)

  • @Tetrix
    I had similar problem sometime ago, after some research I fixed without any reinstallation but I never noted anything… sorry it didn’t help, but the steps was mounting disks, binding some folders and refreshing grub except I don’t need EFI or Secure Boot for my machine. 😊

  • @Tetrix
    Sorry bother you again…

    I wish I had a spare disk to test but my last one died six month ago.
    I was really trying to recall in my mind what I left out, I’m still not certain but I followed this steps to get my system back again:

    sudo mount /dev/sdXY /mnt/root/
    sudo mount /dev/sdXY /mnt/root/boot/
    sudo mount --bind /proc /mnt/root/proc
    sudo mount --bind /dev /mnt/root/dev
    sudo mount --bind /sys /mnt/root/sys
    sudo chroot /mnt/root
    sudo grub-install /dev/sdX
    sudo grub-mkconfig -o /boot/grub/grub.cfg

    Also check if your UUIDs are matching in /etc/fstab

boot320 windows73 ssd30 inserting1 Posts 12Views 2277
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.