• Wayland erratic in Plasma


    Although I have seen some improvement in Plasma with Wayland over the last few months, it is still far from usable for me. When logging in to the Wayland session it seems to start up well enough. (Better than before when I only ended up with a black screen).

    But, the first thing that indicates there is something wrong is the extremely lagging cursor. It drags behind the mouse movements. After just a few minutes the whole system comes to a halt. System monitor shows that the four core CPU behaves extremely erratic, fluctuating between 0 and 100%. The memory starts normal, but even without any activity going on, memory use goes gradually up till it uses almost all of the 8 Gb. After that everything freezes, and I have to hard reboot.

    The whole system is up to date. I am using an Asus K52. Intel 4x core i5-3210 CPU @2.5Ghz, 8 Gb RAM.

    Any ideas what causes this?

    Never to old to learn.

  • Seems the people are right when they say that Wayland is almost usable, after only 8 years of development. Give it another 8 years.
    J.

  • Is there any service showing such ram usage?

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • I have this same problem, and file .wayland-errors more than 100mb.
    with one and the same message

    QtDBus: cannot relay signals from parent KWin::LibInput::Connection(0x55e2ae98cb60 “”) unless they are emitted in the object’s thread QThread(0x55e2ae95db60 “”). Current thread is QThread(0x55e2ae89f9b0 “”).

  • This post is deleted!
  • @fernandomaroto The only service showing an increasing RAM use is Kwin_wayland itself. I tried to make a screenshot but that only results in a black screen. Took one with external camera:

    0_1482841463112_IMG_20161227_200259.jpg

    Never to old to learn.

  • @Jeannie____ With some luck, done before my retirement…

    Never to old to learn.

  • I didn’t find this bug on internet :(

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • Added the Htop output:

    0_1482891744770_Htop output kde-wayland.JPG

    As you can see the memory goes way overboard with just three minutes up-time.

    Never to old to learn.

  • I’d go with good old xorg until wayland is ready.
    J.

  • @Jeannie____ Which I am very happily indeed.
    But if problems like mine will help to iron out the kinks… :smiley:

    Never to old to learn.

  • lol 6 GB ram memory… that’s a serious bug in my opinion.

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • @axioma how did you set up Wayland under Plasma? I may try duplicating the problem on my end.

  • @linuxhelmet Sorry for the delay. Happy New Year.
    Nothing special in relation to settings. I have the following packages installed:

    Wayland 1.12.0-1
    Wayland-protocols 1.7-1
    Kwayland 3.2.1-1
    Kwayland-intergration 5.8.5-1
    lib32-wayland 1.12.0-1
    Plasma-wayland-session 5.8.5-1
    qt5-wayland 5.7.1-1
    xorg-server-xwayland 1.18.4-1

    What could be is that some of the packages interfere with each other.
    I will have some time to test some possibilities the coming days.

    Never to old to learn.

  • In my Gnome, i gave up with Wayland. When i played a video on VLC (or when i captured the screen), the thing just keeps crashing with all the graphical interface.

    Now i use Xorg, all problems gone.

    Antergos Gnome - Lenovo G4070
    Antergos XFCE (Ex-Mate) - Dell D630
    Antergos Cinnamon - Asus E-11
    Puppy Linux Precise 5.7.1 - Asus 701 EEEpc
    Puppy Linux Lxpuptahr USB live - All machines

wayland30 plasma23 erratic1 Posts 15Views 959
Log in to reply