• Using PCManFM with XFCE


    In my quest to go as lightweight as possible, I switched Thunar out for PCManFM. Works great with one exception. The removal of Thunar triggered the removal of Xfdesktop, which meant the next time I logged in no wallpaper, icons, etc. I can restore these things by running

    pcmanfm --desktop
    

    in the terminal, but it must remain open in order to keep working. Furthermore, I don’t seem to be able to right click the desktop.

    Does anyone have a more permanent solution to this than having a terminal open my entire session?

    THanks!

  • @chasbel2112 said in Using PCManFM with XFCE:

    In a terminal: pcmanfm --desktop &

    Or even better, put it in your startup programs in Settings Manager/Session and Startup (or something like that, I’m not in front of my computer atm).

  • @karasu i tried both of your suggestions with regard to that command. Running it in a terminal restored the desktop, though not the right click functionality on the desktop, and stopped displaying the desktop once closed. Adding it to Startup Programs yielded the Error “/home/chas/&: No such file or directory” upon login.

    Additionally, I have noticed that the Applications section of the file manager is empty. Not sure how to remedy or if it’s even possible.

  • i tried both of your suggestions with regard to that command. Running it in a terminal restored the desktop, though not the right click functionality on the desktop, and stopped displaying the desktop once closed.

    If you do it this way, you must close the terminal using the command exit. If you close with the mouse it will kill all processes that were started from that terminal.

    Adding it to Startup Programs yielded the Error “/home/chas/&: No such file or directory”

    If you add it to startup programs you don’t need to add the ending & (if I recall correctly). You have to put exactly this: /usr/bin/pcmanfm --desktop

    Additionally, I have noticed that the Applications section of the file manager is empty. Not sure how to remedy or if it’s even possible.

    https://wiki.archlinux.org/index.php/PCManFM#No_.22Applications.22

    Cheers!

  • @karasu using the exit command does allow for the process to keep running, but unfortunately adding in the command is you wrote it does not start the process on start up, strangely.

    As for the applications menu, the first suggestion of deleting everything in the home/user/.cache/menu will not work because it does not seem as though there is a menu folder in .cache. And forgive my inexperience, but I’m not sure how to edit .xinitrc safely in the manner described.

    I have noticed a few things however:
    running PCManFM as sudo from the terminal removes all my desktop/documents/music etc shortcuts in the left side pane, but restores the functionality of the Applications shortcut. Also, although I’ve set PCManFM as the preferred file manager in Preferred Applications, when I attempt to launch the File Manager from the Dropbox icon on my panel, a popup displays asking me to choose a default file manager.

    I had no idea switching file managers would be this tedious!

  • Hi,

    I’ve just installed pcmanfm in my computer and it just works (to be honest, it’s an Openbox based installation, not a XFCE one).

    I do not have /home/user/.cache/menu folder, or any XDG_MENU env var, so that info must be old, sorry.

    Install gnome-menus and lxmenu-data packages installed and let’s hope it makes a difference (I have both installed).

    sudo pacman -S gnome-menus lxmenu-data

  • Looks like I had both of those installed already

    Now I’m starting to feel bad that my system apparently sucks

    EDIT: OK we can chalk PART of this up to strangeness. I went into Desktop Preferences/Advanced and unchecked “Show menus provided by window managers when desktop is clicked,” and am now able to right click and open a menu containing Create New, Paste, Select All, Invert Selection, Sort Files, and Desktop Preferences. So weird, but OK.

    Still no joy on the Applications folder or the Dropbox thing though

  • Hi,

    I’ve been playing around a bit with pcmanfm.

    I run it this way:
    pcmanfm -d --desktop

    Then automagically it starts controlling my desktop.

    I can change preferences with:
    pcmanfm --desktop-pref

    There is an option to show the default apps menu

    I can open preferences dialog with this:
    pcmanfm --show-pref=1

    But I’m not capable to see what uses to fill the applications tab.

    EDIT: Maybe here you have more luck:
    https://forum.lxde.org/viewforum.php?f=22

    I remember that there is an option in XFCE to tell it which programs do you want to use as default. I suppose you already have tried.

  • @karasu well that command seems to be working for the auto start, so unless there’s something else I should do (based on how thunar did not require such an entry) I think that should be good.

    I do not see any such default apps menu in the desktop preferences folder.

    Guess the applications bit will remain a mystery

xfce50 pcmanfm1 Posts 9Views 913
Log in to reply