• White screen once lightdm starts (lightdm crashes?)


    I did a fresh install with KDE as my desktop environment.

    Lightdm crashes and displays a white screen with only the cursor visible.

    Nothing really valuable in /var/log/Xorg.0.log, however, in journalctl I notice:

    WebkitWebProcess[775]: segfault at 0 ip 00007fc9dde047a8 sp 00007fc9809fe7e0 erro 4 in libwebkit2gtk-4.0.so.37.14.9[7fc9dc66c000+26fe000]
    Started process core dump
    systemd-coredump: Process (WebkitWebProcess) dumped core
    something about libwebkit2gtk-4.0.so.37
    

    I abridged it because I’m typing this manually from another computer.
    Also lightdm outputs this in journalctl

    session_get_login1_session_id: assertion 'session != NULL' failed
    

    Tried installing gdm, but I get an error too, after a crash screen (from journalctl)

    Unrecoverable failure in required component org.gnome.Shell.desktop
    

    Using startx directly, I get into twm just fine. Any idea? Is the Antergos installer broken or something? Thanks for your time. 😉

  • Did you disable lightdm before starting gdm? I installed Antergos on 3 different machines and had problems with lightdm in all 3 cases. My laptop still runs Antergos and I use lxdm as I had problems with gdm as well. May want to give lxdm a try if gdm does not work.

    sudo systemctl disable lightdm && sudo systemctl enable gdm
    
    
  • Yes, I’m pretty sure I disabled AND stopped lightdm before enabling and starting gdm.

    I tried lxdm, it works indeed!

    Can anyone follow up with this? Is this an actual problem with lightdm these day? Are the devs aware of it?

  • UPDATE! I have reinstalled Antergos (KDE) WITHOUT the nVidia proprietary drivers (which mean I must be using nouveau) and lightdm doesn’t crash anymore!

    However, I still can’t figure out how to properly install nvidia drivers for my GTX 670M. It gets stuck at loading the display manager. Nothing in the “bumblebee-for-nvidia-optimus” wiki fixed anything (I don’t hav any Intel GPU)… 😞
    I’m really bummed out. Not sure if I should consider this as solved or not, considering installing proprietary drivers through pacman just doesn’t work in the end.

    Fixed my issues here: forum.antergos.com/topic/5723/nvidia-optimus-graphics-card-with-2-nvidia-gpu
    It was a GPU driver issue after all.

lightdm125 white10 starts4 Posts 4Views 1493
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.