• lost my swap & hibernation device


    When adding yet another linux distro to test it forced me to format swap. Now in Antergos i get a 90 sec delay error swap/hibernation device not found. What line and file do i need to edit in order to have Antergos refind my swap and be rid of the delay? Many thanks!

  • Hi,

    swapon /dev/sdaX (where X is the number of the swap partition)

    If you want to make it permanent (so you don’t have to call swapon each time you boot your computer), you should add this line to your /etc/fstab file (with sudo nano /etc/fstab)

    /dev/sdaX none swap defaults 0 0

    Again, change that X for your partition number

    More info: https://wiki.archlinux.org/index.php/Fstab

    Cheers!

  • if you formatted the swap it changed the ID number, you can open gparted and look for the new ID, then you go to /etc/fstab and change the old ID for the new one as @karasu said.

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • Tried both options but my antergos booted up still looking for
    the original swap drive, with 90 sec delay. On reboot it looks for, but cannot find, the new swap. No biggie for me as I’ve become accustomed to my virtual life on usb drives, and so did a complete reinstall… but i am still interested in the concept. Is there another step where i make the os aware of the fstab change, or am i missing something else? Thanks.

  • @billwx Devices in /etc/fstab may be indicated by using device names, device labels, device UUIDs. All methods are equally valid. There’s no difference between them. Each one may be used.

    Among kernel’s boot parameters there’s one, which indicates a device to be used for hibernation. It is the resume= parameter. The same device, if resume= is present in the boot line, is used for swap.

    Again, devices in resume= may be indicated by using device names, device labels, device UUIDs. All methods are equally valid. There’s no difference between them. Each one may be used.

    One method may be used in /etc/fstab, and another may be used in resume=. It is possible to use device names in one place, and device labels, or device UUIDs in another.

    For example, if the /dev/sda12 has UUID=abcde, then it is possible to write /dev/sda12 none swap defaults 0 0 in /etc/fstab, and resume=UUID=abcde in the kernel’s boot line. Or, use the same scheme in both places.

    The point is - independently from the indication method, both /etc/fstab and resume= must point to the same hibernation / swap device.

    Someone, sometime (arounf 2010) has decided that UUIDs is the smartest way to use. (Personally, I totally disagree and continue to use device names.) If, for any reason, a device UUID changes, it must be adjusted in two places:

    • in /etc/fstab
    • in resume=

    The new UUID may be placed In /etc/fstab by hand.

    To place it in the resume= parameter Grub 2 has a script (command) that rebuilds /boot/grub/grub.cfg file, adjusting resume= value as needed. The script will put the new UUID into it. I do not use Grub 2, and don’t remember the name of the script.

    Just remember - if UUID changes, you should:

    • adjust /etc/fstab
    • adjust grub.cfg

    Regards

  • @just ah, you mean /etc/default/grub (sorry, i forgot to mention)?
    @billwx you must edit the line similar to this:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=7ef73ce6-8250-4b87-80ea-8c76dc27f733"
    put your own UUID number and save.

    Edit: and after you’ll need to update the grub config:
    sudo grub-mkconfig -o /boot/grub/grub.cfg

    Then reboot and see if worked!

    Cheers

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

device10 hibernation7 swap5 lost6 Posts 6Views 664
Log in to reply