• Cinnamon Update crashes Antergos


    Hey,
    I just wanted to install some updates (about 120, haven’t used my Computer for a week) and on trying to update cinnamon it crashed. The only thing I could do was to confirm the “cinnamon crashed” dialogs. After rebooting I’m sitting here with the well-known black Screen wi´the the white blinking cursor. So I did the ctrl+alt+F2 thing and tried to update cinnamon and according to this thread my NVIDIA Drivers (though I took the nvidia packet, not nvidia-304xxx and also tried switching to mesa-libgl, updating lightdm, the numix-frost-themes, installing GNOME, nothing.
    I also tried opening the non-GUI mode (systemd.unit=mulit-user.target) but hadn’t found what I should do there exactly. The only thing that I saw was that I got quiet often the error "could not open file /var/lib/pacman/local/Linux-4.8.13-1/desc: No such file or directory"
    furthermore, after finding the part of installing gdm it looks like I don’t have a network Connection at the moment, at least it ends with some errors including "failed retrieving file xyz from mirror.is.co.za :Could not resolve host: mirror.is.co.za"
    and a ping Google.com delivers "ping: Google.com: Name or Service not known. So downgarding the numix theme would probably fail too (if I would understand the manual)

    Anyone any idea what I could try or at least how I could get some helpful logs to a USB stick to help to find the Problem?

  • @rrosner5 you can try to ‘Chroot’ intoo the system,

    Mount your root to /mnt if you have all mounted, when you on usb stick, then : sudo systemd-nspawn

    services like gist or ix from aur, you can forward to pastebin gist is for github do like : cat file.txt | gist , you get a pastebin

    try to send pacman log and ~/.cinnamon/(some glass log)

    you can eventually , i dont know why he crashed mayby something in the logs will find?

  • try to send pacman log

    That’s vital. We need to know what was the update (/var/log/pacman.log)

    Try also a journalctl -xb

    Oh, to downgrade you don’t need network connection. Go to /var/cache/pacman/pkg and look for the package there. Downgrade with
    sudo pacman -U name_of_the_package_file.xz

    Cheers!

  • @ringo32 said in Cinnamon Update crashes Antergos:

    @rrosner5 you can try to ‘Chroot’ intoo the system,

    Mount your root to /mnt if you have all mounted, when you on usb stick, then : sudo systemd-nspawn

    Ok, but how exactly do I do that? just a mount / /mnt or what exactly? And where do I mount the stick and how do I get the stuff over there?
    Also, it would be easier for me if I could use the Live Antergos to do all that, I’m not the biggest friend of Terminal for everything yet. But I don’t know how to mount it there. From filemanager it seems it can’t find it, at least it won’t show the device the “Disks” tool shows for it. I already tried to unlock the partition from the disks tool (it’s LUKS Encrypted, but I just get an “Authentication is required to unlock the encrypted device Samsung SSD 840 Series (/dev/sda2)” And I have no idea what password it wants. At least it’s not the one for login and sudo.

    Oh, and before I forget, I tried to boot to system again, today I got a message:

    [FAILED] Failed to start Tight Display Manager. See ‘systemctl status lightdm’ for details.

    below that, after showing another error fr a moment it shows

    [ OK ] Started Update man-db cache.

    with the blinking cursor underneath it

  • I already tried to unlock the partition from the disks tool (it’s LUKS Encrypted, but I just get an “Authentication is required to unlock the encrypted device Samsung SSD 840 Series (/dev/sda2)” And I have no idea what password it wants. At least it’s not the one for login and sudo.

    It’s asking you for the luks/encryption password. You set it when installing Antergos in this screen:

    https://antergos.com/wp-content/uploads/2013/11/automatic-lvm-luks.png

  • @karasu no, I don’t think so. all I remember was setting the passphrase, a passwort for login and one for sudo. Never set nor used any additional password. And that password question popped up after entering the passphrase.

    EDIT: tried with latest iso, now that works. Now I went to /var/log/ and got the gufw.log, pacman.log, Xorg.0.log, Xorg.0.log.old, faillog, btmp, btmp.1 and everything from the subfolder lightdm. But I don’t know where the cinnamon lookingglass logs are and how to reproduce the journalctl -xb. Or is that just getting something from the journal folder in /var/log?

    Here you have the pacman.log, lightdm.log and seat0-greeter.log. If you need the others just say so, but I can’t open faillog, btmp and btmp.1 in a way that shows something readable

  • ok, it seems that it’s possible to chroot into the old system and update it via pacman…but I can’t manage to mount it.
    E.g. the device is sdb. After encrypting the partition in a live Antergos (encrypted with LUKS, main/home partition is LVM) I have three parts in the device (only Antergos is on that SSD): AntergosBoot as /dev/sdb1, “Partition 2”, most likely my home partition as /dev/sdb2, Linux LVM as partiton type and LUKS Encryption (version 1) - Unlocked as content; and third “250 GB LVM2 PV” at /dev/mapper/luks-xxxx (one time also showed as /dev/mapper/crypto) and LVM2 Physical Volume (LVM2 001) as content.
    On the left side of the “Disk” tool I also see the block devices /dev/AntergosVG/AntergosRoot and …/AntergosSwap, and a Loop Device which could be on my stick (at least it’s mounted to /run/archiso/sfs/root-image.

    so, for mounting sdb1 and sdb2 (don’t know i if I have to mount any of the others) I do:

    sudo -s
    mkdir /arch
    mkdir /arch/home
    mount /dev/sdb1 /arch
    mount /dev/sdb2 /arch/home
    

    but then I get

    mount: unknown filesystem type 'crypto_LUKS'
    

    I read on a different site how to work with encrypted partitions, skipped the cryptsetup luksOpen /dev/sdb crypto part since ot was already unencrypted and used - like in the example there - the device with LVM2:

    mount /dev/mapper/luks-xxxx /arch
    

    (luks-xxx is that enormous ID-thing I just coppied to terminal) but only got

    mount: unknown filesystem type 'LVM2_member'
    

    Can someone please help me to get the chroot running in my case? I just can’t find a manual that I can understand that shows how to prevent those errors from happening.

  • I read on a different site how to work with encrypted partitions, skipped the cryptsetup luksOpen /dev/sdb crypto part since ot was already unencrypted and used

    Nope, I don’t think so. You must use cryptsetup to “unlock” your LUKS encrypted partition. Then you will be able to mount it normally.

    Did you also setup LVM on that disk? If the answer is yes, you’ll have to deal with it, too.

  • @karasu I tried both, unlocking over the Disk tool and with the mentioned command, problem still exists.
    And that I have to deal with the LVM is the problem. I wrote that my home partition is LVM, it’s written down very exactly.
    Keep in mind, this is the noob section, so read and give helpful tips and don’t come with obvious stuff nobody asks for…

  • Keep in mind, this is the noob section, so read and give helpful tips and don’t come with obvious stuff nobody asks for…

    That’s a good attitude to get help from others.
    If you’re a noob as you say, why did you use LVM and LUKS if you don’t know how to manage them?

    Anyways, once you have unlocked your LUKS device, you must mount your LVM volumes (that is, /dev/AntergosVG/AntergosRoot, not /dev/sdb2)

  • @karasu said in Cinnamon Update crashes Antergos:

    Anyways, once you have unlocked your LUKS device, you must mount your LVM volumes (that is, /dev/AntergosVG/AntergosRoot, not /dev/sdb2)

    thanks, THAT was what I was asking for. I now mounted everything following this manual (I know, it’s written in german but the important part is the commands, so that should be enough to understand what I did.
    But I still can’t really manage to start the chroot:

    # chroot /arch bash
    chroot: failed to run command 'bash': No such file or directory
    

    then I foudn a different command with the same error:

    chroot . /bin/bash
    chroot: failed to run command '/bin/bash': No such file or directory
    

    googling around I found an arch wiki with the following command…and error:

    arch-chroot /arch
    mount: proc is already mounted or /arch/proc busy
           proc is already mounted on /proc
    ==> ERROR: failed to setup chroot /arch
    
    Usage:
     unmount [-hV]
     unmount -a [options]
     unmount [options] <source> | <directory>
    
    Unmount filesystems.
    
    Options:
    xxxx
    
    For more details see unmount (8).
    
  • Hi,

    So you mounted your lvm root volume into /arch, right? Then you only need to run arch-chroot /arch

    I think you got that error (proc is already mounted…) because you manually mounted /proc /sys … into /arch. Don’t do it. arch-chroot /arch does it for you.

    Oh, when you mount your volume into /arch, and before issuing the arch-chroot command, have a look at what’s in there with ls /arch You should see your root volume. (just to be safe).

  • @karasu oh, ok. Then I’ll try that.
    and for repair I hope it’ll be enough to run

    pacman -Syu
    

    …I guess I just have to enter that after successfully enter chroot?

    and after mounting /dev/sda1 to /arch and /dev/AntergosVG/AntergosRoot to /arch/home I get the following stuff in /arch:

    # ls /arch
    dev grub initframfs-linux-fallback.img lost+found sys
    etc home initframfs-linux.img          proc       vmlinuz-linux
    

    is that what is supposed to be there?

    EDIT: I just tried to start chroot…after manually adding /arch/run and /arch/tmp (why doesn’t it just add them itself?) I still get

    chroot: failed to run command '/bin/bash': No such file or directory
    

  • Forget about /home, you don’t need it.

    You have to mount /dev/AntergosVG/AntergosRoot to /arch and then /dev/sda1 to /arch/boot, in this order (first root then boot).

  • @karasu no, I did how I told, but I’ll try that, thanks

    EDIT: worked, thanks. I’m running pacman now. If I can boot the system afterwards I will close here, otherwise I’ll ask again what else I could do

    EDIT2:
    still getting

    [FAILED] Failed to start Light Dsiplay Manager.
    See 'systemctl status lightdm.service' for details.
    [  OK  ] Started Update man-db cache
    

    Back in chroot I get the following

    # systemd-nspawn
    Spawning container on root directory is not supported. Consider using --ephemeral.
    
    # journalctl -xb
    -- No entries --
    
    # systemctl status lightdm.service
    Running in chroot, ignoring request.
    

    Here are the updated log files I could get:
    lightdm.log, pacman.log, seat0-greeter.log and x-0.log includin the .log.old-files

  • personally i dont like the webkit-greeter, causes only blackscreen here… try to install other greeter like lightdm-gtk-greeter, when gnome try gdm ?

  • @ringo32 ok, I did, but I only get this:
    alt text
    Do I have to uninstall the other one? And if so, what is it called?

  • oh yeah damn forgoth to ask ,… edit /etc/lightdm/lightdm.conf

    search for the line lightdm-webkit-greeter , or webkit-greeter, is but in te middle, change the webkit to gtk …

  • @ringo32 I tried to do so from live linux, but I can only open the file as r/o…how can I open it as su? Is there any terminal command to do so?

  • @rrosner5 Do you mean open terminal as sudo in the live cd?
    Open a NORMAL terminal and type sudo [COMMAND]
    PS: It’s not possible to open the ROOT terminal from the live cd since it ask password, but you can open the normal one and type sudo.
    Cheers.

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

cinnamon69 crashes10 Posts 59Views 6150
Log in to reply