• Failed Upgrade-(could not satisfy dependencies)


    KDE Plasma started a large updated this AM and I encounter an upgrade error. It appears the pacman could not satisfy depends. I’ve included the terminal output—any help resolving this is appreciated. Thanks

    [sudo] password for david: 
    [[email protected] ~]$ yaourt -Syyua && sync
    :: Synchronizing package databases...
     antergos                                                               134.4 KiB   878K/s 00:00 [########################################################] 100%
     core                                                                   122.8 KiB  55.6K/s 00:02 [########################################################] 100%
     extra                                                                 1745.9 KiB   518K/s 00:03 [########################################################] 100%
     community                                                                3.7 MiB   881K/s 00:04 [########################################################] 100%
     multilib                                                               184.0 KiB  1122K/s 00:00 [########################################################] 100%
     Foreign packages: | 20 / 20
    
    ==> Package upgrade only (new release):
    extra/kipi-plugins                       5.3.0-5            5 -> 6
    extra/kreport                            3.0.0-1            1 -> 2
    extra/libkgapi                           5.3.1-1            1 -> 2
    extra/libkolab                           1.0.2-2            2 -> 3
    
    ==> Software upgrade (new version) :
    core/libgcrypt                           1.7.3-1            -> 1.7.5-1
    core/linux-lts                           4.4.38-1           -> 4.4.39-1
    core/logrotate                           3.10.0-1           -> 3.11.0-1
    core/man-db                              2.7.5-4            -> 2.7.6.1-2
    core/man-pages                           4.08-1             -> 4.09-1
    core/nano                                2.7.1-1            -> 2.7.2-1
    extra/akonadi                            16.08.3-1          -> 16.12.0-1
    extra/akonadi-calendar                   16.08.3-1          -> 16.12.0-1
    extra/akonadi-contacts                   16.08.3-1          -> 16.12.0-1
    extra/akonadi-mime                       16.08.3-1          -> 16.12.0-1
    extra/akonadi-notes                      16.08.3-1          -> 16.12.0-1
    extra/akonadi-search                     16.08.3-1          -> 16.12.0-1
    extra/akregator                          16.08.3-1          -> 16.12.0-1
    extra/ark                                16.08.3-1          -> 16.12.0-1
    extra/attica-qt5                         5.28.0-1           -> 5.29.0-1
    extra/baloo                              5.28.0-1           -> 5.29.0-1
    extra/baloo-widgets                      16.08.3-1          -> 16.12.0-1
    extra/bluez-qt                           5.28.0-1           -> 5.29.0-1
    extra/breeze-icons                       5.28.0-1           -> 5.29.0-1
    extra/calendarsupport                    16.08.3-1          -> 16.12.0-1
    extra/dolphin                            16.08.3-1          -> 16.12.0-1
    extra/dolphin-plugins                    16.08.3-1          -> 16.12.0-1
    extra/dragon                             16.08.3-1          -> 16.12.0-2
    extra/eventviews                         16.08.3-1          -> 16.12.0-1
    extra/ffmpegthumbs                       16.08.3-1          -> 16.12.0-1
    extra/frameworkintegration               5.28.0-1           -> 5.29.0-1
    extra/grantleetheme                      16.08.3-1          -> 16.12.0-1
    extra/gwenview                           16.08.3-1          -> 16.12.0-1
    extra/incidenceeditor                    16.08.3-1          -> 16.12.0-1
    extra/kaccounts-integration              16.08.3-1          -> 16.12.0-1
    extra/kaccounts-providers                16.08.3-1          -> 16.12.0-1
    extra/kactivities                        5.28.0-1           -> 5.29.0-1
    extra/kactivities-stats                  5.28.0-1           -> 5.29.0-1
    extra/kaddressbook                       16.08.3-1          -> 16.12.0-1
    extra/kalarmcal                          16.08.3-1          -> 16.12.0-1
    extra/karchive                           5.28.0-1           -> 5.29.0-1
    extra/kate                               16.08.3-1          -> 16.12.0-1
    extra/kauth                              5.28.0-1           -> 5.29.0-1
    extra/kbookmarks                         5.28.0-1           -> 5.29.0-1
    extra/kcalc                              16.08.3-1          -> 16.12.0-1
    extra/kcalcore                           16.08.3-1          -> 16.12.0-1
    extra/kcalutils                          16.08.3-1          -> 16.12.0-1
    extra/kcmutils                           5.28.0-1           -> 5.29.0-1
    extra/kcodecs                            5.28.0-1           -> 5.29.0-1
    extra/kcompletion                        5.28.0-1           -> 5.29.0-1
    extra/kconfig                            5.28.0-1           -> 5.29.0-1
    extra/kconfigwidgets                     5.28.0-1           -> 5.29.0-1
    extra/kcontacts                          16.08.3-1          -> 16.12.0-1
    extra/kcoreaddons                        5.28.0-1           -> 5.29.0-1
    extra/kcrash                             5.28.0-1           -> 5.29.0-1
    extra/kdbusaddons                        5.28.0-1           -> 5.29.0-1
    extra/kdebase-runtime                    16.08.3-4          -> 16.12.0-1
    extra/kdeclarative                       5.28.0-1           -> 5.29.0-1
    extra/kded                               5.28.0-1           -> 5.29.0-1
    extra/kdegames-kigo                      16.08.3-1          -> 16.12.0-1
    extra/kdegraphics-thumbnailers           16.08.3-1          -> 16.12.0-1
    extra/kdelibs                            4.14.26-3          -> 4.14.27-1
    extra/kdelibs4support                    5.28.0-1           -> 5.29.0-1
    extra/kdenetwork-kopete                  16.08.3-3          -> 16.12.0-1
    extra/kdenlive                           16.08.3-1          -> 16.12.0-1
    extra/kdepim-apps-libs                   16.08.3-1          -> 16.12.0-1
    extra/kdepim-runtime                     16.08.3-1          -> 16.12.0-1
    extra/kdesu                              5.28.0-1           -> 5.29.0-1
    extra/kde-syndication                    16.08.3-1          -> 16.12.0-1
    extra/kdeutils-sweeper                   16.08.3-1          -> 16.12.0-1
    extra/kdewebkit                          5.28.0-1           -> 5.29.0-1
    extra/kdnssd                             5.28.0-1           -> 5.29.0-1
    extra/kdoctools                          5.28.0-1           -> 5.29.0-1
    extra/kemoticons                         5.28.0-1           -> 5.29.0-1
    extra/kfilemetadata                      5.28.0-1           -> 5.29.0-1
    extra/kglobalaccel                       5.28.0-1           -> 5.29.0-1
    extra/kguiaddons                         5.28.0-1           -> 5.29.0-1
    extra/khelpcenter                        16.08.3-1          -> 16.12.0-1
    extra/kholidays                          16.08.3-1          -> 16.12.0-1
    extra/khtml                              5.28.0-1           -> 5.29.0-1
    extra/ki18n                              5.28.0-1           -> 5.29.0-1
    extra/kiconthemes                        5.28.0-1           -> 5.29.0-1
    extra/kidentitymanagement                16.08.3-1          -> 16.12.0-1
    extra/kidletime                          5.28.0-1           -> 5.29.0-1
    extra/kimap                              16.08.3-1          -> 16.12.0-1
    extra/kinit                              5.28.0-1           -> 5.29.0-1
    extra/kio                                5.28.0-1           -> 5.29.0-1
    extra/kio-extras                         16.08.3-1          -> 16.12.0-1
    extra/kitemmodels                        5.28.0-1           -> 5.29.0-1
    extra/kitemviews                         5.28.0-1           -> 5.29.0-1
    extra/kjobwidgets                        5.28.0-1           -> 5.29.0-1
    extra/kjs                                5.28.0-1           -> 5.29.0-1
    extra/kjsembed                           5.28.0-1           -> 5.29.0-1
    extra/kldap                              16.08.3-1          -> 16.12.0-1
    extra/kmahjongg                          16.08.3-1          -> 16.12.0-1
    extra/kmail                              16.08.3-1          -> 16.12.0-1
    extra/kmailtransport                     16.08.3-1          -> 16.12.0-1
    extra/kmbox                              16.08.3-1          -> 16.12.0-1
    extra/kmime                              16.08.3-1          -> 16.12.0-1
    extra/knewstuff                          5.28.0-1           -> 5.29.0-1
    extra/knotes                             16.08.3-1          -> 16.12.0-1
    extra/knotifications                     5.28.0-1           -> 5.29.0-1
    extra/knotifyconfig                      5.28.0-1           -> 5.29.0-1
    extra/konsole                            16.08.3-1          -> 16.12.0-1
    extra/kontact                            16.08.3-1          -> 16.12.0-1
    extra/kontactinterface                   16.08.3-1          -> 16.12.0-1
    extra/korganizer                         16.08.3-1          -> 16.12.0-1
    extra/kpackage                           5.28.0-2           -> 5.29.1-1
    extra/kparts                             5.28.0-1           -> 5.29.0-1
    extra/kpeople                            5.28.0-1           -> 5.29.0-1
    extra/kpimtextedit                       16.08.3-1          -> 16.12.0-1
    extra/kpty                               5.28.0-1           -> 5.29.0-1
    extra/kross                              5.28.0-1           -> 5.29.0-1
    extra/krunner                            5.28.0-1           -> 5.29.0-1
    extra/kservice                           5.28.0-1           -> 5.29.0-1
    extra/ktexteditor                        5.28.0-1           -> 5.29.0-1
    extra/ktextwidgets                       5.28.0-1           -> 5.29.0-1
    extra/kunitconversion                    5.28.0-1           -> 5.29.0-1
    extra/kwallet                            5.28.0-1           -> 5.29.0-1
    extra/kwalletmanager                     16.08.3-1          -> 16.12.0-1
    extra/kwayland                           5.28.0-1           -> 5.29.0-1
    extra/kwidgetsaddons                     5.28.0-1           -> 5.29.0-1
    extra/kwindowsystem                      5.28.0-1           -> 5.29.0-1
    extra/kxmlgui                            5.28.0-1           -> 5.29.0-1
    extra/libgravatar                        16.08.3-1          -> 16.12.0-1
    extra/libkdcraw                          16.08.3-1          -> 16.12.0-1
    extra/libkdegames                        16.08.3-1          -> 16.12.0-1
    extra/libkdepim                          16.08.3-1          -> 16.12.0-1
    extra/libkexiv2                          16.08.3-1          -> 16.12.0-1
    extra/libkipi                            16.08.3-1          -> 16.12.0-1
    extra/libkleo                            16.08.3-2          -> 16.12.0-1
    extra/libkmahjongg                       16.08.3-1          -> 16.12.0-1
    extra/libksane                           16.08.3-1          -> 16.12.0-1
    extra/libksieve                          16.08.3-1          -> 16.12.0-1
    extra/libktnef                           16.08.3-1          -> 16.12.0-1
    extra/mailcommon                         16.08.3-1          -> 16.12.0-1
    extra/mailimporter                       16.08.3-1          -> 16.12.0-1
    extra/marble                             16.08.3-1          -> 16.12.0-1
    extra/marble-data                        16.08.3-1          -> 16.12.0-1
    extra/messagelib                         16.08.3-1          -> 16.12.0-1
    extra/modemmanager-qt                    5.28.0-1           -> 5.29.0-1
    extra/networkmanager-qt                  5.28.0-1           -> 5.29.0-1
    extra/oxygen-icons                       1:5.28.0-1         -> 1:5.29.0-1
    extra/pimcommon                          16.08.3-1          -> 16.12.0-1
    extra/plasma-framework                   5.28.0-1           -> 5.29.0-1
    extra/print-manager                      16.08.3-1          -> 16.12.0-1
    extra/prison                             5.28.git20161116-1 -> 5.29.0-1
    extra/qt5-base                           5.7.0-9            -> 5.7.1-1
    extra/qt5-declarative                    5.7.0-3            -> 5.7.1-1
    extra/qt5-graphicaleffects               5.7.0-1            -> 5.7.1-1
    extra/qt5-location                       5.7.0-1            -> 5.7.1-1
    extra/qt5-multimedia                     5.7.0-1            -> 5.7.1-1
    extra/qt5-quickcontrols                  5.7.0-1            -> 5.7.1-1
    extra/qt5-script                         5.7.0-1            -> 5.7.1-1
    extra/qt5-sensors                        5.7.0-1            -> 5.7.1-1
    extra/qt5-svg                            5.7.0-1            -> 5.7.1-1
    extra/qt5-tools                          5.7.0-2            -> 5.7.1-1
    extra/qt5-webchannel                     5.7.0-1            -> 5.7.1-1
    extra/qt5-webengine                      5.7.0-7            -> 5.7.1-1
    extra/qt5-webkit                         5.7.0-3            -> 5.7.1-1
    extra/qt5-x11extras                      5.7.0-1            -> 5.7.1-1
    extra/qt5-xmlpatterns                    5.7.0-2            -> 5.7.1-1
    extra/signon-kwallet-extension           16.08.3-1          -> 16.12.0-1
    extra/solid                              5.28.0-1           -> 5.29.0-1
    extra/sonnet                             5.28.0-3           -> 5.29.0-1
    extra/spectacle                          16.08.3-1          -> 16.12.0-1
    extra/telepathy-kde-accounts-kcm         16.08.3-1          -> 16.12.0-1
    extra/telepathy-kde-approver             16.08.3-1          -> 16.12.0-1
    extra/telepathy-kde-auth-handler         16.08.3-1          -> 16.12.0-1
    extra/telepathy-kde-call-ui              16.08.3-1          -> 16.12.0-1
    extra/telepathy-kde-common-internals     16.08.3-1          -> 16.12.0-1
    extra/telepathy-kde-contact-list         16.08.3-1          -> 16.12.0-1
    extra/telepathy-kde-contact-runner       16.08.3-1          -> 16.12.0-1
    extra/telepathy-kde-desktop-applets      16.08.3-1          -> 16.12.0-1
    extra/telepathy-kde-filetransfer-handler 16.08.3-1          -> 16.12.0-1
    extra/telepathy-kde-integration-module   16.08.3-1          -> 16.12.0-1
    extra/telepathy-kde-meta                 16.08-1            -> 16.12-1
    extra/telepathy-kde-send-file            16.08.3-1          -> 16.12.0-1
    extra/telepathy-kde-text-ui              16.08.3-1          -> 16.12.0-1
    extra/threadweaver                       5.28.0-1           -> 5.29.0-1
    
    ==> New package :
    core/qgpgme                              1.7.1-2            (required by libkleo)
    extra/akonadi-import-wizard              16.12.0-1          (required by kmail)
    extra/kdiagram                           2.6.0-1            (required by eventviews)
    extra/kmail-account-wizard               16.12.0-1          (required by kmail)
    extra/mbox-importer                      16.12.0-1          (required by kmail)
    extra/pim-sieve-editor                   16.12.0-1          (required by kmail)
    extra/pim-storage-service-manager        16.12.0-1          (required by kmail)
    extra/syntax-highlighting                5.29.0-1           (required by kpimtextedit)
    
    ==> Continue upgrade ? [Y/n]
    ==> [V]iew package detail   [M]anually select packages
    ==> --------------------------------------------------
    ==> y
    :: Starting full system upgrade...
    :: Replace kdebase-kdialog with extra/kdialog? [Y/n] y
    :: Replace kdebase-kfind with extra/kfind? [Y/n] y
    :: Replace kdegraphics-okular with extra/okular? [Y/n] y
    :: Replace kdeutils-kgpg with extra/kgpg? [Y/n] y
    :: Replace libastro with extra/marble? [Y/n] y
    resolving dependencies...
    looking for conflicting packages...
    :: kmail-account-wizard and kdepim-common are in conflict. Remove kdepim-common? [y/N] y
    error: failed to prepare transaction (could not satisfy dependencies)
    :: antergos-kde-setup: removing kdebase-kdialog breaks dependency 'kdebase-kdialog'
    :: antergos-kde-setup: removing kdebase-kfind breaks dependency 'kdebase-kfind'
    :: antergos-kde-setup: removing kdegraphics-okular breaks dependency 'kdegraphics-okular'
    :: kde-servicemenus-rootactions: removing kdebase-kdialog breaks dependency 'kdebase-kdialog'
    [[email protected] ~]$ `
  • Please, always check for similar issues before creating a new one.
    https://forum.antergos.com/topic/5701/cannot-update-kde-breaks-dependency/8

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @axioma Thanks for the link. I followed the instructions and upgraded successfully.

  • @anarch My apologies. Early morning for me----I should have checked for similar issues…will do so in the future.

  • No worries!:+1:

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch said in Failed Upgrade-(could not satisfy dependencies):

    No worries!:+1:

    So, we get a fix in 24 hours?

  • @dirkme That is not what was suggested by the developers. I am sure they are working on it, but I think they have to attend to their families, work and get some sleep too.
    So, maybe a little longer, or shorter if they get to it. :grinning:

    If in a hurry, just follow the directions given in the link below. :+1:

    Never to old to learn.

  • @dirkme sudo pacman -R kde-servicemenus-rootactions antergos-kde-setup

    That does the trick, now my update is running OK.
    Thanks guys, still thumbs up for Antergos ;-)

upgrade-could1 satisfy3 dependencies4 Posts 9Views 605
Log in to reply