• Python2-pip install problem!


    Hey,
    First forgive me if this is outside the scope of the antergos forums. I’m was trying to update my system and encountered a problem with python2-pip and python-pip. Both errors show that the files already exist in my system, should I try to force the install? What would be the best course of action here?

    I uninstalled python2-pip and python-pip and tried to re-install thinking that might work but it did not.

    python 3 and python 2 error messages

    Packages (1) python-pip-9.0.1-1
    
    Total Download Size:   1.35 MiB
    Total Installed Size:  6.34 MiB
    
    :: Proceed with installation? [Y/n] y
    :: Retrieving packages...
     python-pip-9.0.1-1-any                                                                  1385.1 KiB   102K/s 00:14 [####################################################################] 100%
    (1/1) checking keys in keyring                                                                                     [####################################################################] 100%
    (1/1) checking package integrity                                                                                   [####################################################################] 100%
    (1/1) loading package files                                                                                        [####################################################################] 100%
    (1/1) checking for file conflicts                                                                                  [####################################################################] 100%
    error: failed to commit transaction (conflicting files)
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/__pycache__/appdirs.cpython-35.pyc exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/__pycache__/distro.cpython-35.pyc exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/__pycache__/ordereddict.cpython-35.pyc exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/appdirs.py exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/distro.py exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/html5lib/__pycache__/_ihatexml.cpython-35.pyc exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/html5lib/__pycache__/_inputstream.cpython-35.pyc exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/html5lib/__pycache__/_tokenizer.cpython-35.pyc exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/html5lib/__pycache__/_utils.cpython-35.pyc exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/html5lib/__pycache__/serializer.cpython-35.pyc exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/html5lib/_ihatexml.py exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/html5lib/_inputstream.py exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/html5lib/_tokenizer.py exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/html5lib/_trie/__init__.py exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/html5lib/_trie/__pycache__/__init__.cpython-35.pyc exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/html5lib/_trie/__pycache__/_base.cpython-35.pyc exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/html5lib/_trie/__pycache__/datrie.cpython-35.pyc exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/html5lib/_trie/__pycache__/py.cpython-35.pyc exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/html5lib/_trie/_base.py exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/html5lib/_trie/datrie.py exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/html5lib/_trie/py.py exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/html5lib/_utils.py exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/html5lib/filters/__pycache__/base.cpython-35.pyc exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/html5lib/filters/base.py exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/html5lib/serializer.py exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/html5lib/treeadapters/__pycache__/genshi.cpython-35.pyc exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/html5lib/treeadapters/genshi.py exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/html5lib/treebuilders/__pycache__/base.cpython-35.pyc exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/html5lib/treebuilders/base.py exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/html5lib/treewalkers/__pycache__/base.cpython-35.pyc exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/html5lib/treewalkers/__pycache__/etree_lxml.cpython-35.pyc exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/html5lib/treewalkers/__pycache__/genshi.cpython-35.pyc exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/html5lib/treewalkers/base.py exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/html5lib/treewalkers/etree_lxml.py exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/html5lib/treewalkers/genshi.py exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/ordereddict.py exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/webencodings/__init__.py exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/webencodings/__pycache__/__init__.cpython-35.pyc exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/webencodings/__pycache__/labels.cpython-35.pyc exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/webencodings/__pycache__/mklabels.cpython-35.pyc exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/webencodings/__pycache__/tests.cpython-35.pyc exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/webencodings/__pycache__/x_user_defined.cpython-35.pyc exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/webencodings/labels.py exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/webencodings/mklabels.py exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/webencodings/tests.py exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/_vendor/webencodings/x_user_defined.py exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/commands/__pycache__/check.cpython-35.pyc exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/commands/check.py exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/operations/__pycache__/check.cpython-35.pyc exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/operations/check.py exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/utils/__pycache__/glibc.cpython-35.pyc exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/utils/__pycache__/packaging.cpython-35.pyc exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/utils/glibc.py exists in filesystem
    python-pip: /usr/lib/python3.5/site-packages/pip/utils/packaging.py exists in filesystem
    Errors occurred, no packages were upgraded.
    ...
    ...
    
    Packages (1) python2-pip-9.0.1-1
    
    Total Installed Size:  6.65 MiB
    
    :: Proceed with installation? [Y/n] y
    (1/1) checking keys in keyring                                                                                     [####################################################################] 100%
    (1/1) checking package integrity                                                                                   [####################################################################] 100%
    (1/1) loading package files                                                                                        [####################################################################] 100%
    (1/1) checking for file conflicts                                                                                  [####################################################################] 100%
    error: failed to commit transaction (conflicting files)
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/appdirs.py exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/appdirs.pyc exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/distro.py exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/distro.pyc exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/html5lib/_ihatexml.py exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/html5lib/_ihatexml.pyc exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/html5lib/_inputstream.py exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/html5lib/_inputstream.pyc exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/html5lib/_tokenizer.py exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/html5lib/_tokenizer.pyc exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/html5lib/_trie/__init__.py exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/html5lib/_trie/__init__.pyc exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/html5lib/_trie/_base.py exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/html5lib/_trie/_base.pyc exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/html5lib/_trie/datrie.py exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/html5lib/_trie/datrie.pyc exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/html5lib/_trie/py.py exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/html5lib/_trie/py.pyc exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/html5lib/_utils.py exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/html5lib/_utils.pyc exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/html5lib/filters/base.py exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/html5lib/filters/base.pyc exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/html5lib/serializer.py exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/html5lib/serializer.pyc exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/html5lib/treeadapters/genshi.py exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/html5lib/treeadapters/genshi.pyc exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/html5lib/treebuilders/base.py exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/html5lib/treebuilders/base.pyc exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/html5lib/treewalkers/base.py exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/html5lib/treewalkers/base.pyc exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/html5lib/treewalkers/etree_lxml.py exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/html5lib/treewalkers/etree_lxml.pyc exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/html5lib/treewalkers/genshi.py exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/html5lib/treewalkers/genshi.pyc exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/ordereddict.py exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/ordereddict.pyc exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/webencodings/__init__.py exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/webencodings/__init__.pyc exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/webencodings/labels.py exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/webencodings/labels.pyc exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/webencodings/mklabels.py exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/webencodings/mklabels.pyc exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/webencodings/tests.py exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/webencodings/tests.pyc exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/webencodings/x_user_defined.py exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/_vendor/webencodings/x_user_defined.pyc exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/commands/check.py exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/commands/check.pyc exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/operations/check.py exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/operations/check.pyc exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/utils/glibc.py exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/utils/glibc.pyc exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/utils/packaging.py exists in filesystem
    python2-pip: /usr/lib/python2.7/site-packages/pip/utils/packaging.pyc exists in filesystem
    Errors occurred, no packages were upgraded.
    
  • Did you install pip using another method? (Not using pacman, I mean).

  • I installed with pacman but after the install I updated pip using.

    sudo pip install --update
    
  • Well, if you --force it, those files will be replaced with the pip 9.0.1 version. It’s up to you.

    You should either use one method or the other, but not both.

    Cheers!

  • I forced installed both with no issues, lesson learned.

    Thank you very much for your quick response, this small issue was important and I didn’t want to break anything ;)

    cheers!

python8 Posts 5Views 518
Log in to reply