• Ant log's automatic in while Automatic login is off ?


    Because my previous login problems with a clean Ant install, i have choosen now for a clean install with “Automatic login on” to be sure that i could login. Install and first boot went very smooth and direct logged in admin account.

    When i want to put “Automatic login on” to “Automatic login off” it’s already off in the Gnome user account settings.
    So, Ant log’s in automatic but the settings in Gnome are “Automatic login off”.

    How to fix this properly with the command line?

    Searched the net and Arch forum but nothing really helpfull came up.
    I am on the latest update! ;)

  • Hi,

    Automatic login is done with lightdm (Gnome only controls gdm).

    You have to manually edit the file:
    sudo nano /etc/lightdm/lightdm.conf

    Search for autologin-user and autologin-user-timeout and comment both options putting a # at the beggining of both lines.

    It should do the trick.

    Cheers!

  • @karasu Thanks, that i understand, but wat with those pam security tricks? Can somebody send me that conf file or important part from lightdm.conf? Do i have also to do this in Antergos Gnome but to put auto login off:
    http://skyriderblog.com/lightdm-autologin-arch-linux/

  • Comment everything (pam-service and pam-autologin) it will work as it will use the defaults, do not worry.

    You can also remove yourself from the autologin group.

auto login2 gnome187 Posts 4Views 162
Log in to reply