• \[Solved\]Keyboard not working with Antergos Advanced Options


    I’m working on a Lenovo Y510P. It has optimus Intel with dual Nvidia GeForce 755M using last testing release of Antergos. I was following the Arch wiki for configuring for PRIME. I installed the Nouveau and intel drivers. After booting the greeter no longer shows. I just get a line about device clean, files and blocks.

    In trying to troubleshoot this, I tried to use Advanced options for Antergos. That locks up too. The keyboard works fine for GRUB 2.0 so I remove the “quiet” parameter. Last line shown is [OK] Reached target Graphical Interface. Nothing else happens.

    Then I reboot, try removing “quiet” and adding a “1” for the equivilant of runlevel 1.

    I get the “Welcome to rescue mode!” prompt - however, keyboard does not work. Pressing Control-D does nothing. not even a flashing cursor.

    I’m not all that familure with systemd rescue, so I try kernel parameter “systemd.unit=multi-user.target” and I get the expected login prompt but keyboard still does not work. I tried adding an external USB keyboard, no good. The CAPLOCKS indicator on laptop does turn on and off though.

    I’m not sure what to do here. Google hasn’t been my friend today. Most things I could find are around keyboard not working with X.

    I can boot from live CDs and the keyboard is fine. Keyboard worked fine while installing Antergos.

  • I’m working on a Lenovo Y510P. It has optimus Intel with dual Nvidia GeForce 755M using last testing release of Antergos. I was following the Arch wiki for configuring for PRIME. I installed the Nouveau and intel drivers. After booting the greeter no longer shows. I just get a line about device clean, files and blocks.

    In trying to troubleshoot this, I tried to use Advanced options for Antergos. That locks up too. The keyboard works fine for GRUB 2.0 so I remove the “quiet” parameter. Last line shown is [OK] Reached target Graphical Interface. Nothing else happens.

    Then I reboot, try removing “quiet” and adding a “1” for the equivilant of runlevel 1.

    I get the “Welcome to rescue mode!” prompt - however, keyboard does not work. Pressing Control-D does nothing. not even a flashing cursor.

    I’m not all that familure with systemd rescue, so I try kernel parameter “systemd.unit=multi-user.target” and I get the expected login prompt but keyboard still does not work. I tried adding an external USB keyboard, no good. The CAPLOCKS indicator on laptop does turn on and off though.

    I’m not sure what to do here. Google hasn’t been my friend today. Most things I could find are around keyboard not working with X.

    I can boot from live CDs and the keyboard is fine. Keyboard worked fine while installing Antergos.

  • Hi,

    Add this to the grub kernel command line and also remove “quiet”:

    earlymodules=atkbd modules-load=atkbd systemd.unit=multi-user.target
    

    Then let me know what you find in /var/log/lightdm

    Cheers!

  • That got me a little further, now the last line is “[ OK ] Started D-bus System Message Bus”. Then it hangs for lack of a better word.

    In looking at “/var/log/lightdm” no files have today’s date. If booting with “systemd.unit=multi-user.target” would you expect these files to be updated?

    I’ll try to boot graphical to force the lightdm logs to be updated and post them here…

  • Log files…

  • Okay now we’re getting somewhere. It appears that your system is booting so fast that the nouveau driver doesn’t have a chance to load before X tries to start. Try this:

    Edit the modules line in /etc/mkinitcpio.conf to say this:

    MODULES="nouveau i915"
    

    Then run:

    sudo mkinitcpio -p linux
    

    Try rebooting normally and with any luck you will see the login screen.

    If that doesnt work, grab the logs again so we can see what changed. Also you may want to look into this: [https://wiki.archlinux.org/index.php/NVIDIA#No_screens_found_on_a_laptop.2FNVIDIA_Optimus][0]">[https://wiki.archlinux.org/index.php/NV][1] … IA_Optimus

    Cheers!

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/NV

  • Sorry if I wasn’t clear… the keyboard still does not work when booting with:

    earlymodules=atkbd modules-load=atkbd systemd.unit=multi-user.target
    

    So I can edit the “mkinitcpio.conf” file from my ubuntu environment, but I don’t have a way of running the “mkinitcpio” command.

    I’m going to see if I can do that from a Antergos ISO USB image with chroot pointing to my HDD install perhaps… not sure if that would work.

    I appreciate the help.

  • So I tried booting from the Antergos test USB in legacy mode to do a chroot like environment. I used the following:

    sudo mkdir /mnt/arch  
    sudo mount /dev/sda10 /mnt/arch  
    sudo mount /dev/sda2 /mnt/arch/boot  
    cd /mnt/arch  
    sudo systemd-nspawn
    

    Note: sda2 is my UEFI boot partition and sda10 is the existing Antergos installation.

    The command “sudo mkinitcpio -p linux” worked, with the following questionable lines:

    -> Running build hook: [keymap]
    Couldn’t get a file descriptor referring to the console.

    And these two warning messages:
    ==> WARNING: Possibly missing firmware for module: aic94xx
    ==> WARNING: Possible missing firmware for module: smsmdtv

    Ends with “Image generation successful”.

    After reboot… LOL… won’t go passed “::running early hook [udev]”. Fun part of learning is breaking it and making it worse I guess. The Wiki ([https://wiki.archlinux.org/index.php/Change_Root][0]">[https://wiki.archlinux.org/index.php/Change_Root][1]) says rebuilding initramfs is a supported command with this method.

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/Change_Root

  • Slight improvement on the process… from the Antergos USB boot. I enter in parameters:

    nomodeset systemd.unit=multi-user.target
    

    Then login as root.

    Then create the chroot like enviroment for my system:

    mkdir /mnt/arch  
    mount /dev/sda10 /mnt/arch  
    mount /dev/sda2 /mnt/arch/boot  
    cd /mnt/arch  
    systemd-nspawn
    

    I then edited the “/etc/mkinitcpio.conf” removing the two modules you suggested, then ran “mkinitcpio -p linux” and after reboot I’m back to where I was. Now that I understand the roll back process works, I’ll add them back in and see what I can get from the log files.

  • OK. Logs look much better now… now it proceeds to a black screen… and then nothing.

  • Hi,

    The best way to really learn linux is to break it

    /etc/modprobe.d/nvidia_blacklist.conf

    blacklist nvidia
    

    Soooo…I sort of forgot to include the keyboard fix in my last instructions

    You may not have to worry about chrooting via the live iso b/c the logs show the driver was loaded (though the intel driver was strangely m-i-a). Just try booting without any additional kernel parameters to see what happens, you never know you might get lucky

    Cheers!

  • @“lots.0.logs”:27q5tenz said:

    To make things easier, go ahead and blacklist the nvidia driver.[/quote:27q5tenz]
    Done.

    @“lots.0.logs”:27q5tenz said:

    You’ll have to edit mkinitcpio.conf again (sorry):

    MODULES="psmouse atkbd nouveau i915"
    

    And of course run “sudo mkinitcpio -p linux”.[/quote:27q5tenz]

    Done.

    @“lots.0.logs”:27q5tenz said:

    In any case, dont boot with “nomodset” b/c it can do nothing for you (Graphics driver requires kernel modsetting to function)[/quote:27q5tenz]
    If I don’t use “nomodeset” I just get a back screen or lockup when using the Antergos USB I have to use that or I can not get to the greeter.

    On the install on my HDD, to get a runlevel 3 equiviant (systemd.unit=multi-user.target ) instead of “nomodeset” I can now use “nouveau.modeset=0” otherwise it locks up. So there is still some underlying issue.

    @“lots.0.logs”:27q5tenz said:

    One more thing, check in your UEFI settings err…program? (cant really call it BIOS anymore, but you know what I mean lol) and make sure your intel card is not disabled. [/quote:27q5tenz]
    Unfortunately, Lenovo uses a BIOS by InsydeH20 (3.05). It is such a limited and dumbed down BIOS. There are maybe 15 things which can set on all the screens and none of them are related to video. And there does not appear to be an advanced mode. I have found references to “hacked” BIOS replacements but I’m not ready to muck with that yet.

    I’ll get updated logs…

  • Are the order of the modules in mkinitcpio.conf important? I tried putting the i915 before the nouveau as well and I currently have that. It should be using the intel drivers by default and switch to nouveau as needed.

    In the lightdm x-0.log it ends with “Fatal server error: no screens found”. Googling…

  • I swapped the i915 and nouveau again to be the way you showed it, no different. On boot, it seems to hang at “running early hook [udev]”.

  • There isnt anything else helpful in the xorg logs. Grab the systemd journal. I think you can get it via chroot on the live cd which would make it easier to post here. Actually grab the last few boot cycles like this:

    sudo journalctl -b \> ~journal.last  
    sudo journalctl -b1 \> ~journal.2last  
    sudo journalctl -b2 \> ~journal.3last
    

    Then you can find them in “/home/antergos”

    Also what is the output of the following commands…(not using live cd)

    xrandr --listproviders
    
    glxinfo | grep "OpenGL renderer"
    
  • Dustin - I messed around last night trying various different things and made it worse and worse. At one point I even tried switching to proprietary drivers… I’m going to reinstall and get back to a clean state. I’ll open up a new thread if needed.

Posts 16Views 2212
Log in to reply