• Like 0

    Spotify login crash (KDE)


    Hi!
    Installed Spotify from the AUR today and when I start Spotify the loginscreen shows as normal but when I try to login the program crashes.

    Got the following output:

    (spotify:2740): Gtk-WARNING **: Kan inte hitta temamotorn i "module_path": "adwaita",
    Gtk-Message: (for origin information, set GTK_DEBUG): failed to retrieve property `gtk-primary-button-warps-slider' of type `gboolean' from rc file value "((GString*) 0x4a86560)" of type `gboolean'
    
    (spotify:2740): Gtk-WARNING **: Kan inte hitta temamotorn i "module_path": "adwaita",
    /usr/share/spotify/spotify: /usr/lib/libssl.so.1.0.0: no version information available (required by /usr/share/spotify/spotify)
    /usr/share/spotify/spotify: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /usr/share/spotify/spotify)
    /usr/share/spotify/spotify: /usr/lib/libcurl.so.3: no version information available (required by /usr/share/spotify/spotify)
    [1216/211002:ERROR:main_delegate.cc(752)] Could not load cef_extensions.pak
    /proc/self/exe: /usr/lib/libssl.so.1.0.0: no version information available (required by /proc/self/exe)
    /proc/self/exe: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /proc/self/exe)
    /proc/self/exe: /usr/lib/libcurl.so.3: no version information available (required by /proc/self/exe)
    [1216/211002:ERROR:main_delegate.cc(752)] Could not load cef_extensions.pak
    [1216/211006:ERROR:PlatformKeyboardEvent.cpp(94)] Not implemented reached in static bool blink::PlatformKeyboardEvent::currentCapsLockState()
    /usr/bin/spotify: rad 3:  2740 Segmenteringsfel        (minnesutskrift skapad) /usr/share/spotify/spotify "$@"
    

    Any Ideas??? :smiley:

  • Like 0

    Try installing missing libraries:
    sudo pacman -S openssl libgcrypt crypto++ curl

  • Like 0

    Installed the missing libraries but the player just vanishes on login.
    Thanks for replying. :-)

  • Like 0

    Damn it. What’s the error you’re getting now? The same one?

  • Like 0

    I think it’s the same. Installed Spotify from the AUR in Pamac.

    [[email protected] ~]$ sudo spotify
    [sudo] lösenord för lkarlsson: 
    /usr/share/spotify/spotify: /usr/lib/libssl.so.1.0.0: no version information available (required by /usr/share/spotify/spotify)
    /usr/share/spotify/spotify: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /usr/share/spotify/spotify)
    /usr/share/spotify/spotify: /usr/lib/libcurl.so.3: no version information available (required by /usr/share/spotify/spotify)
    /usr/share/spotify/spotify: /usr/lib/libssl.so.1.0.0: no version information available (required by /usr/share/spotify/spotify)
    /usr/share/spotify/spotify: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /usr/share/spotify/spotify)
    /usr/share/spotify/spotify: /usr/lib/libcurl.so.3: no version information available (required by /usr/share/spotify/spotify)
    [1218/121011:ERROR:main_delegate.cc(752)] Could not load cef_extensions.pak
    /proc/self/exe: /usr/lib/libssl.so.1.0.0: no version information available (required by /proc/self/exe)
    /proc/self/exe: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /proc/self/exe)
    /proc/self/exe: /usr/lib/libcurl.so.3: no version information available (required by /proc/self/exe)
    [1218/121011:ERROR:main_delegate.cc(752)] Could not load cef_extensions.pak
    [1218/121019:ERROR:PlatformKeyboardEvent.cpp(94)] Not implemented reached in static bool blink::PlatformKeyboardEvent::currentCapsLockState()
    /usr/bin/spotify: rad 3:  2155 Segmenteringsfel        (minnesutskrift skapad) /usr/share/spotify/spotify "$@"
    [[email protected] ~]$
    
  • Like 0

    By all means, do not use SUDO when starting applications! ;)

    Can you try it again without it?

    If it still does not work, can you list your /usr/lib contents? Well, maybe just libssl, this way: ls /usr/lib/libssl* -la

    Also, cef_extensions.pak is here:
    https://github.com/AtomicGameEngine/CEF3Binaries/blob/master/Linux/Resources/cef_extensions.pak

  • Like 0

    Hi!

    Here’s the terminal output:

    [[email protected] ~]$ spotify
    /usr/share/spotify/spotify: /usr/lib/libssl.so.1.0.0: no version information available (required by /usr/share/spotify/spotify)
    /usr/share/spotify/spotify: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /usr/share/spotify/spotify)
    /usr/share/spotify/spotify: /usr/lib/libcurl.so.3: no version information available (required by /usr/share/spotify/spotify)
    
    (spotify:1660): Gtk-WARNING **: Kan inte hitta temamotorn i "module_path": "adwaita",
    Gtk-Message: (for origin information, set GTK_DEBUG): failed to retrieve property `gtk-primary-button-warps-slider' of type `gboolean' from rc file value "((GString*) 0x38e4b60)" of type `gboolean'
    
    (spotify:1660): Gtk-WARNING **: Kan inte hitta temamotorn i "module_path": "adwaita",
    /usr/share/spotify/spotify: /usr/lib/libssl.so.1.0.0: no version information available (required by /usr/share/spotify/spotify)
    /usr/share/spotify/spotify: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /usr/share/spotify/spotify)
    /usr/share/spotify/spotify: /usr/lib/libcurl.so.3: no version information available (required by /usr/share/spotify/spotify)
    [1219/201627:ERROR:main_delegate.cc(752)] Could not load cef_extensions.pak
    /proc/self/exe: /usr/lib/libssl.so.1.0.0: no version information available (required by /proc/self/exe)
    /proc/self/exe: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /proc/self/exe)
    /proc/self/exe: /usr/lib/libcurl.so.3: no version information available (required by /proc/self/exe)
    [1219/201627:ERROR:main_delegate.cc(752)] Could not load cef_extensions.pak
    [1219/201633:ERROR:PlatformKeyboardEvent.cpp(94)] Not implemented reached in static bool blink::PlatformKeyboardEvent::currentCapsLockState()
    /usr/bin/spotify: rad 3:  1660 Segmenteringsfel        (minnesutskrift skapad) /usr/share/spotify/spotify "$@"
    [[email protected] ~]$ ls /usr/lib/libssl* -la
    -rwxr-xr-x 1 root root 384024 29 nov 21.10 /usr/lib/libssl3.so                                    
    lrwxrwxrwx 1 root root     15 27 sep 15.52 /usr/lib/libssl.so -> libssl.so.1.0.0                  
    -r-xr-xr-x 1 root root 512672 27 sep 15.52 /usr/lib/libssl.so.1.0.0                               
    [[email protected] ~]$                                               
    

    Downloaded the pak file. Not sure on how to install it though! :-)

  • Like 0

    @karlsson.linda.marie

    Hi,

    Downloaded the pak file. Not sure on how to install it though!

    I think it should go into /usr/share/spotify (but I’m at work and can’t check it, sorry).

  • Like 0

    Hey, out of curiosity, I’ve installed spotify here. Even though I also get some errors, it works. I get this:

    [email protected] [~]$ /usr/share/spotify/spotify: /usr/lib/libssl.so.1.0.0: no version information available (required by /usr/share/spotify/spotify)
    /usr/share/spotify/spotify: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /usr/share/spotify/spotify)
    /usr/share/spotify/spotify: /usr/lib/libcurl.so.3: no version information available (required by /usr/share/spotify/spotify)
    [1221/195202:ERROR:browser_main_loop.cc(231)] Running without the SUID sandbox! See https://chromium.googlesource.com/chromium/src/+/master/docs/linux_suid_sandbox_development.md for more information on developing with the sandbox on.
    /usr/share/spotify/spotify: /usr/lib/libssl.so.1.0.0: no version information available (required by /usr/share/spotify/spotify)
    /usr/share/spotify/spotify: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /usr/share/spotify/spotify)
    /usr/share/spotify/spotify: /usr/lib/libcurl.so.3: no version information available (required by /usr/share/spotify/spotify)
    [1221/195202:ERROR:main_delegate.cc(773)] Could not load cef_extensions.pak
    /proc/self/exe: /usr/lib/libssl.so.1.0.0: no version information available (required by /proc/self/exe)
    /proc/self/exe: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /proc/self/exe)
    /proc/self/exe: /usr/lib/libcurl.so.3: no version information available (required by /proc/self/exe)
    [1221/195202:ERROR:main_delegate.cc(773)] Could not load cef_extensions.pak
    

    So neither the lib errors nor the cef_extensions.pak are really a problem here. There must be something else… but no idea what, sorry.

  • Like 0

    Ok! Thanks so much for trying to help. Spotify webbplayer is ok to use but I thought there might be others that encounter the same error. :-)

  • Like 0

    For me, spotify ( V 1.0.45.186-1) works without problems on my Plasma 5 system.
    J.

  • Like 0

    im having the same problem on my openbox seems to be the same problem when logging into lastpass as well

  • Like 0

    Tried a Gnome install of Antergos from the same installer yesterday and Spotfy had the same issue there. Also the Simple firewall did not start after entering password. I Think it might be when you install with the previous install media. If you have installed with an earlier media and updates to current state it might work. That’s my theory! Haven’t tried the newest iso though.

  • Like 0

    F.Y.I. I had the same issue in Manjaro KDE today. Found this solution in their Forum. Haven’t tried it in Antergos though.

    spotify --username=yourspotifyusername --password=yourspotifypassword

    in terminal or change the command line in the program
    right click the menu button and choose “Edit applikation”. Find Spotify under Multimedia. In the Command input:
    spotify --username=yourspotifyusername --password=yourspotifypassword

    This did it for me in Manjaro. I think it will work in Antergos as well. :-)

kde86 crash15 login59 spotify7 Posts 14Views 901
Log in to reply