• Can't see partition table in Antergos installer


    I’m trying to install antergos alongside windows 10 on my Asus laptop. I’ve shrunk my C: drive so I have 50GB of allocated space and created a live usb drive I can boot into antergos from. When I start it up I connect to my wifi network and the installer updates. I can go through all the steps up to where I see the page where the partition table should be, but it’s not showing up. Anyone else have this issue? I’m unable to install because of it.

  • @Atlas I never experienced that, but are you sure you partitioned the hd correctly? Didn’t you erase some partition?
    The way you explained you must have 3 partitions now:

    • for booting win 10 (system reserved) [probably sda1]
    • installed win 10 [probably sda2]
    • empty one

    One thing you can do is open the terminal on Antergos live cd and type sudo gparted and then verify the partition table
    Or type blkid on terminal to see your partitions as well.

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • @fernandomaroto How does this look?

    0_1481862048185_disk partitions.png

  • @fernandomaroto

    [[email protected] ~]$ lsblk
    NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
    loop0 7:0 0 1.6G 1 loop /run/archiso/sfs/root-image
    sda 8:0 1 15.1G 0 disk
    └─sda1 8:1 1 15.1G 0 part /run/archiso/bootmnt

    when I run gparted it only shows me my usb drive. It’s like it’s not even detecting that there is a hard drive at all.

  • It seems the ISO is not detecting your disks.

    Are you booting in UEFI mode?

    Does sudo fdisk -l show anything at all?

  • @karasu I am booting in UEFI mode and fdisk is only showing my usb drive.

  • @Atlas

    WIN must be off “off” , fastboot deactivated .

    alt text

  • @Archrysler Already done.

  • @Atlas weird, hopefully @karasu (developer) is already trying to help you…
    I’m not sure if you can also disable the fast startup on the motherboard, can you take a look?

    Cheers!

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • @Atlas

    Have you tried another distro (not Arch based)? Ubuntu, for instance.

    Run it and open GParted, tell us if your drive is shown or not.

    To be honest, I have no idea whatsoever of what can be wrong here.

partition16 table2 installer32 Posts 10Views 473
Log in to reply