• cannot login to gnome xorg


    I can;t disable touchpad, so I followed this:
    https://forum.antergos.com/topic/4329/mouse-touchpad-disable-touchpad/16

    by running

    sudo pacman -S xf86-input-libinput
    sudo pacman -R xf86-input-synaptics
    sudo mv /etc/X11/xorg.conf.d/50-synaptics.conf ~/
    

    But now I cannot login to my gnome xorg.

    Then I copied 50-synaptics.conf to its original place, install synaptic and uninstall libinput, still cannot login to xorg.
    I still prefer using xorg, help.

    xorg log

    [   327.292] 
    X.Org X Server 1.18.4
    Release Date: 2016-07-19
    [   327.292] X Protocol Version 11, Revision 0
    [   327.292] Build Operating System: Linux 4.5.4-1-ARCH x86_64 
    [   327.292] Current Operating System: Linux pierot 4.8.13-1-ARCH #1 SMP PREEMPT Fri Dec 9 07:24:34 CET 2016 x86_64
    [   327.293] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=a46d319c-0941-4e3d-a0bb-3a5eaf47fb78 rw quiet resume=UUID=0c883b7b-ffe5-4dd6-aaa4-ba64a2c78c5e
    [   327.293] Build Date: 19 July 2016  05:54:24PM
    [   327.293]  
    [   327.293] Current version of pixman: 0.34.0
    [   327.293] 	Before reporting problems, check http://wiki.x.org
    	to make sure that you have the latest version.
    [   327.293] Markers: (--) probed, (**) from config file, (==) default setting,
    	(++) from command line, (!!) notice, (II) informational,
    	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    [   327.293] (==) Log file: "/home/hitman/.local/share/xorg/Xorg.0.log", Time: Thu Dec 15 19:05:43 2016
    [   327.294] (==) Using config file: "/etc/X11/xorg.conf"
    [   327.294] (==) Using config directory: "/etc/X11/xorg.conf.d"
    [   327.294] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
    [   327.294] (==) ServerLayout "Layout0"
    [   327.294] (**) |-->Screen "Screen0" (0)
    [   327.294] (**) |   |-->Monitor "Monitor0"
    [   327.294] (**) |   |-->Device "Device0"
    [   327.294] (**) |-->Input Device "Keyboard0"
    [   327.294] (**) |-->Input Device "Mouse0"
    [   327.294] (**) Option "DontZap" "false"
    [   327.294] (==) Automatically adding devices
    [   327.294] (==) Automatically enabling devices
    [   327.294] (==) Automatically adding GPU devices
    [   327.294] (==) Max clients allowed: 256, resource mask: 0x1fffff
    [   327.294] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
    [   327.294] 	Entry deleted from font path.
    [   327.294] (==) FontPath set to:
    	/usr/share/fonts/misc/,
    	/usr/share/fonts/TTF/,
    	/usr/share/fonts/OTF/,
    	/usr/share/fonts/100dpi/,
    	/usr/share/fonts/75dpi/
    [   327.294] (==) ModulePath set to "/usr/lib/xorg/modules"
    [   327.294] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
    [   327.294] (WW) Disabling Keyboard0
    [   327.294] (WW) Disabling Mouse0
    [   327.294] (II) Loader magic: 0x821d40
    [   327.294] (II) Module ABI versions:
    [   327.295] 	X.Org ANSI C Emulation: 0.4
    [   327.295] 	X.Org Video Driver: 20.0
    [   327.295] 	X.Org XInput driver : 22.1
    [   327.295] 	X.Org Server Extension : 9.0
    [   327.296] (++) using VT number 2
    
    [   327.296] (--) controlling tty is VT number 2, auto-enabling KeepTty
    [   327.300] (II) systemd-logind: took control of session /org/freedesktop/login1/session/c4
    [   327.300] (II) xfree86: Adding drm device (/dev/dri/card0)
    [   327.301] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 8 paused 0
    [   327.303] (--) PCI:*(0:0:2:0) 8086:1916:1043:11b0 rev 7, Mem @ 0xdd000000/16777216, 0xb0000000/268435456, I/O @ 0x0000f000/64, BIOS @ 0x????????/131072
    [   327.303] (--) PCI: (0:1:0:0) 10de:134d:1043:109e rev 162, Mem @ 0xde000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
    [   327.303] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
    [   327.303] (II) LoadModule: "glx"
    [   327.303] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
    [   327.305] (II) Module glx: vendor="X.Org Foundation"
    [   327.305] 	compiled for 1.18.4, module version = 1.0.0
    [   327.305] 	ABI class: X.Org Server Extension, version 9.0
    [   327.305] (==) AIGLX enabled
    [   327.305] (II) LoadModule: "nvidia"
    [   327.305] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
    [   327.306] (II) Module nvidia: vendor="NVIDIA Corporation"
    [   327.306] 	compiled for 4.0.2, module version = 1.0.0
    [   327.306] 	Module class: X.Org Video Driver
    [   327.306] (II) NVIDIA dlloader X Driver  375.20  Tue Nov 15 16:15:23 PST 2016
    [   327.306] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
    [   327.306] xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
    [   327.306] (EE) No devices detected.
    [   327.306] (EE) 
    Fatal server error:
    [   327.306] (EE) no screens found(EE) 
    [   327.306] (EE) 
    Please consult the The X.Org Foundation support 
    	 at http://wiki.x.org
     for help. 
    [   327.306] (EE) Please also check the log file at "/home/hitman/.local/share/xorg/Xorg.0.log" for additional information.
    [   327.306] (EE)
    

    EDIT
    I found out maybe it’s because im using bumblebee and installing nvidia-setting and it edited my xorg.conf
    I commented the nvidia section in xorg.conf and i can login. But I only have low resolution. I want to reset my xorg.conf but I dunna what nvidia-setting do with xorg.conf

    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 375.20  (buildmeister@swio-display-x86-rhel47-06)  Tue Nov 15 17:49:44 PST 2016
    
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "Unknown"
        HorizSync       28.0 - 33.0
        VertRefresh     43.0 - 72.0
        Option         "DPMS"
    EndSection
    
    #Section "Device"
    #    Identifier     "Device0"
    #    Driver         "nvidia"
    #    VendorName     "NVIDIA Corporation"
    #EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    
  • SOLVED but

    Solved by deleting xorg.conf but… is that ok? I mean… I was having xorg.conf before but now It’s gone. WIll it affect my system?
    I’ll mark as solved for now, … maybe

  • @Pegasusearl
    Using xorg.conf is deprecated and it shouldn’t be necessary in most setups.

    Cheers!

  • @Pegasusearl said in cannot login to gnome xorg:

    SOLVED but

    Solved by deleting xorg.conf but… is that ok? I mean… I was having xorg.conf before but now It’s gone. WIll it affect my system?

    In correctly configured Nvidia Optimus computer with Bumblebee installed xorg.conf simply doesn’t exist. It is a normal, correct situation.

    Bmb uses two its own files, which are xorg.conf analogs, but they are called differently and are situated in Bmb folder structure, not in /etc/X11 folder.

    nvidia-settings utility, if launched in a not correct way, destroys Bmb configuration - by creating xorg.conf, which fools Bmb. It’s a perfect Bmb killer.

    The utility works with single GPU Nvidia cards only. It doesn’t work (when launched in default mode) for hybrid Nvidia cards.

    More info about Bumblebee may be found in AnteWiki here.

  • @just @karasu I think we should develop a GUI for managing graphics configurations (some day in the future).

  • @lots.0.logs said in cannot login to gnome xorg:

    @just @karasu I think we should develop a GUI for managing graphics configurations (some day in the future).

    @karasu has already had a similar idea, almost a year ago. He has even started to develop nvidia-installer. It’s not easy, though possible.

    But covering all video cards, with all their existing modifications (Intel, AMD single GPU, AMD hybrid, Nvidia single GPU, Nvidia hybrid, BIOSes with and without hybrid cards control) is an ambitious goal. And a huge work.

    A GUI for all them would be as sophisticated as Cnchi itself, IMO.

  • @just Yeah I know, what I meant was that we should pick that work back up again at some point. But like you said, its crazy complicated to account for all the various setups. We will need help (mainly in the form of technical guidance as to what works, what doesn’t, etc from people like you who have the experience and/or have done the research) Of course coding help would also be welcomed should anyone be able to contribute on that level :wink:

  • @lots.0.logs

    [offtopic]

    Unfortunately, my work experience are 35 years on IBM mainframes, first under OS/360, later OS/390 and finally z/OS, mainly with Cobol 2. I’m rather unfamiliar with commonly used Linux scripts and languages. Can freely read and understand them, but my coding attempts are mostly a fiasco.

    An unexpected question. Is it easy to adapt Debian bash scripts for Arch?

    Many time ago, when I was on Debian, I wrote some articles, similar to our Bumblebee in AnteWiki, for KWheezy and SolydXK. SolydXK uses Device Driver Manager bash script to install the proper drivers on Intel, AMD single and hybrid, Nvidia simple and hybrid, and even on the Broadcom.

    I took part with testing and suggestions for the DDM part, which installs Bumblebee on Nvidia Optimus.

    It’s a stupid question, but maybe it could be easier to borrow the existing Debian code?

    Edit

    Yes, I know that usually it’s easier to write a new program than try to modify an old one :) .

    [/offtopic]

xorg22 gnome220 login72 Posts 8Views 685
Log in to reply