• SOLVED Virtualbox modules reload problem


    Hi there!

    I have a problem with my virtualbox: if I want to start it after fresh reboot, I need to install virtualbox-host-modules.

    Have installed the package, made a reboot of my PC…but I got the same error like in the window in the right side (see the screenshot). It means I have to install the package again…

    [[img:2p4ewfpi]http://s7.directupload.net/images/140322/temp/53pqkkks.png[/img:2p4ewfpi][/url:2p4ewfpi]

    For every good solution big thanks in advance.

    Cheers
    Freecaster]0

    [img:37xo6dtq]http://antergos.com/wp-content/uploads/2013/04/logo.gif[/img:37xo6dtq]

  • Hi there!

    I have a problem with my virtualbox: if I want to start it after fresh reboot, I need to install virtualbox-host-modules.

    Have installed the package, made a reboot of my PC…but I got the same error like in the window in the right side (see the screenshot). It means I have to install the package again…

    [[img:2p4ewfpi]http://s7.directupload.net/images/140322/temp/53pqkkks.png[/img:2p4ewfpi][/url:2p4ewfpi]

    For every good solution big thanks in advance.

    Cheers
    Freecaster]0

    [img:37xo6dtq]http://antergos.com/wp-content/uploads/2013/04/logo.gif[/img:37xo6dtq]

  • Hi,

    Install virtualbox-host-modules-dkms and enable it with:

    sudo systemctl enable dkms
    

    Then restart.

    Cheers!

  • @“lots.0.logs”:kvqefqr1 said:

    Hi,

    Install virtualbox-host-modules-dkms and enable it with:

    sudo systemctl enable dkms
    

    Then restart.

    Cheers![/quote:kvqefqr1]

    Have tried to install your recommended package:

      
    > [root @ frecaster freecaster] \# pacman-S virtualbox-host-modules-dkms   
    > Error: target not found: virtualbox-host-modules-dkms   
    > [root @ frecaster freecaster] \#
    

    Did you made a typo?

    [img:37xo6dtq]http://antergos.com/wp-content/uploads/2013/04/logo.gif[/img:37xo6dtq]

  • It’s [i:kedkgar6]virtualbox-host-dkms[/i:kedkgar6].

  • Yep, if you go into PacmanXG, then Package Management, and immediately start typing in ‘virtualbox’, you will see all the related packages for virtualbox available for install or uninstall.

    Hope this helps…

    In God's love,
    †MaNNa <{{{\>< …to You all thanks and glory Lord Yeshua!

    And Jesus prayed to The Father, "And this is the way to ete…

  • Hmm, it does not work.
    Have a look at my next screenshot. I have installed there everyhing what I need, but I am getting the error like in first screenshot with not installed host-modules. Kernel is: [b:j2v0xc24]3.13.6-1-ARCH[/b:j2v0xc24]
    [img:j2v0xc24]http://s14.directupload.net/images/140325/temp/uws78au7.png[/img:j2v0xc24][/url:j2v0xc24]

    [img:37xo6dtq]http://antergos.com/wp-content/uploads/2013/04/logo.gif[/img:37xo6dtq]

  • Hi,

    I use virtualbox in a regular basis with no problems. I do not use the dkms package.

    My installed packages:

      
    virtualbox  
    virtualbox-host-modules  
    
    

    Check that you have a file called virtualbox.conf in /etc/modules-load.d/ with this contents

      
    vboxdrv  
    vboxnetadp  
    vboxnetflt  
    vboxpci  
    
    

    Hope this helps. Cheers!

  • @“karasu”:y3kmh6rp said:

    Hi,

    I use virtualbox in a regular basis with no problems. I do not use the dkms package.

    My installed packages:

      
    > virtualbox  
    > virtualbox-host-modules  
    > 
    

    Check that you have a file called virtualbox.conf in /etc/modules-load.d/ with this contents

      
    > vboxdrv  
    > vboxnetadp  
    > vboxnetflt  
    > vboxpci  
    > 
    

    Hope this helps. Cheers![/quote:y3kmh6rp]

    Hi!

    Have looked under /etc/modules-load.d/ and saw, there was not virtualbox.conf. I have created it, and pasted there your content. After reboot, my virtualbox does not wanted to load virtualbox machine. It was the same error like in the first screenshot.

    [img:37xo6dtq]http://antergos.com/wp-content/uploads/2013/04/logo.gif[/img:37xo6dtq]

  • Hi,

    That’s strange… please, try to force loading the virtualbox module. In a terminal, type this:

    sudo modprobe vboxdrv
    

    and try again…

  • @“karasu”:208318fq said:

    Hi,

    That’s strange… please, try to force loading the virtualbox module. In a terminal, type this:

    sudo modprobe vboxdrv
    

    and try again…[/quote:208318fq]

    I forgot to tell in the problem decribing, that I need always this command when I want to use virtualbox-machine.
    I will try now with newest Kernel 3.13.7 which has been released for antergos in the last days.
    I will report, if it’s don’t need [b:208318fq]modprobe vboxdrv[/b:208318fq] anymore.

    [img:37xo6dtq]http://antergos.com/wp-content/uploads/2013/04/logo.gif[/img:37xo6dtq]

  • Really strange.

    Have made a system-upgrade, got newest linux-kernel…but the problem stayed.

    I need the command [b:2hr2r8lk]modprobe vboxdrv[/b:2hr2r8lk] for every start of vbox-machine.

    [b:2hr2r8lk]New[/b:2hr2r8lk] screenshot:

    [img:2hr2r8lk]http://s14.directupload.net/images/140325/temp/qxvzujxm.png[/img:2hr2r8lk][/url:2hr2r8lk]

    [img:37xo6dtq]http://antergos.com/wp-content/uploads/2013/04/logo.gif[/img:37xo6dtq]

  • Hi,

    OK, what I wanted to know was if modprobe vboxdrv was working or not. So as it is working, your problem is that is not loaded on boot (sorry, I didn’t get you in the first place).

    Well… as it’s said here: [url:14kv3d59]https://wiki.archlinux.org/index.php/kernel_modules[/url:14kv3d59] adding that conf file to /etc/modules-load.d/ should be enough. Something is preventing loading the module on boot (or so it seems).

    Could you boot your computer and post here the results of running a dmesg command? Also run modprobe vboxdrv and run dmesg again and post it here.

    This way we’ll see if it’s really trying to load the module on boot (and if it fails, why).

  • Could you boot your computer and post here the results of running a dmesg command? Also run modprobe vboxdrv and run dmesg again and post it here.

    This way we’ll see if it’s really trying to load the module on boot (and if it fails, why).

    I don’t understand it, I should boot my PC and post running a dmesg command? How do it? Never made it under debian unstable (my old system)…

    [img:37xo6dtq]http://antergos.com/wp-content/uploads/2013/04/logo.gif[/img:37xo6dtq]

  • Sorry I wasn’t more specific.

    Boot your computer, go to a terminal (CTRL+ALT+F2) and run there:

    dmesg \> dmesg1.txt
    

    Then load the vboxdrv module

    sudo modprobe vboxdrv
    

    And finally run the dmesg command again:

    dmesg \> dmesg2.txt
    

    Post here dmesg1.txt and dmesg2.txt

    Cheers!

  • @“karasu”:3hc5wue6 said:

    Sorry I wasn’t more specific.

    Boot your computer, go to a terminal (CTRL+ALT+F2) and run there:

    dmesg \> dmesg1.txt
    

    Then load the vboxdrv module

    sudo modprobe vboxdrv
    

    And finally run the dmesg command again:

    dmesg \> dmesg2.txt
    

    Post here dmesg1.txt and dmesg2.txt

    Cheers![/quote:3hc5wue6]

    Done!

    Text nr 1: [http://pastebin.com/P0SUvEAA][0]">[http://pastebin.com/P0SUvEAA][1]

    Text nr.2: [http://pastebin.com/fGbc5zsv][0]">[http://pastebin.com/fGbc5zsv][2]

    Cheers
    Freecaster

    [0]: <a href=
    [1]: http://pastebin.com/P0SUvEAA
    [2]: http://pastebin.com/fGbc5zsv

    [img:37xo6dtq]http://antergos.com/wp-content/uploads/2013/04/logo.gif[/img:37xo6dtq]

  • Hi,

    As I feared, there’s no problem loading vboxdrv, so I think your system is not loading modules-load.d conf files.

    Check that systemd-modules-load is enabled and ok:

    sudo systemctl status systemd-modules-load
    

    To enable it:

    sudo systemctl enable systemd-modules-load
    

    To restart it:

    sudo systemctl restart systemd-modules-load
    

    I’m writing this commands from my memory… hope there are no mistakes

  • Hey Karasu!

    Your commands worked without breaks:

    [[email protected] freecaster]\# sudo systemctl status systemd-modules-load  
    systemd-modules-load.service - Load Kernel Modules  
    Loaded: loaded (/usr/lib/systemd/system/systemd-modules-load.service; static)  
    Active: active (exited) since Mi 2014-03-26 14:13:11 CET; 2min 19s ago  
    Docs: man:systemd-modules-load.service(8)  
    man:modules-load.d(5)  
    Process: 99 ExecStart=/usr/lib/systemd/systemd-modules-load (code=exited, status=0/SUCCESS)  
    Main PID: 99 (code=exited, status=0/SUCCESS)  
    CGroup: /system.slice/systemd-modules-load.service  
      
    Mär 26 14:13:11 frecaster systemd[1]: Started Load Kernel Modules.  
    Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.  
    [[email protected] freecaster]\# sudo systemctl enable systemd-modules-load  
    The unit files have no [Install] section. They are not meant to be enabled  
    using systemctl.  
    Possible reasons for having this kind of units are:  
    1) A unit may be statically enabled by being symlinked from another unit's  
    .wants/ or .requires/ directory.  
    2) A unit's purpose may be to act as a helper for some other unit which has  
    a requirement dependency on it.  
    3) A unit may be started when needed via activation (socket, path, timer,  
    D-Bus, udev, scripted systemctl call, ...).  
    [[email protected] freecaster]\# sudo systemctl restart systemd-modules-load  
    [[email protected] freecaster]\#   
    
    

    I reboot now my PC and will see how virtualbox box works.

    Cheers
    freecaster

    [img:37xo6dtq]http://antergos.com/wp-content/uploads/2013/04/logo.gif[/img:37xo6dtq]

  • OK, don’t panic !

    Have rebooted my PC, but Virtualbox does not start without [b:3bb0nade]“modprobe vboxdrv[/b:3bb0nade]” again

    [img:37xo6dtq]http://antergos.com/wp-content/uploads/2013/04/logo.gif[/img:37xo6dtq]

  • Edit your /etc/modules-load.d/modules.conf file, and put these in:

    vboxdrv
    vboxnetflt
    vboxnetadp
    vboxpci

    That should do it for you…

    Ref: [url:y8crpnf0]https://wiki.archlinux.org/index.php/VirtualBox#Load_the_VirtualBox_kernel_modules[/url:y8crpnf0]

    In God's love,
    †MaNNa <{{{\>< …to You all thanks and glory Lord Yeshua!

    And Jesus prayed to The Father, "And this is the way to ete…

Posts 34Views 8219
Log in to reply