• Bluetooth scan and pairing not working


    Hello to everyone, i’ve buyed a bluetooth mouse, and when i try to pair it with my laptop (first time i’m using bluetooth in Antergos) the Gnome settings stays forever in “Scanning for devices” (picture 1)

    I’ve tried to do this in the terminal with this results:

    [[email protected] ~]$ hcitool scan
    Scanning ...
    [[email protected] ~]$ 
    

    And this

    [[email protected] ~]$ sudo bluetoothctl
    [sudo] password for borja: 
    [NEW] Controller 44:1C:A8:E4:DA:0C Borja-HP-G4 [default]
    [bluetooth]# scan on
    Discovery started
    [bluetooth]# scan on
    Failed to start discovery: org.bluez.Error.InProgress
    [bluetooth]# scan
    Missing on/off argument
    [bluetooth]# pair 30:23:00:08:01:A5
    Device 30:23:00:08:01:A5 not available
    [bluetooth]# 
    

    Any ideas?? i can give you more information if need

    Never Settle

  • Edit1: the adapter is the

    bcm43142A0
    

    according to the

    lsusb
    

    Never Settle

  • @geek_person You may need to completely un-pair devices before you can re-pair them, especially if the device still thinks it’s paired to its true love and waiting to be recognized.

    When using the command line, right after you get connected, also try trust and pair the devices (one of those may include the other implicitly).

  • I never paired them becouse the bluetooth appears but it doesn’t scan or pair or anything is like the system sees it but cannot use the bluetooth interface, i’ve tried to flash de firmware, to insert the hcm file in the firmware folder do the modprobes and nothing, well yes, the bluetooth dissapears Y_Y

    Never Settle

  • @geek_person Are you sure the devices are unpaired from everything else? They won’t necessarily come up into the available-to-pair mode if they are paired to something else (or if they’re paired to your Antergos comp with incorrect connection keys).

  • No. Im putting the mouse un pairing mode. Also. My android device is not recognized

    Never Settle

bluetooth22 pairing1 scan1 Posts 6Views 427
Log in to reply