• No Wifi in Live USB on 2013 Macbook Air?


    I am trying to dual boot Antergos with Mac OS on my Macbook Air, but when I boot into the live usb there is no Wifi. I have searched the web trying to figure it out, thus far to no avail. Any tips? Thanks!

  • @perin.lionshead

    Hi,

    Which wifi chip do you have? Run with the live USB and run lspci ,lsusb and dmesg | grep wlan in a terminal, please. (put the results here).

  • 8.069172 iwlwifi 0000:01.0 wlol: renamed from wlan0

  • OK, your interface is detected by iwlwifi and is renamed from wlan0 to wlol.
    Please, run lspci and sudo iwconfig

  • Okay, I ran that, but I got “no wireless extensions found” back.

  • Hi,

    I suppose there is no ethernet port… you could try save the broadcom-wl package in another usb and install it.

  • Yeah, no ethernet…it’s quite irksome, has always caused problems. I guess I will try downloading the driver and installing manually then! Thank you!

  • Okay, now I’m trying to install from tar.gz file from Arch site. Can’t figure out how to build it. Any tips? Thank you!

  • You have to download the xz file:

    http://repo.antergos.com/antergos/x86_64/broadcom-wl-6.30.223.271-6-x86_64.pkg.tar.xz

    Then, to install it:
    sudo pacman -U broadcom-wl-6.30.223.271-6-x86_64.pkg.tar.xz

  • Okay, making progress…it installed just fine. Does it typically require a reboot to load though? Still no wifi appearing in network settings!

  • After installing:

    rmmod b43
    rmmod ssb
    modprobe wl
    depmod -a
    
  • I ran it. After first step I got “ERROR: Module b43 is not currently loaded”

  • That’s ok. rmmod is used to remove undesired modules (incompatible with wl). If you don’t have them loaded you will get this error, is perfectly normal, you can go on.

  • Yeah, unfortunately it’s all errors after that as well. And still no wifi! Thank you for your help, but I’m beginning to wonder if the air is just too much trouble! Thanks!

live usb9 wifi86 macbook air2 Posts 14Views 1387
Log in to reply