• EMMC Flash Install Hangs on Antergos


    This is more a note to myself than anything else as I have found myself banging my head on the wall for hours trying to figure out why I keep getting a hang on install with an eMMC flash card.

    Problem:
    On install Antergos hangs if you select the default install settings. It will always hang on:
    Configuring Hardware for Install 100%
    This problem also seems to be as a result of the installer mounting the eMMC card by default. Not sure why.

    Solution:
    Manually set the partition tables and mount points. This in turn will have the partition manager tell Antergos that the eMMC drive is mounted and will be unmounted to continue. After that it SHOULD install without any further hangs.

    Unless of course I’m just throwing wrenches at a user error problem that should do it :P

  • There are laptops that use this type of storage to install the OS there, and then a bigger device to store data (usually a mechanical drive). Long time ago users complained about the impossibility to install Antergos in such devices. Maybe fixing this made eMMC installation a default by mistake.

    When you selected “Automatic” installation, couldn’t you select in which drive did you want to install it?

  • Yes I selected the main storage partition (31gb) where all other drives show up as 0gb. I think it has something to do with the way the eMMC is naturally setup. I recall there being 4 partitions and only one showing actual storage. All others read as 0.

  • Yes I selected the main storage partition (31gb) where all other drives show up as 0gb.

    That’s odd. Sadly, we do not have any laptop of this kind to do some tests. When I have the time (don’t hold your breath) I’ll try to fix automatic installation in these cases (at least, show other drives’ sizes correctly).

    Thanks for pointing it out!

  • No problem it’s not the biggest issue I just posted it as a reminder in case I forget to do manual partitioning on eMMC flash.

  • Only for the competition ;)
    Is this solved? here is a user with may the same issue?
    https://forum.antergos.com/topic/6862/stuck-on-getting-ready-your-disk-s-on-only-uefi-netbook/9

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    how to add system logs

  • Is this solved?

    No.

    here is a user with may the same issue?

    Yes.

    I’m really sorry but as I said, I do not have any hardware to test this on.

  • @karasu but works fine with manual partition…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    how to add system logs

  • I know old thread is old but I needed this again for another install and saw the convo.

    @joekamprad the partitioning you mentioned in the other thread >>> |250MB for /boot (ext4)| | 25GB for / (ext4) | |5GB for swap (swap) extended partition| <<< Is pretty similar to my own manual partitioning. In fact I’d say that works very well for the install.

    @karasu if you really wanted hardware to test eMMC flash storage they are reallly cheap.
    Newegg search does wonders (saw one for 50ish bucks right now):
    https://www.newegg.com/Product/ProductList.aspx?Submit=ENE&DEPA=0&Order=BESTMATCH&Description=emmc&ignorear=0&N=100008345&isNodeId=1
    My hardware is the Liva X but that’s a bit pricier. HTPC and all.

    Manual partitioning on eMMC does work on Antergos last I checked. Hope it helps!

hardware9 emmc4 Posts 9Views 669
Log in to reply