• pacman not syncrhonised with antergos mirrors ?


    Hi,
    This is my first post in this forum.
    I have installed antergos on my PC 2 months ago and I like it… :-)
    Since nearly 2 weeks , I got strange message when updating antergos (see attached copy).
    Seems that some elements on my disk are newer than the mirrors :

    • antergos-mirrorlist
    • antergos-wallpaper
    • dropbox
    • lightdm-webkit2-greeter
    • numix-*
    • pamac

    I have no idea to where the problem come from…
    Any help welcome… :-)
    0_1481403230154_Capture d’écran_2016-12-10_21-22-33.png

  • @Patrick

    https://wiki.archlinux.org/index.php/Reflector

    $ sudo pacman -Syyuu
    

    Autodidacta en la VIDA …y en Linux, también.

  • @judd Thanks for your fast answer ! :-)

    I used Reflector (after a mirrorlist backup) as indicated in the archwiki page and then started pacman.
    I got a lot of 404 errors for each files, seems that all the mirrors where not at the same state…
    Finally pacman found good mirrors and downgraded the concerned apps.
    It make me feel trouble to see a downgrade to previous version. I was hoping that pacman would just say my actuals versions were ok, without downgrade.
    My trouble is particularly from dropbox which downgraded from 11.4.22-1 to 9.4.49-1 while the archlinux repository indicate version 15.4.22-1 !!! I am lost…
    Can anyone tell me which version of dropbox he is currently running on his up-to-date antergos ?
    Thanks

  • @Patrick said in pacman not syncrhonised with antergos mirrors ?:

    Mi problema es sobre todo a partir de la cual Dropbox rebajado de 11.4.22-1 a 9.4.49-1 mientras que el repositorio de archlinux indican versión 15.4.22-1 estoy perdido …
    ¿Puede alguien decirme qué versión de Dropbox que se está ejecutando actualmente en su hasta -to-antergos fecha?

    $ sudo pacman -Ss dropbox
    
    community/perl-net-dropbox-api 1.9-3
        Net::Dropbox::API - Perl dropbox API interface
    community/python-dropbox 7.1.1-1
        Python SDK for Dropbox Core APIs
    community/python2-dropbox 7.1.1-1
        Python SDK for Dropbox Core APIs
    community/rclone 1.34-1
        Sync files to and from Google Drive, S3, Swift, Cloudfiles, Dropbox and
        Google Cloud Storage
    archlinuxfr/dropbox 9.4.49-1
        A free service that lets you bring your photos, docs, and videos anywhere
        and share them easily.
    archlinuxfr/nautilus-dropbox 2015.10.28-1
        Dropbox for Linux - Nautilus extension
    
    

    Autodidacta en la VIDA …y en Linux, también.

  • @judd Thanks a lot.
    I have now the same version number than yours. I believe my problem is now solved.
    Thanks again for you help.
    Whish you a very nice day :-)

  • Hi,

    Something must be wrong. In my computer, when I issue a pacman -Ss dropbox I get:

    antergos/dropbox 15.4.22-1 (cloud-storage) [instal·lat]
        A free service that lets you bring your photos, docs, and videos anywhere and share them easily.
    antergos/nemo-dropbox 3.2.0-1
        Dropbox for Linux - Nemo extension
    community/perl-net-dropbox-api 1.9-3
        Net::Dropbox::API - Perl dropbox API interface
    community/python-dropbox 7.1.1-1
        Python SDK for Dropbox Core APIs
    community/python2-dropbox 7.1.1-1
        Python SDK for Dropbox Core APIs
    community/rclone 1.34-1
        Sync files to and from Google Drive, S3, Swift, Cloudfiles, Dropbox and Google Cloud Storage
    

    Latest dropbox version is 15.4.22-1

    You can always check our packages here

  • @karasu Hi Karasu, thanks for your message this helped me a lot !
    @judd sorry judd but it seems we have the same mirror-list problem… but the solution is here ! :-)

    I found this post in the forum : solved-mirrorlist
    I understand that Reflector work only on archlinux mirrors, not antergos and my incriminated progs were on antergos.
    For the antergos mirrors I found this command :

    sudo rankmirrors -n 0 /etc/pacman.d/antergos-mirrorlist > /tmp/antergos-mirrorlist && sudo cp /tmp/antergos-mirrorlist /etc/pacman.d
    

    (please note there is a backslash (\) error in the original post)
    Then after starting pacman I got this :

    sudo pacman -Syyu
    :: Synchronisation des bases de données de paquets...
     antergos                 133,5 KiB   417K/s 00:00 [######################] 100%
     core                     122,6 KiB   543K/s 00:00 [######################] 100%
     extra                   1747,0 KiB  1218K/s 00:01 [######################] 100%
     community                  3,7 MiB  1551K/s 00:02 [######################] 100%
     multilib                 182,1 KiB   929K/s 00:00 [######################] 100%
     archlinuxfr               14,6 KiB   310K/s 00:00 [######################] 100%
    :: Début de la mise à jour complète du système...
    résolution des dépendances...
    recherche des conflits entre paquets...
    
    Paquets (18) antergos-mirrorlist-20161107-2  antergos-wallpapers-0.7-1
                 dropbox-15.4.22-1  filezilla-3.23.0.2-1  icu-58.2-1
                 libfilezilla-0.9.0-1  lightdm-webkit2-greeter-2.1.6-1
                 linux-4.8.13-1  linux-lts-4.4.38-1  numix-frost-themes-3.6.6-1
                 numix-icon-theme-1:0.r1890-1  numix-icon-theme-square-1:0.r83_7-1
                 openjpeg2-2.1.2-2  pacman-mirrorlist-20161211-1  pamac-4.1.6-2
                 python-setuptools-1:30.4.0-1  python2-setuptools-1:30.4.0-1
                 xfce4-whiskermenu-plugin-1.6.2-1
    
    Taille totale du téléchargement :  183,72 MiB
    Taille totale installée :         406,54 MiB
    Taille de mise à jour nette :      -0,83 MiB
    
    :: Procéder à l’installation ? [O/n]
    

    Seems the correct versions of progs are now found.

    Thanks for your help :-)

  • @Patrick said in pacman not syncrhonised with antergos mirrors ?:

    @judd sorry judd but it seems we have the same mirror-list problem… but the solution is here !

    No, No, do not ask me why, although in theory it would have to be the same …, because it is not, because all that post answers with Arch and now being in Antergos gives me something else, like Karasu with pacman -Ss dropbox:flushed:

    No, no me preguntes porque, aunque en teoria tendría que ser lo mismo…, pues no lo es, porque todo ese post lo conteste con Arch y ahora estando en Antergos me da otra cosa, como a Karasu con pacman -Ss dropbox

    No entiendo que pasa ?

    Autodidacta en la VIDA …y en Linux, también.

  • @judd said in pacman not syncrhonised with antergos mirrors ?:

    pacman -Ss dropbox

    Here it is :

    pacman -Ss dropbox
    antergos/dropbox 15.4.22-1 (cloud-storage) [installé]
        A free service that lets you bring your photos, docs, and videos anywhere
        and share them easily.
    antergos/nemo-dropbox 3.2.0-1
        Dropbox for Linux - Nemo extension
    community/perl-net-dropbox-api 1.9-3
        Net::Dropbox::API - Perl dropbox API interface
    community/python-dropbox 7.1.1-1
        Python SDK for Dropbox Core APIs
    community/python2-dropbox 7.1.1-1
        Python SDK for Dropbox Core APIs
    community/rclone 1.34-1
        Sync files to and from Google Drive, S3, Swift, Cloudfiles, Dropbox and
        Google Cloud Storage
    archlinuxfr/dropbox 9.4.49-1 [installé: 15.4.22-1]
        A free service that lets you bring your photos, docs, and videos anywhere
        and share them easily.
    archlinuxfr/nautilus-dropbox 2015.10.28-1
        Dropbox for Linux - Nautilus extension
    
  • @judd If you’re using Arch, have you added the Antegos repository to pacman.conf? If not, it’s only logical that you don’t see our packages.

    In Spanish ;)
    @judd Si estás usando Arch, has añadido el repositorio de Antergos en tu pacman.conf? Si no lo has hecho, es lógico que no veas nuestros paquetes.

    Cheers! / Saludos!

  • @karasu said in pacman not syncrhonised with antergos mirrors ?:

    @judd Si estás usando Arch, has añadido el repositorio de Antergos en tu pacman.conf? Si no lo has hecho, es lógico que no veas nuestros paquetes.

    Claro sí, otra ves prometo contestar antergos con laptop de antergos :hand: :)

    Autodidacta en la VIDA …y en Linux, también.

mirrors9 syncrhonised1 pacman77 Posts 11Views 1007
Log in to reply