• Like 0

    Configure Logitech K400 Plus keyboard


    I have a Logitech K400 Plus wireless keyboard which works great by default. However, I want to configure it so that the trackpad doesn’t click on double taps. I don’t know how to configure the keyboard at all. I tried changing the xorg configuration but it didn’t change anything.

    How do I know if this device is managed by Synaptic or xinput? How should I go about configuring this keyboard to change the double tap sensitivity?

  • Like 0

    @dmp1ce Install Solaar from the aur and re-pair your keyboard in the menu it works for me.

  • Like 0

    I installed Solaar and re-paired my keyboard, but the xinput properties didn’t change. I’m still not sure how to change the double tap sensitivity. Right now I see the following from xinput.

    $ xinput list-props 10
    Device 'Logitech K400 Plus':
    	Device Enabled (153):	1
    	Coordinate Transformation Matrix (155):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
    	Device Accel Profile (480):	0
    	Device Accel Constant Deceleration (481):	1.000000
    	Device Accel Adaptive Deceleration (482):	1.000000
    	Device Accel Velocity Scaling (483):	10.000000
    	Device Product ID (273):	1133, 16461
    	Device Node (274):	"/dev/input/event16"
    	Evdev Axis Inversion (484):	0, 0
    	Evdev Axes Swap (486):	0
    	Axis Labels (487):	"Rel X" (163), "Rel Y" (164), "Rel Horiz Wheel" (523), "Rel Dial" (524), "Rel Vert Wheel" (479)
    	Button Labels (488):	"Button Left" (156), "Button Middle" (157), "Button Right" (158), "Button Wheel Up" (159), "Button Wheel Down" (160), "Button Horiz Wheel Left" (161), "Button Horiz Wheel Right" (162), "Button Side" (474), "Button Extra" (475), "Button Forward" (476), "Button Back" (477), "Button Task" (478), "Button Unknown" (473), "Button Unknown" (473), "Button Unknown" (473), "Button Unknown" (473), "Button Unknown" (473), "Button Unknown" (473), "Button Unknown" (473), "Button Unknown" (473), "Button Unknown" (473), "Button Unknown" (473), "Button Unknown" (473), "Button Unknown" (473)
    	Evdev Scrolling Distance (489):	1, 1, 1
    	Evdev Middle Button Emulation (490):	0
    	Evdev Middle Button Timeout (491):	50
    	Evdev Third Button Emulation (492):	0
    	Evdev Third Button Emulation Timeout (493):	1000
    	Evdev Third Button Emulation Button (494):	3
    	Evdev Third Button Emulation Threshold (495):	20
    	Evdev Wheel Emulation (496):	0
    	Evdev Wheel Emulation Axes (497):	0, 0, 4, 5
    	Evdev Wheel Emulation Inertia (498):	10
    	Evdev Wheel Emulation Timeout (499):	200
    	Evdev Wheel Emulation Button (500):	4
    	Evdev Drag Lock Buttons (501):	0
    

    Which properties effect the double tap click functionality?

  • Like 0

    @dmp1ce Mouse and Touchpad in the Control Panel Menu there is an adjustment there. I use Cinnamon but it might be different for other desktops.

  • Like 0

    @meekee In “Mouse and Touchpad” I only see “Primary Button” “Mouse Speed” and “Natural Scrolling” settings. I don’t see anything about double tapping features.

    I’m using Gnome.

  • Like 0

    @dmp1ce I am using Cinnamon in the Menu there is the option of tap to click on or off, it must be a different setup in Gnome. I have never used Gnome I don’t know what to suggest otherwise, sorry Mate but in all the time I have used a K400 keyboard I have never had any problems with any desktop or any Distro it just works. Someone in the Gnome Desktop Section can probably help or do like I do Google it I will always find help there If it’s not available on the forum.

  • Like 0

    After some searching I found out that I can press “FN+Right Click” which will disable taps on this keyboard. That works for me although I’m still not sure how to disable or adjust taps with the OS under Gnome.

  • Like 0

    @dmp1ce Great stuff I knew you could do it!

k4001 configure3 logitech3 plus2 Posts 8Views 375
Log in to reply